summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics/terminus-font
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-oe/recipes-graphics/terminus-font
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-oe/recipes-graphics/terminus-font')
-rw-r--r--meta-oe/recipes-graphics/terminus-font/terminus-font_4.38.bb45
1 files changed, 45 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/terminus-font/terminus-font_4.38.bb b/meta-oe/recipes-graphics/terminus-font/terminus-font_4.38.bb
new file mode 100644
index 000000000..a6bef1002
--- /dev/null
+++ b/meta-oe/recipes-graphics/terminus-font/terminus-font_4.38.bb
@@ -0,0 +1,45 @@
1SUMMARY = "Terminus fonts packages (console and X11)"
2DESCRIPTION = "Terminus Font is a clean, fixed width bitmap font, designed for \
3 long (8 and more hours per day) work with computers."
4HOMEPAGE = "http://terminus-font.sourceforge.net/"
5AUTHOR = "Dimitar Zhekov"
6SECTION = "fonts"
7
8LICENSE = "OFL-1.1"
9LIC_FILES_CHKSUM = "file://OFL.TXT;md5=9cadb26f4c5c005618c5ae74f041ec54"
10
11DEPENDS = "perl-native-runtime gzip-native"
12
13SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BPN}-${PV}.tar.gz"
14SRC_URI[md5sum] = "a8e792fe6e84c86ed2b6ed3e2a12ba66"
15SRC_URI[sha256sum] = "f6f4876a4dabe6a37c270c20bb9e141e38fb50e0bba200e1b9d0470e5eed97b7"
16
17inherit allarch fontcache
18
19PACKAGECONFIG ?= "${@base_contains('DISTRO_FEATURES', 'x11', 'x11', '', d)}"
20PACKAGECONFIG[x11] = ""
21
22# Don't use font cache mecanism for console packages
23FONT_PACKAGES = "${@base_contains('PACKAGECONFIG', 'x11', '${PN}-pcf', '', d)}"
24
25# Hand made configure script. Don't need oe_runconf
26do_configure() {
27 chmod +x ${S}/configure
28 ${S}/configure --prefix=${prefix} \
29 --psfdir=${datadir}/consolefonts \
30 --acmdir=${datadir}/consoletrans \
31 --x11dir=${datadir}/fonts/terminus
32}
33
34do_compile() {
35 oe_runmake DESTDIR=${D} psf txt ${@base_contains('PACKAGECONFIG', 'x11', 'pcf', '', d)}
36}
37
38do_install() {
39 oe_runmake DESTDIR=${D} install-psf install-acm ${@base_contains('PACKAGECONFIG', 'x11', 'install-pcf', '', d)}
40}
41
42PACKAGES += "${PN}-consolefonts ${PN}-consoletrans ${PN}-pcf"
43FILES_${PN}-consolefonts = "${datadir}/consolefonts"
44FILES_${PN}-consoletrans = "${datadir}/consoletrans"
45FILES_${PN}-pcf = "${datadir}/fonts/terminus"