diff options
author | Koen Kooi <koen@dominion.thruhere.net> | 2011-03-17 21:41:22 +0100 |
---|---|---|
committer | Koen Kooi <koen@dominion.thruhere.net> | 2011-03-17 21:41:22 +0100 |
commit | c58cc7d3796dcee6e93885c835ed04cb566abeb2 (patch) | |
tree | 3eea4d4ef6a4ef79e0f4e025d7012c1a5cc38835 /meta-oe/recipes-graphics/pango | |
parent | eec6ab97f712e06eb52c9f7c99e19ffab3ce9d74 (diff) | |
download | meta-openembedded-c58cc7d3796dcee6e93885c835ed04cb566abeb2.tar.gz |
move layer into meta-oe in preparation for future splits
As per TSC decision
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-graphics/pango')
-rw-r--r-- | meta-oe/recipes-graphics/pango/pango-1.28.3/no-tests.patch | 10 | ||||
-rw-r--r-- | meta-oe/recipes-graphics/pango/pango.inc | 53 | ||||
-rw-r--r-- | meta-oe/recipes-graphics/pango/pango/no-tests.patch | 15 | ||||
-rw-r--r-- | meta-oe/recipes-graphics/pango/pango/pkgconfig_fixes.patch | 79 | ||||
-rw-r--r-- | meta-oe/recipes-graphics/pango/pango_1.28.3.bb | 9 | ||||
-rw-r--r-- | meta-oe/recipes-graphics/pango/pangomm_2.26.0.bb | 22 |
6 files changed, 188 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/pango/pango-1.28.3/no-tests.patch b/meta-oe/recipes-graphics/pango/pango-1.28.3/no-tests.patch new file mode 100644 index 000000000..dafcb20c3 --- /dev/null +++ b/meta-oe/recipes-graphics/pango/pango-1.28.3/no-tests.patch | |||
@@ -0,0 +1,10 @@ | |||
1 | --- /tmp/Makefile.am 2007-03-01 13:29:37.000000000 +0100 | ||
2 | +++ pango-1.16.0/Makefile.am 2007-03-01 13:29:52.545251000 +0100 | ||
3 | @@ -1,6 +1,6 @@ | ||
4 | ## Process this file with automake to create Makefile.in. | ||
5 | |||
6 | -SUBDIRS= pango modules pango-view examples docs tools tests | ||
7 | +SUBDIRS= pango modules pango-view examples docs tools | ||
8 | |||
9 | EXTRA_DIST = \ | ||
10 | autogen.sh \ | ||
diff --git a/meta-oe/recipes-graphics/pango/pango.inc b/meta-oe/recipes-graphics/pango/pango.inc new file mode 100644 index 000000000..b09869135 --- /dev/null +++ b/meta-oe/recipes-graphics/pango/pango.inc | |||
@@ -0,0 +1,53 @@ | |||
1 | DESCRIPTION = "The goal of the Pango project is to provide an \ | ||
2 | Open Source framework for the layout and rendering of \ | ||
3 | internationalized text." | ||
4 | LICENSE = "LGPL" | ||
5 | |||
6 | inherit gnome | ||
7 | EXTRA_AUTORECONF = "" | ||
8 | |||
9 | SECTION = "x11/libs" | ||
10 | |||
11 | DEPENDS = "glib-2.0 fontconfig freetype zlib virtual/libiconv virtual/libx11 libxft gtk-doc cairo" | ||
12 | |||
13 | DEPENDS_virtclass-native = "glib-2.0-native cairo-native" | ||
14 | BBCLASSEXTEND = "native" | ||
15 | |||
16 | PACKAGES_DYNAMIC = "pango-module-*" | ||
17 | PACKAGES_DYNAMIC_virtclass-native = "" | ||
18 | |||
19 | RRECOMMENDS_${PN} = "pango-module-basic-x pango-module-basic-fc" | ||
20 | |||
21 | INC_PR = "r1" | ||
22 | |||
23 | # seems to go wrong with default cflags | ||
24 | FULL_OPTIMIZATION_arm = "-O2" | ||
25 | |||
26 | SRC_URI += "file://no-tests.patch \ | ||
27 | " | ||
28 | |||
29 | EXTRA_OECONF += "--disable-glibtest \ | ||
30 | --enable-explicit-deps=no \ | ||
31 | --disable-debug" | ||
32 | |||
33 | LEAD_SONAME = "libpango-1.0*" | ||
34 | LIBV = "1.6.0" | ||
35 | |||
36 | FILES_${PN} = "/etc ${bindir}/* ${libdir}/libpango*.so.*" | ||
37 | FILES_${PN}-dbg += "${libdir}/pango/${LIBV}/modules/.debug" | ||
38 | FILES_${PN}-dev += "${libdir}/pango/${LIBV}/modules/*.la" | ||
39 | |||
40 | postinst_prologue() { | ||
41 | if [ "x$D" != "x" ]; then | ||
42 | exit 1 | ||
43 | fi | ||
44 | |||
45 | } | ||
46 | |||
47 | python populate_packages_prepend () { | ||
48 | prologue = bb.data.getVar("postinst_prologue", d, 1) | ||
49 | |||
50 | modules_root = bb.data.expand('${libdir}/pango/${LIBV}/modules', d) | ||
51 | |||
52 | do_split_packages(d, modules_root, '^pango-(.*)\.so$', 'pango-module-%s', 'Pango module %s', prologue + 'pango-querymodules > /etc/pango/pango.modules') | ||
53 | } | ||
diff --git a/meta-oe/recipes-graphics/pango/pango/no-tests.patch b/meta-oe/recipes-graphics/pango/pango/no-tests.patch new file mode 100644 index 000000000..b38212612 --- /dev/null +++ b/meta-oe/recipes-graphics/pango/pango/no-tests.patch | |||
@@ -0,0 +1,15 @@ | |||
1 | |||
2 | # | ||
3 | # Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher | ||
4 | # | ||
5 | |||
6 | --- pango-1.2.5/Makefile.am~no-tests 2003-01-30 22:43:47.000000000 +0100 | ||
7 | +++ pango-1.2.5/Makefile.am 2004-03-11 11:31:25.000000000 +0100 | ||
8 | @@ -1,6 +1,6 @@ | ||
9 | ## Process this file with automake to create Makefile.in. | ||
10 | |||
11 | -SUBDIRS= pango modules examples docs tools tests | ||
12 | +SUBDIRS= pango modules examples docs tools | ||
13 | |||
14 | EXTRA_DIST = \ | ||
15 | pango.pc.in \ | ||
diff --git a/meta-oe/recipes-graphics/pango/pango/pkgconfig_fixes.patch b/meta-oe/recipes-graphics/pango/pango/pkgconfig_fixes.patch new file mode 100644 index 000000000..f021591a9 --- /dev/null +++ b/meta-oe/recipes-graphics/pango/pango/pkgconfig_fixes.patch | |||
@@ -0,0 +1,79 @@ | |||
1 | Index: pango-1.18.1/configure.in | ||
2 | =================================================================== | ||
3 | --- pango-1.18.1.orig/configure.in 2007-08-28 00:29:54.000000000 +0000 | ||
4 | +++ pango-1.18.1/configure.in 2007-11-12 19:21:22.000000000 +0000 | ||
5 | @@ -226,13 +226,9 @@ | ||
6 | # | ||
7 | # Checks for FreeType | ||
8 | # | ||
9 | - FREETYPE_LIBS= | ||
10 | - FREETYPE_CFLAGS= | ||
11 | - AC_PATH_PROG(FREETYPE_CONFIG, freetype-config, no) | ||
12 | - if test "x$FREETYPE_CONFIG" != "xno" ; then | ||
13 | - FREETYPE_CFLAGS=`$FREETYPE_CONFIG --cflags` | ||
14 | - FREETYPE_LIBS=`$FREETYPE_CONFIG --libs` | ||
15 | + PKG_CHECK_MODULES(FREETYPE, freetype2 >= 1.0.1, have_freetype=true, AC_MSG_RESULT([no])) | ||
16 | |||
17 | + if $have_freetype ; then | ||
18 | pango_save_ldflags=$LDFLAGS | ||
19 | LDFLAGS="$LDFLAGS $FREETYPE_LIBS" | ||
20 | AC_CHECK_LIB(freetype, FT_Get_Next_Char, have_freetype=true, :) | ||
21 | Index: pango-1.18.1/pangoft2-uninstalled.pc.in | ||
22 | =================================================================== | ||
23 | --- pango-1.18.1.orig/pangoft2-uninstalled.pc.in 2007-07-05 21:30:28.000000000 +0000 | ||
24 | +++ pango-1.18.1/pangoft2-uninstalled.pc.in 2007-11-12 19:23:44.000000000 +0000 | ||
25 | @@ -1,7 +1,7 @@ | ||
26 | Name: Pango FT2 Uninstalled | ||
27 | Description: Freetype 2.0 font support for Pango, Not Installed | ||
28 | Version: @VERSION@ | ||
29 | -Requires: pango | ||
30 | -Libs: ${pc_top_builddir}/${pcfiledir}/pango/libpangoft2-@PANGO_API_VERSION@.la @FREETYPE_LIBS@ | ||
31 | -Cflags: -I${pc_top_builddir}/${pcfiledir}/@srcdir@ @FREETYPE_CFLAGS@ | ||
32 | +Requires: pango freetype2 | ||
33 | +Libs: ${pc_top_builddir}/${pcfiledir}/pango/libpangoft2-@PANGO_API_VERSION@.la | ||
34 | +Cflags: -I${pc_top_builddir}/${pcfiledir}/@srcdir@ | ||
35 | |||
36 | Index: pango-1.18.1/pangoft2.pc.in | ||
37 | =================================================================== | ||
38 | --- pango-1.18.1.orig/pangoft2.pc.in 2007-07-05 21:30:28.000000000 +0000 | ||
39 | +++ pango-1.18.1/pangoft2.pc.in 2007-11-12 19:27:05.000000000 +0000 | ||
40 | @@ -6,7 +6,7 @@ | ||
41 | Name: Pango FT2 | ||
42 | Description: Freetype 2.0 font support for Pango | ||
43 | Version: @VERSION@ | ||
44 | -Requires: pango | ||
45 | -Libs: -L${libdir} -lpangoft2-@PANGO_API_VERSION@ @PKGCONFIG_FREETYPE_LIBS@ | ||
46 | -Cflags: -I${includedir}/pango-1.0 @FONTCONFIG_CFLAGS@ @FREETYPE_CFLAGS@ | ||
47 | +Requires: pango freetype2 fontconfig | ||
48 | +Libs: -L${libdir} -lpangoft2-@PANGO_API_VERSION@ | ||
49 | +Cflags: -I${includedir}/pango-1.0 | ||
50 | |||
51 | Index: pango-1.18.1/pangoxft-uninstalled.pc.in | ||
52 | =================================================================== | ||
53 | --- pango-1.18.1.orig/pangoxft-uninstalled.pc.in 2007-07-05 21:30:28.000000000 +0000 | ||
54 | +++ pango-1.18.1/pangoxft-uninstalled.pc.in 2007-11-12 19:22:24.000000000 +0000 | ||
55 | @@ -1,7 +1,7 @@ | ||
56 | Name: Pango Xft Uninstalled | ||
57 | Description: Xft font support for Pango, Not Installed | ||
58 | Version: @VERSION@ | ||
59 | -Requires: pango | ||
60 | -Libs: ${pc_top_builddir}/${pcfiledir}/pango/libpangoxft-@PANGO_API_VERSION@.la @XFT_LIBS@ | ||
61 | -Cflags: -I${pc_top_builddir}/${pcfiledir}/@srcdir@ @X_CFLAGS@ @FREETYPE_CFLAGS@ | ||
62 | +Requires: pango xft | ||
63 | +Libs: ${pc_top_builddir}/${pcfiledir}/pango/libpangoxft-@PANGO_API_VERSION@.la | ||
64 | +Cflags: -I${pc_top_builddir}/${pcfiledir}/@srcdir@ @X_CFLAGS@ | ||
65 | |||
66 | Index: pango-1.18.1/pangoxft.pc.in | ||
67 | =================================================================== | ||
68 | --- pango-1.18.1.orig/pangoxft.pc.in 2007-07-05 21:30:28.000000000 +0000 | ||
69 | +++ pango-1.18.1/pangoxft.pc.in 2007-11-12 19:21:57.000000000 +0000 | ||
70 | @@ -6,6 +6,6 @@ | ||
71 | Name: Pango Xft | ||
72 | Description: Xft font support for Pango | ||
73 | Version: @VERSION@ | ||
74 | -Requires: pango pangoft2 | ||
75 | -Libs: -L${libdir} -lpangoxft-@PANGO_API_VERSION@ @PKGCONFIG_XFT_LIBS@ | ||
76 | -Cflags: -I${includedir}/pango-1.0 @XFT_CFLAGS@ | ||
77 | +Requires: pango pangoft2 xft | ||
78 | +Libs: -L${libdir} -lpangoxft-@PANGO_API_VERSION@ | ||
79 | +Cflags: -I${includedir}/pango-1.0 | ||
diff --git a/meta-oe/recipes-graphics/pango/pango_1.28.3.bb b/meta-oe/recipes-graphics/pango/pango_1.28.3.bb new file mode 100644 index 000000000..4c875bf33 --- /dev/null +++ b/meta-oe/recipes-graphics/pango/pango_1.28.3.bb | |||
@@ -0,0 +1,9 @@ | |||
1 | require pango.inc | ||
2 | |||
3 | LIC_FILES_CHKSUM = "file://COPYING;md5=3bf50002aefd002f49e7bb854063f7e7" | ||
4 | |||
5 | SRC_URI[archive.md5sum] = "caa74baea47e7e16bc73c89f9089d522" | ||
6 | SRC_URI[archive.sha256sum] = "5e278bc9430cc7bb00270f183360d262c5006b51248e8b537ea904573f200632" | ||
7 | |||
8 | PR = "${INC_PR}.0" | ||
9 | |||
diff --git a/meta-oe/recipes-graphics/pango/pangomm_2.26.0.bb b/meta-oe/recipes-graphics/pango/pangomm_2.26.0.bb new file mode 100644 index 000000000..ecf2dd1ee --- /dev/null +++ b/meta-oe/recipes-graphics/pango/pangomm_2.26.0.bb | |||
@@ -0,0 +1,22 @@ | |||
1 | DESCRIPTION = "C++ bindings for the pango library." | ||
2 | SECTION = "libs" | ||
3 | PRIORITY = "optional" | ||
4 | LICENSE = "LGPL" | ||
5 | DEPENDS = "mm-common cairomm glibmm" | ||
6 | SHRT_VER = "${@bb.data.getVar('PV',d,1).split('.')[0]}.${@bb.data.getVar('PV',d,1).split('.')[1]}" | ||
7 | PR = "r1" | ||
8 | |||
9 | SRC_URI = "ftp://ftp.gnome.org/pub/GNOME/sources/pangomm/${SHRT_VER}/pangomm-${PV}.tar.bz2" | ||
10 | |||
11 | inherit autotools flow-lossage | ||
12 | |||
13 | FILES_${PN} = "${libdir}/lib*.so.*" | ||
14 | FILES_${PN}-dev += "${libdir}/*/include/" | ||
15 | |||
16 | EXTRA_OECONF = " --disable-documentation " | ||
17 | |||
18 | AUTOTOOLS_STAGE_PKGCONFIG = "1" | ||
19 | |||
20 | |||
21 | SRC_URI[md5sum] = "37f54dc8e6cb73ed923b22f313352156" | ||
22 | SRC_URI[sha256sum] = "bf26ebe42c12c81e5c32ceca80ff226a01c8d80d4db2a4cc3463d5bf241b095e" | ||