diff options
author | Andreas Müller <schnitzeltony@googlemail.com> | 2015-10-08 08:23:03 +0200 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2015-10-13 12:28:17 +0200 |
commit | 91cfb371adaeb0f581fa87cd6e8165d264f1e0bc (patch) | |
tree | 8ccae70c36139837aa2e4023528ba9b464a19684 /meta-oe/recipes-graphics/openbox | |
parent | dafdc09cf56d602a011d27433a8012b1e2028d20 (diff) | |
download | meta-openembedded-91cfb371adaeb0f581fa87cd6e8165d264f1e0bc.tar.gz |
openbox: fix sporadic race on compile
| make: creating data/xsession/openbox-gnome-session
| make: creating data/xsession/openbox-session
| make: creating data/xsession/openbox-kde-session
| make: creating data/autostart/openbox-autostart
| make: creating doc/openbox.1
| make: creating data/autostart/autostart
| make: creating doc/openbox-session.1
| make: creating doc/openbox-gnome-session.1
| make: creating doc/openbox-kde-session.1
| make: creating doc/obxprop.1
| mkdir: cannot create directory './data/autostart': File exists
| Makefile:4329: recipe for target 'data/autostart/autostart' failed
Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-graphics/openbox')
-rw-r--r-- | meta-oe/recipes-graphics/openbox/files/0001-Makefile.am-avoid-race-when-creating-autostart-direc.patch | 54 | ||||
-rw-r--r-- | meta-oe/recipes-graphics/openbox/openbox_3.6.1.bb | 5 |
2 files changed, 58 insertions, 1 deletions
diff --git a/meta-oe/recipes-graphics/openbox/files/0001-Makefile.am-avoid-race-when-creating-autostart-direc.patch b/meta-oe/recipes-graphics/openbox/files/0001-Makefile.am-avoid-race-when-creating-autostart-direc.patch new file mode 100644 index 000000000..2762e1c21 --- /dev/null +++ b/meta-oe/recipes-graphics/openbox/files/0001-Makefile.am-avoid-race-when-creating-autostart-direc.patch | |||
@@ -0,0 +1,54 @@ | |||
1 | From 6bbde84a2197c97e49d9e64118a979728209e436 Mon Sep 17 00:00:00 2001 | ||
2 | From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@googlemail.com> | ||
3 | Date: Wed, 23 Sep 2015 23:21:42 +0200 | ||
4 | Subject: [PATCH] Makefile.am: avoid race when creating autostart directories | ||
5 | MIME-Version: 1.0 | ||
6 | Content-Type: text/plain; charset=UTF-8 | ||
7 | Content-Transfer-Encoding: 8bit | ||
8 | |||
9 | fixes: | ||
10 | |||
11 | | make: creating data/xsession/openbox-gnome-session | ||
12 | | make: creating data/xsession/openbox-session | ||
13 | | make: creating data/xsession/openbox-kde-session | ||
14 | | make: creating data/autostart/openbox-autostart | ||
15 | | make: creating doc/openbox.1 | ||
16 | | make: creating data/autostart/autostart | ||
17 | | make: creating doc/openbox-session.1 | ||
18 | | make: creating doc/openbox-gnome-session.1 | ||
19 | | make: creating doc/openbox-kde-session.1 | ||
20 | | make: creating doc/obxprop.1 | ||
21 | | mkdir: cannot create directory './data/autostart': File exists | ||
22 | | Makefile:4329: recipe for target 'data/autostart/autostart' failed | ||
23 | |||
24 | Upstream-Status: Pending | ||
25 | |||
26 | Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> | ||
27 | --- | ||
28 | Makefile.am | 6 ++---- | ||
29 | 1 file changed, 2 insertions(+), 4 deletions(-) | ||
30 | |||
31 | diff --git a/Makefile.am b/Makefile.am | ||
32 | index f25bf8e..306e77d 100644 | ||
33 | --- a/Makefile.am | ||
34 | +++ b/Makefile.am | ||
35 | @@ -505,14 +505,12 @@ edit = $(SED) \ | ||
36 | |||
37 | data/autostart/autostart: $(top_srcdir)/data/autostart/autostart.in Makefile | ||
38 | @echo make: creating $@ | ||
39 | - @test -d $(shell dirname $(top_builddir)/$@) || \ | ||
40 | - mkdir $(shell dirname $(top_builddir)/$@) | ||
41 | + mkdir -p $(shell dirname $(top_builddir)/$@) | ||
42 | @$(edit) $< >$(top_builddir)/$@ | ||
43 | |||
44 | data/autostart/openbox-autostart: $(top_srcdir)/data/autostart/openbox-autostart.in Makefile | ||
45 | @echo make: creating $@ | ||
46 | - @test -d $(shell dirname $(top_builddir)/$@) || \ | ||
47 | - mkdir $(shell dirname $(top_builddir)/$@) | ||
48 | + mkdir -p $(shell dirname $(top_builddir)/$@) | ||
49 | @$(edit) $< >$(top_builddir)/$@ | ||
50 | |||
51 | %.desktop: %.desktop.in Makefile | ||
52 | -- | ||
53 | 2.1.0 | ||
54 | |||
diff --git a/meta-oe/recipes-graphics/openbox/openbox_3.6.1.bb b/meta-oe/recipes-graphics/openbox/openbox_3.6.1.bb index 44afed2d3..9f42177c2 100644 --- a/meta-oe/recipes-graphics/openbox/openbox_3.6.1.bb +++ b/meta-oe/recipes-graphics/openbox/openbox_3.6.1.bb | |||
@@ -4,7 +4,10 @@ DEPENDS = "glib-2.0 pango libxml2 virtual/libx11 libcroco librsvg gdk-pixbuf" | |||
4 | LICENSE = "GPLv2+" | 4 | LICENSE = "GPLv2+" |
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f" | 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f" |
6 | 6 | ||
7 | SRC_URI = "http://icculus.org/openbox/releases/openbox-${PV}.tar.gz" | 7 | SRC_URI = " \ |
8 | http://icculus.org/openbox/releases/openbox-${PV}.tar.gz \ | ||
9 | file://0001-Makefile.am-avoid-race-when-creating-autostart-direc.patch \ | ||
10 | " | ||
8 | 11 | ||
9 | SRC_URI[md5sum] = "b72794996c6a3ad94634727b95f9d204" | 12 | SRC_URI[md5sum] = "b72794996c6a3ad94634727b95f9d204" |
10 | SRC_URI[sha256sum] = "8b4ac0760018c77c0044fab06a4f0c510ba87eae934d9983b10878483bde7ef7" | 13 | SRC_URI[sha256sum] = "8b4ac0760018c77c0044fab06a4f0c510ba87eae934d9983b10878483bde7ef7" |