summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics/openbox
diff options
context:
space:
mode:
authorMario Domenech Goulart <mario@ossystems.com.br>2012-12-03 16:03:23 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2012-12-04 10:46:09 +0100
commit3becce8504033dfac7c497fa12675f873a5df9e0 (patch)
treee1bb4ab00f3ca251c14d0852fe6e61a9b6d93cbb /meta-oe/recipes-graphics/openbox
parente7e3fd797b46a85ffc03cc7c4b2267d686476f93 (diff)
downloadmeta-openembedded-3becce8504033dfac7c497fa12675f873a5df9e0.tar.gz
openbox: separate package for configuration files (openbox-config)
Change-Id: I528392100854fb73c2a14973fd1bfa9c94e836a7 Signed-off-by: Mario Domenech Goulart <mario@ossystems.com.br> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-graphics/openbox')
-rw-r--r--meta-oe/recipes-graphics/openbox/openbox_3.5.0.bb8
1 files changed, 6 insertions, 2 deletions
diff --git a/meta-oe/recipes-graphics/openbox/openbox_3.5.0.bb b/meta-oe/recipes-graphics/openbox/openbox_3.5.0.bb
index 3f6d7673c..a2c5a66bb 100644
--- a/meta-oe/recipes-graphics/openbox/openbox_3.5.0.bb
+++ b/meta-oe/recipes-graphics/openbox/openbox_3.5.0.bb
@@ -9,6 +9,8 @@ SRC_URI = "http://icculus.org/openbox/releases/openbox-${PV}.tar.gz"
9SRC_URI[md5sum] = "00441b53cf14c03566c8e82643544ff9" 9SRC_URI[md5sum] = "00441b53cf14c03566c8e82643544ff9"
10SRC_URI[sha256sum] = "6fa90016530b3aa6102e254079461977439398531fb23e7ec076ff2c140fea0a" 10SRC_URI[sha256sum] = "6fa90016530b3aa6102e254079461977439398531fb23e7ec076ff2c140fea0a"
11 11
12PR = "1"
13
12inherit autotools gettext update-alternatives 14inherit autotools gettext update-alternatives
13 15
14ALTERNATIVE_PATH = "${bindir}/openbox" 16ALTERNATIVE_PATH = "${bindir}/openbox"
@@ -18,7 +20,7 @@ ALTERNATIVE_PRIORITY = "10"
18 20
19EXTRA_OECONF += "--with-plugins=none" 21EXTRA_OECONF += "--with-plugins=none"
20 22
21PACKAGES =+ "${PN}-core ${PN}-lxde ${PN}-gnome" 23PACKAGES =+ "${PN}-core ${PN}-lxde ${PN}-gnome ${PN}-config"
22 24
23PACKAGES_DYNAMIC += "^${PN}-theme-.*" 25PACKAGES_DYNAMIC += "^${PN}-theme-.*"
24 26
@@ -28,7 +30,7 @@ python populate_packages_prepend() {
28 do_split_packages(d, theme_dir, '(.*)', theme_name, '${PN} theme for %s', extra_depends='', allow_dirs=True) 30 do_split_packages(d, theme_dir, '(.*)', theme_name, '${PN} theme for %s', extra_depends='', allow_dirs=True)
29} 31}
30 32
31RDEPENDS_${PN} += "${PN}-core" 33RDEPENDS_${PN} += "${PN}-core ${PN}-config"
32FILES_${PN}-core = "${bindir}/openbox ${libdir}/*${SOLIBS}" 34FILES_${PN}-core = "${bindir}/openbox ${libdir}/*${SOLIBS}"
33 35
34FILES_${PN}-lxde += "${datadir}/lxde/ \ 36FILES_${PN}-lxde += "${datadir}/lxde/ \
@@ -37,3 +39,5 @@ FILES_${PN}-lxde += "${datadir}/lxde/ \
37 ${datadir}/icons" 39 ${datadir}/icons"
38 40
39FILES_${PN}-gnome += "${datadir}/gnome/" 41FILES_${PN}-gnome += "${datadir}/gnome/"
42
43FILES_${PN}-config += "${sysconfdir}"