diff options
author | Khem Raj <raj.khem@gmail.com> | 2017-03-30 13:14:40 -0700 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2017-04-05 19:28:29 +0200 |
commit | b17f499131ea75b1a5396314dc66acaa234460b3 (patch) | |
tree | 13699d11c84d0ba617c545de1fc4b2a19c5108dc /meta-oe/recipes-graphics/lxdm | |
parent | 386f2eaddad00a6e76e38ebb2c9d824c9540b7e4 (diff) | |
download | meta-openembedded-b17f499131ea75b1a5396314dc66acaa234460b3.tar.gz |
lxdm: Find libexecinfo if its on platform
fixes build with musl
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-graphics/lxdm')
-rw-r--r-- | meta-oe/recipes-graphics/lxdm/lxdm/0001-check-for-libexecinfo-providing-backtrace-APIs.patch | 36 | ||||
-rw-r--r-- | meta-oe/recipes-graphics/lxdm/lxdm_0.5.3.bb | 16 |
2 files changed, 45 insertions, 7 deletions
diff --git a/meta-oe/recipes-graphics/lxdm/lxdm/0001-check-for-libexecinfo-providing-backtrace-APIs.patch b/meta-oe/recipes-graphics/lxdm/lxdm/0001-check-for-libexecinfo-providing-backtrace-APIs.patch new file mode 100644 index 000000000..f9fd4970f --- /dev/null +++ b/meta-oe/recipes-graphics/lxdm/lxdm/0001-check-for-libexecinfo-providing-backtrace-APIs.patch | |||
@@ -0,0 +1,36 @@ | |||
1 | From 1d2425febf2020e38db70188df582acc9f37b136 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Thu, 30 Mar 2017 13:01:33 -0700 | ||
4 | Subject: [PATCH] check for libexecinfo providing backtrace() APIs | ||
5 | |||
6 | on musl it depends on external library to provide backtrace APIs | ||
7 | unlike glibc where it is bundled in | ||
8 | |||
9 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
10 | --- | ||
11 | configure.ac | 2 ++ | ||
12 | 1 file changed, 2 insertions(+) | ||
13 | |||
14 | diff --git a/configure.ac b/configure.ac | ||
15 | index aa3291c..b15f65d 100644 | ||
16 | --- a/configure.ac | ||
17 | +++ b/configure.ac | ||
18 | @@ -15,6 +15,7 @@ AM_PROG_CC_C_O | ||
19 | |||
20 | # Checks for libraries. | ||
21 | AC_CHECK_LIB([crypt], [crypt]) | ||
22 | +AC_CHECK_LIB([execinfo], [backtrace]) | ||
23 | |||
24 | # Check for PAM support | ||
25 | AC_ARG_WITH(pam, AC_HELP_STRING([--with-pam],[Use PAM for authentication]), | ||
26 | @@ -33,6 +34,7 @@ AM_CONDITIONAL(HAVE_PAM, [test -n "$USE_PAM" -a "x$USE_PAM" != xno ]) | ||
27 | # Checks for header files. | ||
28 | AC_PATH_X | ||
29 | AC_CHECK_HEADERS([shadow.h stdlib.h string.h unistd.h utmpx.h]) | ||
30 | +AC_CHECK_HEADERS([execinfo.h]) | ||
31 | |||
32 | # Checks for typedefs, structures, and compiler characteristics. | ||
33 | AC_TYPE_PID_T | ||
34 | -- | ||
35 | 2.12.1 | ||
36 | |||
diff --git a/meta-oe/recipes-graphics/lxdm/lxdm_0.5.3.bb b/meta-oe/recipes-graphics/lxdm/lxdm_0.5.3.bb index 407129dde..c98c3a132 100644 --- a/meta-oe/recipes-graphics/lxdm/lxdm_0.5.3.bb +++ b/meta-oe/recipes-graphics/lxdm/lxdm_0.5.3.bb | |||
@@ -2,13 +2,13 @@ SUMMARY = "LXDM is the lightweight display manager" | |||
2 | HOMEPAGE = "http://blog.lxde.org/?p=531" | 2 | HOMEPAGE = "http://blog.lxde.org/?p=531" |
3 | LICENSE = "GPLv3" | 3 | LICENSE = "GPLv3" |
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" | 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" |
5 | SRC_URI = " \ | 5 | SRC_URI = "${SOURCEFORGE_MIRROR}/project/${BPN}/${BPN}%20${PV}/${BPN}-${PV}.tar.xz \ |
6 | ${SOURCEFORGE_MIRROR}/project/${BPN}/${BPN}%20${PV}/${BPN}-${PV}.tar.xz \ | 6 | file://lxdm.conf \ |
7 | file://lxdm.conf \ | 7 | ${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'file://lxdm-pam file://lxdm-pam-debug', '', d)} \ |
8 | ${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'file://lxdm-pam file://lxdm-pam-debug', '', d)} \ | 8 | ${@bb.utils.contains("DISTRO_TYPE", "debug", "", "file://0001-lxdm.conf.in-blacklist-root-for-release-images.patch",d)} \ |
9 | ${@bb.utils.contains("DISTRO_TYPE", "debug", "", "file://0001-lxdm.conf.in-blacklist-root-for-release-images.patch",d)} \ | 9 | file://0002-let-autotools-create-lxdm.conf.patch \ |
10 | file://0002-let-autotools-create-lxdm.conf.patch \ | 10 | file://0001-check-for-libexecinfo-providing-backtrace-APIs.patch \ |
11 | " | 11 | " |
12 | SRC_URI[md5sum] = "061caae432634e6db38bbdc84bc6ffa0" | 12 | SRC_URI[md5sum] = "061caae432634e6db38bbdc84bc6ffa0" |
13 | SRC_URI[sha256sum] = "4891efee81c72a400cc6703e40aa76f3f3853833d048b72ec805da0f93567f2f" | 13 | SRC_URI[sha256sum] = "4891efee81c72a400cc6703e40aa76f3f3853833d048b72ec805da0f93567f2f" |
14 | 14 | ||
@@ -16,6 +16,7 @@ PE = "1" | |||
16 | 16 | ||
17 | DEPENDS = "virtual/libintl intltool-native cairo dbus gdk-pixbuf glib-2.0 gtk+ virtual/libx11 libxcb pango iso-codes" | 17 | DEPENDS = "virtual/libintl intltool-native cairo dbus gdk-pixbuf glib-2.0 gtk+ virtual/libx11 libxcb pango iso-codes" |
18 | DEPENDS += "${@bb.utils.contains("DISTRO_FEATURES", "systemd", "", "consolekit", d)}" | 18 | DEPENDS += "${@bb.utils.contains("DISTRO_FEATURES", "systemd", "", "consolekit", d)}" |
19 | DEPENDS_append_libc-musl = " libexecinfo" | ||
19 | 20 | ||
20 | # combine oe-core way with angstrom DISTRO_TYPE | 21 | # combine oe-core way with angstrom DISTRO_TYPE |
21 | DISTRO_TYPE ?= "${@bb.utils.contains("IMAGE_FEATURES", "debug-tweaks", "debug", "",d)}" | 22 | DISTRO_TYPE ?= "${@bb.utils.contains("IMAGE_FEATURES", "debug-tweaks", "debug", "",d)}" |
@@ -25,6 +26,7 @@ inherit autotools pkgconfig gettext systemd distro_features_check | |||
25 | REQUIRED_DISTRO_FEATURES = "x11" | 26 | REQUIRED_DISTRO_FEATURES = "x11" |
26 | 27 | ||
27 | CFLAGS_append = " -fno-builtin-fork -fno-builtin-memset -fno-builtin-strstr " | 28 | CFLAGS_append = " -fno-builtin-fork -fno-builtin-memset -fno-builtin-strstr " |
29 | LDFLAGS_append_libc-musl = " -lexecinfo" | ||
28 | 30 | ||
29 | EXTRA_OECONF += "--enable-gtk3=no --enable-password=yes --with-x -with-xconn=xcb \ | 31 | EXTRA_OECONF += "--enable-gtk3=no --enable-password=yes --with-x -with-xconn=xcb \ |
30 | ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '--with-systemdsystemunitdir=${systemd_unitdir}/system/ --disable-consolekit', '--without-systemdsystemunitdir', d)} \ | 32 | ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '--with-systemdsystemunitdir=${systemd_unitdir}/system/ --disable-consolekit', '--without-systemdsystemunitdir', d)} \ |