diff options
author | Ross Burton <ross.burton@intel.com> | 2016-04-22 20:48:49 +0100 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2016-04-28 10:38:38 +0200 |
commit | 21f10c11f39020f9502d741c774a12d1aeb39499 (patch) | |
tree | fdc66c039950da89d82b6b7405ebfc50cbba693a /meta-oe/recipes-graphics/lxdm | |
parent | 723b55f5c1f7df21dbcfa7cb2dcaecb10d886041 (diff) | |
download | meta-openembedded-21f10c11f39020f9502d741c774a12d1aeb39499.tar.gz |
meta-oe: use bb.utils.contains() instead of base_contains()
base_contains() is a compatibility wrapper and may warn in the future, so
replace all instances with bb.utils.contains().
Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-graphics/lxdm')
-rw-r--r-- | meta-oe/recipes-graphics/lxdm/lxdm_0.5.3.bb | 18 |
1 files changed, 9 insertions, 9 deletions
diff --git a/meta-oe/recipes-graphics/lxdm/lxdm_0.5.3.bb b/meta-oe/recipes-graphics/lxdm/lxdm_0.5.3.bb index 227709251..407129dde 100644 --- a/meta-oe/recipes-graphics/lxdm/lxdm_0.5.3.bb +++ b/meta-oe/recipes-graphics/lxdm/lxdm_0.5.3.bb | |||
@@ -5,8 +5,8 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" | |||
5 | SRC_URI = " \ | 5 | SRC_URI = " \ |
6 | ${SOURCEFORGE_MIRROR}/project/${BPN}/${BPN}%20${PV}/${BPN}-${PV}.tar.xz \ | 6 | ${SOURCEFORGE_MIRROR}/project/${BPN}/${BPN}%20${PV}/${BPN}-${PV}.tar.xz \ |
7 | file://lxdm.conf \ | 7 | file://lxdm.conf \ |
8 | ${@base_contains('DISTRO_FEATURES', 'pam', 'file://lxdm-pam file://lxdm-pam-debug', '', d)} \ | 8 | ${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'file://lxdm-pam file://lxdm-pam-debug', '', d)} \ |
9 | ${@base_contains("DISTRO_TYPE", "debug", "", "file://0001-lxdm.conf.in-blacklist-root-for-release-images.patch",d)} \ | 9 | ${@bb.utils.contains("DISTRO_TYPE", "debug", "", "file://0001-lxdm.conf.in-blacklist-root-for-release-images.patch",d)} \ |
10 | file://0002-let-autotools-create-lxdm.conf.patch \ | 10 | file://0002-let-autotools-create-lxdm.conf.patch \ |
11 | " | 11 | " |
12 | SRC_URI[md5sum] = "061caae432634e6db38bbdc84bc6ffa0" | 12 | SRC_URI[md5sum] = "061caae432634e6db38bbdc84bc6ffa0" |
@@ -15,10 +15,10 @@ SRC_URI[sha256sum] = "4891efee81c72a400cc6703e40aa76f3f3853833d048b72ec805da0f93 | |||
15 | PE = "1" | 15 | PE = "1" |
16 | 16 | ||
17 | DEPENDS = "virtual/libintl intltool-native cairo dbus gdk-pixbuf glib-2.0 gtk+ virtual/libx11 libxcb pango iso-codes" | 17 | DEPENDS = "virtual/libintl intltool-native cairo dbus gdk-pixbuf glib-2.0 gtk+ virtual/libx11 libxcb pango iso-codes" |
18 | DEPENDS += "${@base_contains("DISTRO_FEATURES", "systemd", "", "consolekit", d)}" | 18 | DEPENDS += "${@bb.utils.contains("DISTRO_FEATURES", "systemd", "", "consolekit", d)}" |
19 | 19 | ||
20 | # combine oe-core way with angstrom DISTRO_TYPE | 20 | # combine oe-core way with angstrom DISTRO_TYPE |
21 | DISTRO_TYPE ?= "${@base_contains("IMAGE_FEATURES", "debug-tweaks", "debug", "",d)}" | 21 | DISTRO_TYPE ?= "${@bb.utils.contains("IMAGE_FEATURES", "debug-tweaks", "debug", "",d)}" |
22 | 22 | ||
23 | inherit autotools pkgconfig gettext systemd distro_features_check | 23 | inherit autotools pkgconfig gettext systemd distro_features_check |
24 | # depends on virtual/libx11 | 24 | # depends on virtual/libx11 |
@@ -27,8 +27,8 @@ REQUIRED_DISTRO_FEATURES = "x11" | |||
27 | CFLAGS_append = " -fno-builtin-fork -fno-builtin-memset -fno-builtin-strstr " | 27 | CFLAGS_append = " -fno-builtin-fork -fno-builtin-memset -fno-builtin-strstr " |
28 | 28 | ||
29 | EXTRA_OECONF += "--enable-gtk3=no --enable-password=yes --with-x -with-xconn=xcb \ | 29 | EXTRA_OECONF += "--enable-gtk3=no --enable-password=yes --with-x -with-xconn=xcb \ |
30 | ${@base_contains('DISTRO_FEATURES', 'systemd', '--with-systemdsystemunitdir=${systemd_unitdir}/system/ --disable-consolekit', '--without-systemdsystemunitdir', d)} \ | 30 | ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '--with-systemdsystemunitdir=${systemd_unitdir}/system/ --disable-consolekit', '--without-systemdsystemunitdir', d)} \ |
31 | ${@base_contains('DISTRO_FEATURES', 'pam', '--with-pam', '--without-pam', d)} \ | 31 | ${@bb.utils.contains('DISTRO_FEATURES', 'pam', '--with-pam', '--without-pam', d)} \ |
32 | " | 32 | " |
33 | 33 | ||
34 | do_configure_prepend() { | 34 | do_configure_prepend() { |
@@ -48,11 +48,11 @@ do_compile_append() { | |||
48 | do_install_append() { | 48 | do_install_append() { |
49 | install -d ${D}${localstatedir}/lib/lxdm | 49 | install -d ${D}${localstatedir}/lib/lxdm |
50 | install -m 644 ${WORKDIR}/lxdm.conf ${D}${localstatedir}/lib/lxdm | 50 | install -m 644 ${WORKDIR}/lxdm.conf ${D}${localstatedir}/lib/lxdm |
51 | if ${@base_contains('DISTRO_FEATURES', 'pam', 'true', 'false', d)}; then | 51 | if ${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'true', 'false', d)}; then |
52 | # ArchLinux version of pam config has the following advantages: | 52 | # ArchLinux version of pam config has the following advantages: |
53 | # * simple setup of passwordless login | 53 | # * simple setup of passwordless login |
54 | # * in XFCE powerdown/restart enabled in logoff dialog | 54 | # * in XFCE powerdown/restart enabled in logoff dialog |
55 | install -m 644 ${WORKDIR}/${@base_contains("DISTRO_TYPE", "debug", "lxdm-pam-debug", "lxdm-pam",d)} ${D}${sysconfdir}/pam.d/lxdm | 55 | install -m 644 ${WORKDIR}/${@bb.utils.contains("DISTRO_TYPE", "debug", "lxdm-pam-debug", "lxdm-pam",d)} ${D}${sysconfdir}/pam.d/lxdm |
56 | fi | 56 | fi |
57 | } | 57 | } |
58 | 58 | ||
@@ -70,7 +70,7 @@ done | |||
70 | sed -i "s:last_langs=.*$:last_langs=$langs:g" $D${localstatedir}/lib/lxdm/lxdm.conf | 70 | sed -i "s:last_langs=.*$:last_langs=$langs:g" $D${localstatedir}/lib/lxdm/lxdm.conf |
71 | } | 71 | } |
72 | 72 | ||
73 | RDEPENDS_${PN} = "${@base_contains('DISTRO_FEATURES', 'pam', 'pam-plugin-loginuid', '', d)} setxkbmap bash librsvg-gtk" | 73 | RDEPENDS_${PN} = "${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'pam-plugin-loginuid', '', d)} setxkbmap bash librsvg-gtk" |
74 | 74 | ||
75 | RPROVIDES_${PN} += "${PN}-systemd" | 75 | RPROVIDES_${PN} += "${PN}-systemd" |
76 | RREPLACES_${PN} += "${PN}-systemd" | 76 | RREPLACES_${PN} += "${PN}-systemd" |