summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics/lxdm/lxdm_git.bb
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2012-09-17 08:15:47 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2012-09-17 10:42:35 +0200
commit4d234731b2770f8983f16ba22177ed022fe8eea9 (patch)
tree70824fe72de69e19f72659529c34ae09046a8722 /meta-oe/recipes-graphics/lxdm/lxdm_git.bb
parent72335a05f2b9a47aceec9e6f3881cd7209224343 (diff)
downloadmeta-openembedded-4d234731b2770f8983f16ba22177ed022fe8eea9.tar.gz
lxdm: initial add 1.22_git
* use git version since 1.21 missing escape button and bugfixes * no init-scripts (I am working with systemd -> testing causes huge efforts -> subsequent patches) * run tested on overo/xfce Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-graphics/lxdm/lxdm_git.bb')
-rw-r--r--meta-oe/recipes-graphics/lxdm/lxdm_git.bb62
1 files changed, 62 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/lxdm/lxdm_git.bb b/meta-oe/recipes-graphics/lxdm/lxdm_git.bb
new file mode 100644
index 000000000..fd28c41c9
--- /dev/null
+++ b/meta-oe/recipes-graphics/lxdm/lxdm_git.bb
@@ -0,0 +1,62 @@
1DESCRIPTION = "LXDM is the lightweight display manager"
2HOMEPAGE = "http://blog.lxde.org/?p=531"
3LICENSE = "GPLv3"
4LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
5SRC_URI = " \
6 git://lxde.git.sourceforge.net/gitroot/lxde/${BPN};protocol=git;branch=master \
7 file://lxdm.conf \
8 file://lxdm-pam \
9 file://lxdm-pam-debug \
10 ${@base_contains("DISTRO_TYPE", "debug", "", "file://0001-lxdm.conf.in-blacklist-root-for-release-images.patch",d)} \
11"
12
13LXDM_PAM = "${@base_contains("DISTRO_TYPE", "debug", "lxdm-pam-debug", "lxdm-pam",d)}"
14
15SRCREV = "d681bc90b62ec2e13ed62fc30cdaf5dbbba23cdc"
16PV = "0.4.2+git${SRCPV}"
17
18DEPENDS = "cairo consolekit dbus gdk-pixbuf glib-2.0 gtk+ virtual/libx11 libxcb pango"
19
20# combine oe-core way with angstrom DISTRO_TYPE
21DISTRO_TYPE ?= "${@base_contains("IMAGE_FEATURES", "debug-tweaks", "debug", "",d)}"
22
23inherit autotools gettext
24
25S = "${WORKDIR}/git"
26
27do_compile_append() {
28 # default background configured not available / no password field available
29 sed -i -e 's,bg=,# bg=,g' \
30 -e 's,# skip_password=,skip_password=,g' \
31 ${S}/data/lxdm.conf.in
32 # add default configuration
33 oe_runmake -C ${S}/data lxdm.conf
34}
35
36do_install_append() {
37 install -d ${D}${localstatedir}/lib/lxdm
38 install -m 644 ${WORKDIR}/lxdm.conf ${D}${localstatedir}/lib/lxdm
39 # ArchLinux version of pam config has the following advantages:
40 # * simple setup of passwordless login
41 # * in XFCE powerdown/restart enabled in logoff dialog
42 install -m 644 ${WORKDIR}/${LXDM_PAM} ${D}${sysconfdir}/pam.d/lxdm
43}
44
45# make installed languages choosable
46pkg_postinst_${PN} () {
47if [ "x$D" != "x" ]; then
48 exit 1
49fi
50langs=""
51for lang in `find ${libdir}/locale -maxdepth 1 | grep _ | sort`; do
52 lang=`basename $lang`
53 if [ "x$langs" = "x" ]; then
54 langs="$lang"
55 else
56 langs="$langs $lang"
57 fi
58done
59sed -i "s:last_langs=.*$:last_langs=$langs:g" ${localstatedir}/lib/lxdm/lxdm.conf
60}
61
62RDEPENDS_${PN} = "pam-plugin-loginuid"