summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics/graphviz
diff options
context:
space:
mode:
authorKai Kang <kai.kang@windriver.com>2022-03-29 13:48:38 +0800
committerKhem Raj <raj.khem@gmail.com>2022-03-29 08:33:41 -0700
commit49139cf082de562150a24b239f31799b15227e69 (patch)
treef7f320f76dd6fce5bc1e44c9a4e2c80a87fa23bc /meta-oe/recipes-graphics/graphviz
parent144a7fff1e32f682610e80aba4851dc97fc1b575 (diff)
downloadmeta-openembedded-49139cf082de562150a24b239f31799b15227e69.tar.gz
graphviz: add pkg_postinst script
It needs to run `dot -c` first before call 'dot' command, otherwise it fails with: | Format: "png" not recognized. No formats found. | Perhaps "dot -c" needs to be run (with installer's privileges) to register the plugins? Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-graphics/graphviz')
-rw-r--r--meta-oe/recipes-graphics/graphviz/graphviz_2.50.0.bb19
1 files changed, 18 insertions, 1 deletions
diff --git a/meta-oe/recipes-graphics/graphviz/graphviz_2.50.0.bb b/meta-oe/recipes-graphics/graphviz/graphviz_2.50.0.bb
index 0eca7fdba..66353b837 100644
--- a/meta-oe/recipes-graphics/graphviz/graphviz_2.50.0.bb
+++ b/meta-oe/recipes-graphics/graphviz/graphviz_2.50.0.bb
@@ -17,7 +17,7 @@ DEPENDS = " \
17DEPENDS:append:class-target = " ${BPN}-native" 17DEPENDS:append:class-target = " ${BPN}-native"
18DEPENDS:append:class-nativesdk = " ${BPN}-native" 18DEPENDS:append:class-nativesdk = " ${BPN}-native"
19 19
20inherit autotools-brokensep pkgconfig gettext 20inherit autotools-brokensep pkgconfig gettext qemu
21 21
22SRC_URI = "https://gitlab.com/api/v4/projects/4207231/packages/generic/${BPN}-releases/${PV}/${BP}.tar.xz \ 22SRC_URI = "https://gitlab.com/api/v4/projects/4207231/packages/generic/${BPN}-releases/${PV}/${BP}.tar.xz \
23 " 23 "
@@ -81,6 +81,23 @@ graphviz_sstate_postinst() {
81} 81}
82SYSROOT_PREPROCESS_FUNCS:append:class-native = " graphviz_sstate_postinst" 82SYSROOT_PREPROCESS_FUNCS:append:class-native = " graphviz_sstate_postinst"
83 83
84pkg_postinst:${PN} () {
85 if [ -n "$D" ]; then
86 if ${@bb.utils.contains('MACHINE_FEATURES', 'qemu-usermode', 'true', 'false', d)}; then
87 ${@qemu_run_binary(d, '$D', '${bindir}/dot')} -c
88 fi
89 else
90 dot -c
91 fi
92}
93
94pkg_postrm:${PN} () {
95 rm -f $D${libdir}/graphviz/config*
96 rmdir --ignore-fail-on-non-empty $D${libdir}/graphviz
97}
98
99PACKAGE_WRITE_DEPS += "qemu-native"
100
84PACKAGES =+ "${PN}-python ${PN}-perl ${PN}-demo" 101PACKAGES =+ "${PN}-python ${PN}-perl ${PN}-demo"
85 102
86FILES:${PN}-python += "${libdir}/python*/site-packages/ ${libdir}/graphviz/python/" 103FILES:${PN}-python += "${libdir}/python*/site-packages/ ${libdir}/graphviz/python/"