summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics/gphoto2/libgphoto2_2.4.11.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-06-13 11:50:39 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2011-06-13 11:50:39 +0200
commit670fe1cb4ddc951c02e2fb6d642e218e2cba1b6c (patch)
treedc1931ac649c33e93d3604681ad0592d4fd9b818 /meta-oe/recipes-graphics/gphoto2/libgphoto2_2.4.11.bb
parent58b79786c6b1ee26340b20e7606d2144f52543ed (diff)
downloadmeta-openembedded-670fe1cb4ddc951c02e2fb6d642e218e2cba1b6c.tar.gz
libghoto2: update to 2.4.11
Regenerate fdi and udev rules Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-graphics/gphoto2/libgphoto2_2.4.11.bb')
-rw-r--r--meta-oe/recipes-graphics/gphoto2/libgphoto2_2.4.11.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/gphoto2/libgphoto2_2.4.11.bb b/meta-oe/recipes-graphics/gphoto2/libgphoto2_2.4.11.bb
new file mode 100644
index 000000000..fa63f840e
--- /dev/null
+++ b/meta-oe/recipes-graphics/gphoto2/libgphoto2_2.4.11.bb
@@ -0,0 +1,49 @@
1DESCRIPTION = "libgphoto2 allows you to access digital cameras"
2SECTION = "libs"
3LICENSE = "LGPLv2.1"
4LIC_FILES_CHKSUM = "file://COPYING;md5=0448d3676bc0de00406af227d341a4d1"
5
6DEPENDS = "libtool jpeg virtual/libusb0 libexif"
7
8# The .fdi and .rules files were generated with:
9# libgphoto2-2.4.7/packaging/generic$ qemu-arm -s 1048576 -r 2.6.24 -L /OE/angstrom-dev/staging/armv5te-angstrom-linux-gnueabi/ .libs/print-camera-list
10# They are release specific, so please regen when adding new releases
11
12SRC_URI = "${SOURCEFORGE_MIRROR}/gphoto/libgphoto2-${PV}.tar.bz2;name=libgphoto2 \
13 file://10-camera-libgphoto2-device.fdi \
14 file://10-camera-libgphoto2.fdi \
15 file://40-libgphoto2.rules \
16"
17
18SRC_URI[libgphoto2.md5sum] = "16a22b9739e45a95980ed62705fe7333"
19SRC_URI[libgphoto2.sha256sum] = "5116bbacea57dfe22585e8e939ea30b5fb99fe08de526002788c84e37105c423"
20
21inherit autotools pkgconfig gettext lib_package
22
23EXTRA_OECONF = " --with-drivers=all udevscriptdir=/lib/udev ac_cv_lib_ltdl_lt_dlcaller_register=yes"
24
25do_configure_append() {
26 cd ${S}/libgphoto2_port/
27 autoreconf -Wcross --verbose --install --force ${EXTRA_AUTORECONF} $acpaths
28 cd ${S}
29}
30
31do_install_append() {
32 install -d ${D}${datadir}/hal/fdi/information/20thirdparty
33 install -m 0644 ${WORKDIR}/*.fdi ${D}${datadir}/hal/fdi/information/20thirdparty/
34
35 install -d ${D}${sysconfdir}/udev/rules.d/
36 install -m 0755 ${WORKDIR}/*.rules ${D}${sysconfdir}/udev/rules.d/
37}
38
39PACKAGES =+ "libgphotoport libgphoto2-camlibs"
40FILES_libgphoto2-camlibs = "${libdir}/libgphoto2*/*/*.so*"
41RDEPENDS_${PN} = "libgphoto2-camlibs"
42
43FILES_libgphotoport = "${libdir}/libgphoto2_port.so.*"
44
45FILES_${PN} += "${base_libdir}/udev/* ${datadir}/hal"
46FILES_${PN}-dbg += "${libdir}/*/*/.debug"
47
48
49