diff options
author | Ann Thornton <ann.thornton@nxp.com> | 2016-09-06 17:08:57 -0500 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2016-09-15 10:22:45 +0200 |
commit | 5b4a5572650e8a20c4a5c956d1874813f81c2d1b (patch) | |
tree | 79c3cd0406ed8b087dcdda44ee9fa47c224ad969 /meta-oe/recipes-graphics/glcompbench | |
parent | f3cd93f4bd7d77e3f75076e53bffff3425c2ee98 (diff) | |
download | meta-openembedded-5b4a5572650e8a20c4a5c956d1874813f81c2d1b.tar.gz |
glcompbench: Fix issues causing failures in GCC6
Signed-off-by: Ann Thornton <ann.thornton@nxp.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-graphics/glcompbench')
4 files changed, 64 insertions, 4 deletions
diff --git a/meta-oe/recipes-graphics/glcompbench/glcompbench/Fix-configure-for-sqrt-check.patch b/meta-oe/recipes-graphics/glcompbench/glcompbench/Fix-configure-for-sqrt-check.patch new file mode 100755 index 000000000..4831c401f --- /dev/null +++ b/meta-oe/recipes-graphics/glcompbench/glcompbench/Fix-configure-for-sqrt-check.patch | |||
@@ -0,0 +1,14 @@ | |||
1 | Index: git/wscript | ||
2 | =================================================================== | ||
3 | --- git.orig/wscript 2016-07-29 13:15:44.954249796 -0500 | ||
4 | +++ git/wscript 2016-07-29 15:52:06.196768865 -0500 | ||
5 | @@ -56,7 +56,7 @@ | ||
6 | ctx.check_cxx(lib = lib, uselib_store = uselib) | ||
7 | |||
8 | # Check required functions | ||
9 | - req_funcs = [('gettimeofday', 'sys/time.h', []) ,('sqrt', 'math.h', ['m']), | ||
10 | + req_funcs = [('gettimeofday', 'sys/time.h', []), | ||
11 | ('strtol', 'stdlib.h', []), ('strtoul', 'stdlib.h', [])] | ||
12 | for func, header, uselib in req_funcs: | ||
13 | ctx.check_cxx(function_name = func, header_name = header, uselib = uselib, mandatory = True) | ||
14 | |||
diff --git a/meta-oe/recipes-graphics/glcompbench/glcompbench/Fix_auto_ptr_deprecated.patch b/meta-oe/recipes-graphics/glcompbench/glcompbench/Fix_auto_ptr_deprecated.patch new file mode 100755 index 000000000..930c7cb50 --- /dev/null +++ b/meta-oe/recipes-graphics/glcompbench/glcompbench/Fix_auto_ptr_deprecated.patch | |||
@@ -0,0 +1,24 @@ | |||
1 | diff -aur glcompbench-2012.08/src/libmatrix/shader-source.cc Fixed/src/libmatrix/shader-source.cc | ||
2 | --- glcompbench-2012.08/src/libmatrix/shader-source.cc 2012-08-22 13:41:36.000000000 -0500 | ||
3 | +++ Fixed/src/libmatrix/shader-source.cc 2016-08-24 14:23:49.576023317 -0500 | ||
4 | @@ -34,7 +34,7 @@ | ||
5 | bool | ||
6 | ShaderSource::load_file(const std::string& filename, std::string& str) | ||
7 | { | ||
8 | - std::auto_ptr<std::istream> is_ptr(Util::get_resource(filename)); | ||
9 | + std::unique_ptr<std::istream> is_ptr(Util::get_resource(filename)); | ||
10 | std::istream& inputFile(*is_ptr); | ||
11 | |||
12 | if (!inputFile) | ||
13 | diff -aur glcompbench-2012.08/src/texture.cc Fixed/src/texture.cc | ||
14 | --- glcompbench-2012.08/src/texture.cc 2012-08-22 13:41:36.000000000 -0500 | ||
15 | +++ Fixed/src/texture.cc 2016-08-24 14:23:28.223917438 -0500 | ||
16 | @@ -52,7 +52,7 @@ | ||
17 | |||
18 | Log::debug("Reading PNG file %s\n", filename.c_str()); | ||
19 | |||
20 | - const std::auto_ptr<std::istream> is_ptr(Util::get_resource(filename)); | ||
21 | + const std::unique_ptr<std::istream> is_ptr(Util::get_resource(filename)); | ||
22 | if (!(*is_ptr)) { | ||
23 | Log::error("Cannot open file %s!\n", filename.c_str()); | ||
24 | return false; | ||
diff --git a/meta-oe/recipes-graphics/glcompbench/glcompbench/Fix_space_issues.patch b/meta-oe/recipes-graphics/glcompbench/glcompbench/Fix_space_issues.patch new file mode 100755 index 000000000..516baadae --- /dev/null +++ b/meta-oe/recipes-graphics/glcompbench/glcompbench/Fix_space_issues.patch | |||
@@ -0,0 +1,22 @@ | |||
1 | diff -aur glcompbench-2012.08/src/composite-canvas.cc Fixed/src/composite-canvas.cc | ||
2 | --- glcompbench-2012.08/src/composite-canvas.cc 2012-08-22 13:41:36.000000000 -0500 | ||
3 | +++ Fixed/src/composite-canvas.cc 2016-08-24 14:05:28.970565709 -0500 | ||
4 | @@ -41,7 +41,7 @@ | ||
5 | #include "log.h" | ||
6 | #include "profiler.h" | ||
7 | |||
8 | -const std::string glcompbench_version_string("glcompbench "GLCOMPBENCH_VERSION); | ||
9 | +const std::string glcompbench_version_string("glcompbench " GLCOMPBENCH_VERSION); | ||
10 | |||
11 | /******************* | ||
12 | * Private methods * | ||
13 | @@ -495,7 +495,7 @@ | ||
14 | // When we complete an iteration, reset the count and tell the caller. | ||
15 | |||
16 | if (stats.total >= current_test_duration_) { | ||
17 | - Log::info("FPS: %"PRIu64"\n", (uint64_t)(1000 * stats.nsamples / stats.total)); | ||
18 | + Log::info("FPS: %" PRIu64 "\n", (uint64_t)(1000 * stats.nsamples / stats.total)); | ||
19 | |||
20 | for (Profiler::Point p = 0; p < profiler.get_num_points(); p += 2) { | ||
21 | profiler.get_stats(p, p + 1, stats); | ||
22 | |||
diff --git a/meta-oe/recipes-graphics/glcompbench/glcompbench_2012.08.bb b/meta-oe/recipes-graphics/glcompbench/glcompbench_2012.08.bb index 0c5d7b5fc..35fb4adb3 100644..100755 --- a/meta-oe/recipes-graphics/glcompbench/glcompbench_2012.08.bb +++ b/meta-oe/recipes-graphics/glcompbench/glcompbench_2012.08.bb | |||
@@ -6,7 +6,10 @@ DEPENDS = "virtual/libgl virtual/egl virtual/libgles1 virtual/libgles2 \ | |||
6 | virtual/libx11 libxcomposite pixman libxrender libpng12" | 6 | virtual/libx11 libxcomposite pixman libxrender libpng12" |
7 | 7 | ||
8 | SRC_URI = "https://launchpad.net/glcompbench/trunk/${PV}/+download/${BPN}-${PV}.tar.gz \ | 8 | SRC_URI = "https://launchpad.net/glcompbench/trunk/${PV}/+download/${BPN}-${PV}.tar.gz \ |
9 | file://glbench-compile-fix.patch" | 9 | file://glbench-compile-fix.patch \ |
10 | file://Fix-configure-for-sqrt-check.patch \ | ||
11 | file://Fix_space_issues.patch \ | ||
12 | file://Fix_auto_ptr_deprecated.patch" | ||
10 | 13 | ||
11 | SRC_URI[md5sum] = "c939d9156fe940960098f38707fea827" | 14 | SRC_URI[md5sum] = "c939d9156fe940960098f38707fea827" |
12 | SRC_URI[sha256sum] = "b04b738cec06c6786ceafa86e4735fd8b971c078265754854ef356b0379542ee" | 15 | SRC_URI[sha256sum] = "b04b738cec06c6786ceafa86e4735fd8b971c078265754854ef356b0379542ee" |
@@ -14,6 +17,3 @@ SRC_URI[sha256sum] = "b04b738cec06c6786ceafa86e4735fd8b971c078265754854ef356b037 | |||
14 | inherit pkgconfig waf distro_features_check | 17 | inherit pkgconfig waf distro_features_check |
15 | # depends on virtual/libx11 | 18 | # depends on virtual/libx11 |
16 | REQUIRED_DISTRO_FEATURES = "x11" | 19 | REQUIRED_DISTRO_FEATURES = "x11" |
17 | |||
18 | # http://errors.yoctoproject.org/Errors/Details/68631/ | ||
19 | PNBLACKLIST[glcompbench] ?= "BROKEN: fails to build with gcc-6" | ||