diff options
author | Andreas Müller <schnitzeltony@gmail.com> | 2020-01-17 17:42:17 +0100 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2020-01-17 15:44:06 -0800 |
commit | 1cc86099a86397dadc6e909e689ce20b5091e04b (patch) | |
tree | 429c0f484d1f73facf01815856de9e898f0d5ed5 /meta-oe/recipes-graphics/fontforge | |
parent | 8966ea9928cb983ee539f71a558c53c0bcc949fe (diff) | |
download | meta-openembedded-1cc86099a86397dadc6e909e689ce20b5091e04b.tar.gz |
fontforge: rework for python3
* python3native is necessary because configure asks for version. If it uses
host's version python modules might be installed in wrong paths
* checked: ${PN}-python is packed properly
* while at it remove uneccessary (wrong) line: there is no ${PN}-python-dbg
Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-graphics/fontforge')
-rw-r--r-- | meta-oe/recipes-graphics/fontforge/fontforge_20190801.bb | 8 |
1 files changed, 3 insertions, 5 deletions
diff --git a/meta-oe/recipes-graphics/fontforge/fontforge_20190801.bb b/meta-oe/recipes-graphics/fontforge/fontforge_20190801.bb index 99c108da1..b84806fd6 100644 --- a/meta-oe/recipes-graphics/fontforge/fontforge_20190801.bb +++ b/meta-oe/recipes-graphics/fontforge/fontforge_20190801.bb | |||
@@ -6,10 +6,10 @@ LIC_FILES_CHKSUM = " \ | |||
6 | file://LICENSE;md5=d042f3d2a8fd7208b704a499168e3c89 \ | 6 | file://LICENSE;md5=d042f3d2a8fd7208b704a499168e3c89 \ |
7 | " | 7 | " |
8 | 8 | ||
9 | DEPENDS = "glib-2.0 pango giflib tiff libxml2 jpeg python libtool uthash gettext-native" | 9 | DEPENDS = "glib-2.0 pango giflib tiff libxml2 jpeg libtool uthash gettext-native" |
10 | DEPENDS_append_class-target = " libxi" | 10 | DEPENDS_append_class-target = " libxi" |
11 | 11 | ||
12 | inherit autotools pkgconfig pythonnative features_check gettext gtk-icon-cache mime | 12 | inherit autotools pkgconfig python3native features_check gettext gtk-icon-cache mime |
13 | 13 | ||
14 | REQUIRED_DISTRO_FEATURES_append_class-target = " x11" | 14 | REQUIRED_DISTRO_FEATURES_append_class-target = " x11" |
15 | 15 | ||
@@ -31,8 +31,6 @@ EXTRA_OECONF_append_class-native = " with_x=no" | |||
31 | 31 | ||
32 | PACKAGES =+ "${PN}-python" | 32 | PACKAGES =+ "${PN}-python" |
33 | 33 | ||
34 | RPROVIDES_${PN}-dbg += "${PN}-python-dbg" | ||
35 | |||
36 | FILES_${PN} += " \ | 34 | FILES_${PN} += " \ |
37 | ${datadir}/appdata \ | 35 | ${datadir}/appdata \ |
38 | ${datadir}/metainfo \ | 36 | ${datadir}/metainfo \ |
@@ -40,7 +38,7 @@ FILES_${PN} += " \ | |||
40 | " | 38 | " |
41 | 39 | ||
42 | FILES_${PN}-python = "${PYTHON_SITEPACKAGES_DIR} ${datadir}/${BPN}/python" | 40 | FILES_${PN}-python = "${PYTHON_SITEPACKAGES_DIR} ${datadir}/${BPN}/python" |
43 | RDEPENDS_${PN}-python = "python" | 41 | RDEPENDS_${PN}-python = "python3" |
44 | 42 | ||
45 | # for e.g kde's oxygen-fonts | 43 | # for e.g kde's oxygen-fonts |
46 | BBCLASSEXTEND = "native" | 44 | BBCLASSEXTEND = "native" |