summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics/fontforge/fontforge_20150824.bb
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2015-08-30 12:33:55 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2015-09-08 16:18:34 +0200
commitde033e18d168af57cab6ce1aa6b01d2999f322b5 (patch)
treed0c81adf8989509af30e7960b64e2b5c12f887d7 /meta-oe/recipes-graphics/fontforge/fontforge_20150824.bb
parentb996aaab173126c9266fe35ac7fc1caab8bb20c4 (diff)
downloadmeta-openembedded-de033e18d168af57cab6ce1aa6b01d2999f322b5.tar.gz
fontforge: update to 20150824
* LICENSE was rewrittem stating out more clearly that huge parts were initially licensed under BSD clause 3 - so add that licence. * Follow suggestion not to use github release tarballs [1] and use git as source. [1] http://lists.openembedded.org/pipermail/openembedded-devel/2015-August/102843.html Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-graphics/fontforge/fontforge_20150824.bb')
-rw-r--r--meta-oe/recipes-graphics/fontforge/fontforge_20150824.bb43
1 files changed, 43 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/fontforge/fontforge_20150824.bb b/meta-oe/recipes-graphics/fontforge/fontforge_20150824.bb
new file mode 100644
index 000000000..eb58d8f88
--- /dev/null
+++ b/meta-oe/recipes-graphics/fontforge/fontforge_20150824.bb
@@ -0,0 +1,43 @@
1SUMMARY = "A font editor"
2HOMEPAGE = "http://fontforge.github.io/en-US/"
3LICENSE = "BSD-3-Clause & GPLv3"
4LIC_FILES_CHKSUM = " \
5 file://COPYING.gplv3;md5=d32239bcb673463ab874e80d47fae504 \
6 file://LICENSE;md5=3f922b42ed0033fa0fd4cd3268f6429c \
7"
8
9inherit autotools pkgconfig pythonnative distro_features_check
10
11DEPENDS = "glib-2.0 pango giflib tiff libxml2 jpeg python libtool"
12DEPENDS_append_class-target = " libxi"
13REQUIRED_DISTRO_FEATURES_append_class-target = " x11"
14
15SRC_URI = "git://github.com/${BPN}/${BPN}.git"
16# tag 20150824
17SRCREV = "07d5ccff2704f8a56f1b3cc6695a4e31f85f88e6"
18S = "${WORKDIR}/git"
19
20EXTRA_OECONF_append_class-native = " with_x=no --disable-python-extension --disable-python-scripting"
21
22do_configure_prepend() {
23 currdir=`pwd`
24 cd ${S}
25 ./bootstrap --force
26 cd $currdir
27}
28
29EXTRA_OEMAKE = "CFLAGS='${CFLAGS} -I${B}/uthash/src'"
30
31PACKAGES =+ "${PN}-python-dbg ${PN}-python"
32
33FILES_${PN} += " \
34 ${datadir}/mime \
35 ${datadir}/icons \
36"
37
38FILES_${PN}-python = "${PYTHON_SITEPACKAGES_DIR} ${datadir}/${PN}/python"
39FILES_${PN}-python-dbg = "${PYTHON_SITEPACKAGES_DIR}/.debug"
40RDEPENDS_${PN}-python = "python"
41
42# for e.g kde's oxygen-fonts
43BBCLASSEXTEND = "native"