summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics/feh
diff options
context:
space:
mode:
authorDmitry Baryshkov <dbaryshkov@gmail.com>2020-12-28 05:34:01 +0300
committerKhem Raj <raj.khem@gmail.com>2020-12-29 15:50:45 -0800
commit5513ba6a919f435e2d4482b423a37fa69338e483 (patch)
tree4b48ecf7f4d51fcb594562df203c34071e10c455 /meta-oe/recipes-graphics/feh
parentd58ec0453fdca1fb6e7704235bf0e7bf84dee4f7 (diff)
downloadmeta-openembedded-5513ba6a919f435e2d4482b423a37fa69338e483.tar.gz
feh: imlib2 based image viewer
Add feh, small but powerfull image viewer. One of its features is an ability to set X11 root window background. Signed-off-by: Dmitry Baryshkov <dmitry.baryshkov@linaro.org> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-graphics/feh')
-rw-r--r--meta-oe/recipes-graphics/feh/feh_3.6.1.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/feh/feh_3.6.1.bb b/meta-oe/recipes-graphics/feh/feh_3.6.1.bb
new file mode 100644
index 000000000..1e49e68f8
--- /dev/null
+++ b/meta-oe/recipes-graphics/feh/feh_3.6.1.bb
@@ -0,0 +1,31 @@
1SUMMARY = "X11 image viewer aimed mostly at console users"
2AUTHOR = "Tom Gilbert & Daniel Friesel"
3HOMEPAGE = "https://feh.finalrewind.org/"
4SECTION = "x11/utils"
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://COPYING;md5=f91bd06901085c94bdc50649d98c5059"
7DEPENDS = "\
8 imlib2 \
9 virtual/libx11 libxt\
10"
11
12SRC_URI = "https://feh.finalrewind.org/feh-${PV}.tar.bz2"
13SRC_URI[sha256sum] = "9b1edec52cbae97b17530cb5db10666abfb9983f51a5d820c89added6f7b1ea8"
14
15inherit mime-xdg features_check
16# depends on virtual/libx11
17REQUIRED_DISTRO_FEATURES = "x11"
18
19EXTRA_OEMAKE = "curl=0 xinerama=0 PREFIX=/usr"
20
21do_compile () {
22 oe_runmake
23}
24
25do_install () {
26 oe_runmake install app=1 'DESTDIR=${D}' 'ICON_PREFIX=${D}${datadir}/icons'
27}
28
29RDEPENDS_${PN} += "imlib2-loaders"
30
31FILES_${PN} += "${datadir}/icons"