summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics/fbida
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2014-04-21 10:55:58 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2014-05-03 20:45:01 +0200
commit6c535e76e862fcba9307615f324b4d369ec42d88 (patch)
treef3c5bde069328617f175c222e77ad82295214e75 /meta-oe/recipes-graphics/fbida
parentd1a619eeddb829caed85ef1a9f5901b772344b33 (diff)
downloadmeta-openembedded-6c535e76e862fcba9307615f324b4d369ec42d88.tar.gz
fbida: update to latest git and make motif a PACKAGECONFIG option
The x11 dependencies are now deterministic instead of enabling based on DISTRO_FEATURES without changing DEPENDS. Disable motif by default as well, since *fb*ida is supposed to be framebuffer only by default. Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-graphics/fbida')
-rw-r--r--meta-oe/recipes-graphics/fbida/fbida_git.bb10
1 files changed, 5 insertions, 5 deletions
diff --git a/meta-oe/recipes-graphics/fbida/fbida_git.bb b/meta-oe/recipes-graphics/fbida/fbida_git.bb
index 9eea664b9..f4dd01d8b 100644
--- a/meta-oe/recipes-graphics/fbida/fbida_git.bb
+++ b/meta-oe/recipes-graphics/fbida/fbida_git.bb
@@ -11,7 +11,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=8ca43cbc842c2336e835926c2166c28b"
11DEPENDS = "virtual/libiconv jpeg fontconfig freetype libexif curl" 11DEPENDS = "virtual/libiconv jpeg fontconfig freetype libexif curl"
12 12
13SRC_URI = "git://git.kraxel.org/fbida" 13SRC_URI = "git://git.kraxel.org/fbida"
14SRCREV = "cb0ce5fa5f42bfaea4f8f326bcd8914dd14e782d" 14SRCREV = "6aa5563cb3c8864ad15cf83eb6fca3b773da1099"
15PV = "2.09+git${SRCPV}" 15PV = "2.09+git${SRCPV}"
16S = "${WORKDIR}/git" 16S = "${WORKDIR}/git"
17 17
@@ -21,15 +21,12 @@ PACKAGECONFIG ??= "gif png"
21PACKAGECONFIG[gif] = ",,libungif" 21PACKAGECONFIG[gif] = ",,libungif"
22PACKAGECONFIG[png] = ",,libpng" 22PACKAGECONFIG[png] = ",,libpng"
23PACKAGECONFIG[tiff] = ",,tiff" 23PACKAGECONFIG[tiff] = ",,tiff"
24PACKAGECONFIG[motif] = ",,libx11 libxext libxpm libxt openmotif"
24 25
25do_compile() { 26do_compile() {
26 sed -i -e 's:/sbin/ldconfig:echo x:' ${S}/mk/Autoconf.mk 27 sed -i -e 's:/sbin/ldconfig:echo x:' ${S}/mk/Autoconf.mk
27 sed -i -e 's: cpp: ${TARGET_PREFIX}cpp -I${STAGING_INCDIR}:' ${S}/GNUmakefile 28 sed -i -e 's: cpp: ${TARGET_PREFIX}cpp -I${STAGING_INCDIR}:' ${S}/GNUmakefile
28 29
29 if [ -z "${@base_contains('DISTRO_FEATURES', 'x11', 'x11', '', d)}" ]; then
30 sed -i -e '/^HAVE_MOTIF/s/:=.*$/:= no/' ${S}/GNUmakefile
31 fi
32
33 # Be sure to respect preferences (force to "no") 30 # Be sure to respect preferences (force to "no")
34 # Also avoid issues when ${BUILD_ARCH} == ${HOST_ARCH} 31 # Also avoid issues when ${BUILD_ARCH} == ${HOST_ARCH}
35 if [ -z "${@base_contains('PACKAGECONFIG', 'gif', 'gif', '', d)}" ]; then 32 if [ -z "${@base_contains('PACKAGECONFIG', 'gif', 'gif', '', d)}" ]; then
@@ -41,6 +38,9 @@ do_compile() {
41 if [ -z "${@base_contains('PACKAGECONFIG', 'tiff', 'tiff', '', d)}" ]; then 38 if [ -z "${@base_contains('PACKAGECONFIG', 'tiff', 'tiff', '', d)}" ]; then
42 sed -i -e '/^HAVE_LIBTIFF/s/:=.*$/:= no/' ${S}/GNUmakefile 39 sed -i -e '/^HAVE_LIBTIFF/s/:=.*$/:= no/' ${S}/GNUmakefile
43 fi 40 fi
41 if [ -z "${@base_contains('PACKAGECONFIG', 'motif', 'motif', '', d)}" ]; then
42 sed -i -e '/^HAVE_MOTIF/s/:=.*$/:= no/' ${S}/GNUmakefile
43 fi
44 44
45 oe_runmake 45 oe_runmake
46} 46}