summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics/fbida
diff options
context:
space:
mode:
authorMatthieu CRAPET <Matthieu.CRAPET@ingenico.com>2014-02-28 15:11:04 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2014-03-11 14:58:50 +0100
commit50f7a7c96604e74b12bea7f9269dfa9064f358f1 (patch)
tree0d05032b5988b560055849c5bdb0e965eba40a3d /meta-oe/recipes-graphics/fbida
parent0d3445e00a2f523545da44db782fae1b912be3ec (diff)
downloadmeta-openembedded-50f7a7c96604e74b12bea7f9269dfa9064f358f1.tar.gz
fbida 2.09: cleanups and use PACKAGECONFIG
There are now 3 packageconfig variables: gif, png, tiff. Changes: - rename recipe to _git (match SRCREV) - fix missing $ for STAGING_INCDIR (jpeg version detection) - add DESCRIPTION - no more QA warnings Use this to reveal: sed -i -e '/^verbose/s/no/yes/' ${S}/mk/Autoconf.mk Signed-off-by: Matthieu Crapet <Matthieu.Crapet@ingenico.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-graphics/fbida')
-rw-r--r--meta-oe/recipes-graphics/fbida/fbida_2.09.bb27
-rw-r--r--meta-oe/recipes-graphics/fbida/fbida_git.bb52
2 files changed, 52 insertions, 27 deletions
diff --git a/meta-oe/recipes-graphics/fbida/fbida_2.09.bb b/meta-oe/recipes-graphics/fbida/fbida_2.09.bb
deleted file mode 100644
index 32f376f04..000000000
--- a/meta-oe/recipes-graphics/fbida/fbida_2.09.bb
+++ /dev/null
@@ -1,27 +0,0 @@
1HOMEPAGE = "http://linux.bytesex.org/fbida/"
2SUMMARY = "frame buffer image and doc viewer tools"
3AUTHOR = "Gerd Hoffmann"
4SECTION = "utils"
5
6LICENSE = "GPLv2"
7LIC_FILES_CHKSUM = "file://COPYING;md5=8ca43cbc842c2336e835926c2166c28b"
8
9DEPENDS = "virtual/libiconv libpng jpeg fontconfig freetype libexif curl libungif tiff"
10
11SRC_URI = "git://git.kraxel.org/fbida"
12SRCREV = "cb0ce5fa5f42bfaea4f8f326bcd8914dd14e782d"
13S = "${WORKDIR}/git"
14
15EXTRA_OEMAKE = "STRIP="
16
17do_compile() {
18 sed -i -e 's: cpp: ${TARGET_PREFIX}cpp -I{STAGING_INCDIR}:g' GNUmakefile
19 oe_runmake
20}
21
22do_install() {
23 oe_runmake 'DESTDIR=${D}' install
24}
25
26RDEPENDS_${PN} = "ttf-dejavu-sans-mono"
27
diff --git a/meta-oe/recipes-graphics/fbida/fbida_git.bb b/meta-oe/recipes-graphics/fbida/fbida_git.bb
new file mode 100644
index 000000000..9eea664b9
--- /dev/null
+++ b/meta-oe/recipes-graphics/fbida/fbida_git.bb
@@ -0,0 +1,52 @@
1SUMMARY = "Framebuffer image and doc viewer tools"
2DESCRIPTION = "The fbida project contains a few applications for viewing and editing images, \
3 with the main focus being photos."
4HOMEPAGE = "http://linux.bytesex.org/fbida/"
5AUTHOR = "Gerd Hoffmann"
6SECTION = "utils"
7
8LICENSE = "GPLv2"
9LIC_FILES_CHKSUM = "file://COPYING;md5=8ca43cbc842c2336e835926c2166c28b"
10
11DEPENDS = "virtual/libiconv jpeg fontconfig freetype libexif curl"
12
13SRC_URI = "git://git.kraxel.org/fbida"
14SRCREV = "cb0ce5fa5f42bfaea4f8f326bcd8914dd14e782d"
15PV = "2.09+git${SRCPV}"
16S = "${WORKDIR}/git"
17
18EXTRA_OEMAKE = "STRIP="
19
20PACKAGECONFIG ??= "gif png"
21PACKAGECONFIG[gif] = ",,libungif"
22PACKAGECONFIG[png] = ",,libpng"
23PACKAGECONFIG[tiff] = ",,tiff"
24
25do_compile() {
26 sed -i -e 's:/sbin/ldconfig:echo x:' ${S}/mk/Autoconf.mk
27 sed -i -e 's: cpp: ${TARGET_PREFIX}cpp -I${STAGING_INCDIR}:' ${S}/GNUmakefile
28
29 if [ -z "${@base_contains('DISTRO_FEATURES', 'x11', 'x11', '', d)}" ]; then
30 sed -i -e '/^HAVE_MOTIF/s/:=.*$/:= no/' ${S}/GNUmakefile
31 fi
32
33 # Be sure to respect preferences (force to "no")
34 # Also avoid issues when ${BUILD_ARCH} == ${HOST_ARCH}
35 if [ -z "${@base_contains('PACKAGECONFIG', 'gif', 'gif', '', d)}" ]; then
36 sed -i -e '/^HAVE_LIBUNGIF/s/:=.*$/:= no/' ${S}/GNUmakefile
37 fi
38 if [ -z "${@base_contains('PACKAGECONFIG', 'png', 'png', '', d)}" ]; then
39 sed -i -e '/^HAVE_LIBPNG/s/:=.*$/:= no/' ${S}/GNUmakefile
40 fi
41 if [ -z "${@base_contains('PACKAGECONFIG', 'tiff', 'tiff', '', d)}" ]; then
42 sed -i -e '/^HAVE_LIBTIFF/s/:=.*$/:= no/' ${S}/GNUmakefile
43 fi
44
45 oe_runmake
46}
47
48do_install() {
49 oe_runmake 'DESTDIR=${D}' install
50}
51
52RDEPENDS_${PN} = "ttf-dejavu-sans-mono"