diff options
author | Ross Burton <ross.burton@intel.com> | 2016-04-22 20:48:49 +0100 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2016-04-28 10:38:38 +0200 |
commit | 21f10c11f39020f9502d741c774a12d1aeb39499 (patch) | |
tree | fdc66c039950da89d82b6b7405ebfc50cbba693a /meta-oe/recipes-graphics/fbida/fbida_2.10.bb | |
parent | 723b55f5c1f7df21dbcfa7cb2dcaecb10d886041 (diff) | |
download | meta-openembedded-21f10c11f39020f9502d741c774a12d1aeb39499.tar.gz |
meta-oe: use bb.utils.contains() instead of base_contains()
base_contains() is a compatibility wrapper and may warn in the future, so
replace all instances with bb.utils.contains().
Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-graphics/fbida/fbida_2.10.bb')
-rw-r--r-- | meta-oe/recipes-graphics/fbida/fbida_2.10.bb | 14 |
1 files changed, 7 insertions, 7 deletions
diff --git a/meta-oe/recipes-graphics/fbida/fbida_2.10.bb b/meta-oe/recipes-graphics/fbida/fbida_2.10.bb index 8a4c083a4..8d3da69aa 100644 --- a/meta-oe/recipes-graphics/fbida/fbida_2.10.bb +++ b/meta-oe/recipes-graphics/fbida/fbida_2.10.bb | |||
@@ -31,25 +31,25 @@ do_compile() { | |||
31 | 31 | ||
32 | # Be sure to respect preferences (force to "no") | 32 | # Be sure to respect preferences (force to "no") |
33 | # Also avoid issues when ${BUILD_ARCH} == ${HOST_ARCH} | 33 | # Also avoid issues when ${BUILD_ARCH} == ${HOST_ARCH} |
34 | if [ -z "${@base_contains('PACKAGECONFIG', 'curl', 'curl', '', d)}" ]; then | 34 | if [ -z "${@bb.utils.contains('PACKAGECONFIG', 'curl', 'curl', '', d)}" ]; then |
35 | sed -i -e '/^HAVE_LIBCURL/s/:=.*$/:= no/' ${S}/GNUmakefile | 35 | sed -i -e '/^HAVE_LIBCURL/s/:=.*$/:= no/' ${S}/GNUmakefile |
36 | fi | 36 | fi |
37 | if [ -z "${@base_contains('PACKAGECONFIG', 'gif', 'gif', '', d)}" ]; then | 37 | if [ -z "${@bb.utils.contains('PACKAGECONFIG', 'gif', 'gif', '', d)}" ]; then |
38 | sed -i -e '/^HAVE_LIBGIF/s/:=.*$/:= no/' ${S}/GNUmakefile | 38 | sed -i -e '/^HAVE_LIBGIF/s/:=.*$/:= no/' ${S}/GNUmakefile |
39 | fi | 39 | fi |
40 | if [ -z "${@base_contains('PACKAGECONFIG', 'png', 'png', '', d)}" ]; then | 40 | if [ -z "${@bb.utils.contains('PACKAGECONFIG', 'png', 'png', '', d)}" ]; then |
41 | sed -i -e '/^HAVE_LIBPNG/s/:=.*$/:= no/' ${S}/GNUmakefile | 41 | sed -i -e '/^HAVE_LIBPNG/s/:=.*$/:= no/' ${S}/GNUmakefile |
42 | fi | 42 | fi |
43 | if [ -z "${@base_contains('PACKAGECONFIG', 'tiff', 'tiff', '', d)}" ]; then | 43 | if [ -z "${@bb.utils.contains('PACKAGECONFIG', 'tiff', 'tiff', '', d)}" ]; then |
44 | sed -i -e '/^HAVE_LIBTIFF/s/:=.*$/:= no/' ${S}/GNUmakefile | 44 | sed -i -e '/^HAVE_LIBTIFF/s/:=.*$/:= no/' ${S}/GNUmakefile |
45 | fi | 45 | fi |
46 | if [ -z "${@base_contains('PACKAGECONFIG', 'motif', 'motif', '', d)}" ]; then | 46 | if [ -z "${@bb.utils.contains('PACKAGECONFIG', 'motif', 'motif', '', d)}" ]; then |
47 | sed -i -e '/^HAVE_MOTIF/s/:=.*$/:= no/' ${S}/GNUmakefile | 47 | sed -i -e '/^HAVE_MOTIF/s/:=.*$/:= no/' ${S}/GNUmakefile |
48 | fi | 48 | fi |
49 | if [ -z "${@base_contains('PACKAGECONFIG', 'webp', 'webp', '', d)}" ]; then | 49 | if [ -z "${@bb.utils.contains('PACKAGECONFIG', 'webp', 'webp', '', d)}" ]; then |
50 | sed -i -e '/^HAVE_LIBWEBP/s/:=.*$/:= no/' ${S}/GNUmakefile | 50 | sed -i -e '/^HAVE_LIBWEBP/s/:=.*$/:= no/' ${S}/GNUmakefile |
51 | fi | 51 | fi |
52 | if [ -z "${@base_contains('PACKAGECONFIG', 'lirc', 'lirc', '', d)}" ]; then | 52 | if [ -z "${@bb.utils.contains('PACKAGECONFIG', 'lirc', 'lirc', '', d)}" ]; then |
53 | sed -i -e '/^HAVE_LIBLIRC/s/:=.*$/:= no/' ${S}/GNUmakefile | 53 | sed -i -e '/^HAVE_LIBLIRC/s/:=.*$/:= no/' ${S}/GNUmakefile |
54 | fi | 54 | fi |
55 | 55 | ||