summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics/fbida/fbida_2.10.bb
diff options
context:
space:
mode:
authorMatthieu CRAPET <Matthieu.CRAPET@ingenico.com>2015-04-01 11:24:50 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2015-04-13 12:55:50 +0200
commit2900fef5c56627351003a4995c58968295ca085d (patch)
treeae2bb57cc8ebe48981fdef876ceccc8911e58bc3 /meta-oe/recipes-graphics/fbida/fbida_2.10.bb
parent90b13eded76f7f7fa1a6715e67c32504e7788e96 (diff)
downloadmeta-openembedded-2900fef5c56627351003a4995c58968295ca085d.tar.gz
fbida: update to 2.10
This release fixes QA Issue [file-rdeps] Changes: - fix HAVE_LIBUNGIF => HAVE_LIBGIF - add "curl" and "webp" to PACKAGECONFIG Signed-off-by: Matthieu Crapet <Matthieu.Crapet@ingenico.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-graphics/fbida/fbida_2.10.bb')
-rw-r--r--meta-oe/recipes-graphics/fbida/fbida_2.10.bb59
1 files changed, 59 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/fbida/fbida_2.10.bb b/meta-oe/recipes-graphics/fbida/fbida_2.10.bb
new file mode 100644
index 000000000..c7195fc98
--- /dev/null
+++ b/meta-oe/recipes-graphics/fbida/fbida_2.10.bb
@@ -0,0 +1,59 @@
1SUMMARY = "Framebuffer image and doc viewer tools"
2DESCRIPTION = "The fbida project contains a few applications for viewing and editing images, \
3 with the main focus being photos."
4HOMEPAGE = "http://linux.bytesex.org/fbida/"
5AUTHOR = "Gerd Hoffmann"
6SECTION = "utils"
7
8LICENSE = "GPLv2"
9LIC_FILES_CHKSUM = "file://COPYING;md5=8ca43cbc842c2336e835926c2166c28b"
10
11DEPENDS = "virtual/libiconv jpeg fontconfig freetype libexif"
12
13SRC_URI = "https://www.kraxel.org/releases/fbida/fbida-${PV}.tar.gz"
14SRC_URI[md5sum] = "09460b964b58c2e39b665498eca29018"
15SRC_URI[sha256sum] = "7a5a3aac61b40a6a2bbf716d270a46e2f8e8d5c97e314e927d41398a4d0b6cb6"
16
17EXTRA_OEMAKE = "STRIP="
18
19PACKAGECONFIG ??= "gif png curl"
20PACKAGECONFIG[curl] = ",,curl"
21PACKAGECONFIG[gif] = ",,giflib"
22PACKAGECONFIG[png] = ",,libpng"
23PACKAGECONFIG[tiff] = ",,tiff"
24PACKAGECONFIG[motif] = ",,libx11 libxext libxpm libxt openmotif"
25PACKAGECONFIG[webp] = ",,libwebp"
26
27do_compile() {
28 sed -i -e 's:/sbin/ldconfig:echo x:' ${S}/mk/Autoconf.mk
29 sed -i -e 's: cpp: ${TARGET_PREFIX}cpp -I${STAGING_INCDIR}:' ${S}/GNUmakefile
30
31 # Be sure to respect preferences (force to "no")
32 # Also avoid issues when ${BUILD_ARCH} == ${HOST_ARCH}
33 if [ -z "${@base_contains('PACKAGECONFIG', 'curl', 'curl', '', d)}" ]; then
34 sed -i -e '/^HAVE_LIBCURL/s/:=.*$/:= no/' ${S}/GNUmakefile
35 fi
36 if [ -z "${@base_contains('PACKAGECONFIG', 'gif', 'gif', '', d)}" ]; then
37 sed -i -e '/^HAVE_LIBGIF/s/:=.*$/:= no/' ${S}/GNUmakefile
38 fi
39 if [ -z "${@base_contains('PACKAGECONFIG', 'png', 'png', '', d)}" ]; then
40 sed -i -e '/^HAVE_LIBPNG/s/:=.*$/:= no/' ${S}/GNUmakefile
41 fi
42 if [ -z "${@base_contains('PACKAGECONFIG', 'tiff', 'tiff', '', d)}" ]; then
43 sed -i -e '/^HAVE_LIBTIFF/s/:=.*$/:= no/' ${S}/GNUmakefile
44 fi
45 if [ -z "${@base_contains('PACKAGECONFIG', 'motif', 'motif', '', d)}" ]; then
46 sed -i -e '/^HAVE_MOTIF/s/:=.*$/:= no/' ${S}/GNUmakefile
47 fi
48 if [ -z "${@base_contains('PACKAGECONFIG', 'webp', 'webp', '', d)}" ]; then
49 sed -i -e '/^HAVE_LIBWEBP/s/:=.*$/:= no/' ${S}/GNUmakefile
50 fi
51
52 oe_runmake
53}
54
55do_install() {
56 oe_runmake 'DESTDIR=${D}' install
57}
58
59RDEPENDS_${PN} = "ttf-dejavu-sans-mono"