diff options
author | Zheng Ruoqin <zhengrq.fnst@cn.fujitsu.com> | 2017-12-20 00:13:52 +0800 |
---|---|---|
committer | Armin Kuster <akuster808@gmail.com> | 2017-12-27 07:52:26 -0800 |
commit | 9c6309582611519c92ec11cbda5769e0f0f0c315 (patch) | |
tree | 9af30239ad1f51017cce7785c92412e6e8dea3d5 /meta-oe/recipes-graphics/dnfdragora | |
parent | 9473dddf8aecb73df88d7a1c83ad5643393ab057 (diff) | |
download | meta-openembedded-9c6309582611519c92ec11cbda5769e0f0f0c315.tar.gz |
dnfdragora: new add
Add a new recipe dnfdragora.
Signed-off-by: Zheng Ruoqin <zhengrq.fnst@cn.fujitsu.com>
Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe/recipes-graphics/dnfdragora')
5 files changed, 137 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/dnfdragora/dnfdragora/0001-Do-not-set-PYTHON_INSTALL_DIR-by-running-python.patch b/meta-oe/recipes-graphics/dnfdragora/dnfdragora/0001-Do-not-set-PYTHON_INSTALL_DIR-by-running-python.patch new file mode 100644 index 000000000..46d4dbde4 --- /dev/null +++ b/meta-oe/recipes-graphics/dnfdragora/dnfdragora/0001-Do-not-set-PYTHON_INSTALL_DIR-by-running-python.patch | |||
@@ -0,0 +1,26 @@ | |||
1 | From 80179c297abb9de2829bd02356257241dd414d70 Mon Sep 17 00:00:00 2001 | ||
2 | From: Lei Maohui <leimaohui@cn.fujitsu.com> | ||
3 | Date: Mon, 18 Dec 2017 16:25:54 +0900 | ||
4 | Subject: [PATCH] Do not set PYTHON_INSTALL_DIR by running python. | ||
5 | |||
6 | Signed-off-by: Lei Maohui <leimaohui@cn.fujitsu.com> | ||
7 | --- | ||
8 | CMakeLists.txt | 2 +- | ||
9 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
10 | |||
11 | diff --git a/CMakeLists.txt b/CMakeLists.txt | ||
12 | index 7c66b39..1489ef6 100644 | ||
13 | --- a/CMakeLists.txt | ||
14 | +++ b/CMakeLists.txt | ||
15 | @@ -19,7 +19,7 @@ else(NOT SPHINX_EXECUTABLE-NOTFOUND) | ||
16 | message(STATUS "Could NOT find sphinx-build.") | ||
17 | endif(NOT SPHINX_EXECUTABLE-NOTFOUND) | ||
18 | |||
19 | -execute_process(COMMAND ${PYTHON_EXECUTABLE} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib(), end='')" OUTPUT_VARIABLE PYTHON_INSTALL_DIR) | ||
20 | +#execute_process(COMMAND ${PYTHON_EXECUTABLE} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib(), end='')" OUTPUT_VARIABLE PYTHON_INSTALL_DIR) | ||
21 | string(REGEX REPLACE "\n$" "" ${PYTHON_INSTALL_DIR} "${PYTHON_INSTALL_DIR}") | ||
22 | execute_process(COMMAND ${PYTHON_EXECUTABLE} -c "import sys; sys.stdout.write('%s.%s' % (sys.version_info.major, sys.version_info.minor))" OUTPUT_VARIABLE PYTHON_MAJOR_DOT_MINOR_VERSION) | ||
23 | message(STATUS "Python install dir is ${PYTHON_INSTALL_DIR}") | ||
24 | -- | ||
25 | 2.7.4 | ||
26 | |||
diff --git a/meta-oe/recipes-graphics/dnfdragora/dnfdragora/0001-Run-python-scripts-using-env.patch b/meta-oe/recipes-graphics/dnfdragora/dnfdragora/0001-Run-python-scripts-using-env.patch new file mode 100644 index 000000000..75b6b8fd9 --- /dev/null +++ b/meta-oe/recipes-graphics/dnfdragora/dnfdragora/0001-Run-python-scripts-using-env.patch | |||
@@ -0,0 +1,25 @@ | |||
1 | From 15d0afcfa4868b7b072b3434bac0064617d61f99 Mon Sep 17 00:00:00 2001 | ||
2 | From: Lei Maohui <leimaohui@cn.fujitsu.com> | ||
3 | Date: Tue, 19 Dec 2017 14:53:14 +0900 | ||
4 | Subject: [PATCH] Run python scripts using env | ||
5 | |||
6 | Otherwise the build tools hardcode the python path into them. | ||
7 | |||
8 | Signed-off-by: Lei Maohui <leimaohui@cn.fujitsu.com> | ||
9 | --- | ||
10 | bin/dnfdragora | 2 +- | ||
11 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
12 | |||
13 | diff --git a/bin/dnfdragora b/bin/dnfdragora | ||
14 | index b8e0550..cd80f7f 100755 | ||
15 | --- a/bin/dnfdragora | ||
16 | +++ b/bin/dnfdragora | ||
17 | @@ -1,4 +1,4 @@ | ||
18 | -#!/usr/bin/python3 | ||
19 | +#!/usr/bin/env python3 | ||
20 | # vim: set et ts=4 sw=4: | ||
21 | # Copyright 2016-2017 Angelo Naselli <anaselli@linux.it> | ||
22 | # | ||
23 | -- | ||
24 | 2.7.4 | ||
25 | |||
diff --git a/meta-oe/recipes-graphics/dnfdragora/dnfdragora/0001-To-fix-error-when-do_package.patch b/meta-oe/recipes-graphics/dnfdragora/dnfdragora/0001-To-fix-error-when-do_package.patch new file mode 100644 index 000000000..90ce1d0ac --- /dev/null +++ b/meta-oe/recipes-graphics/dnfdragora/dnfdragora/0001-To-fix-error-when-do_package.patch | |||
@@ -0,0 +1,31 @@ | |||
1 | From 56d9b838b3475729d7ed9c6c156d72c28943c2b6 Mon Sep 17 00:00:00 2001 | ||
2 | From: Lei Maohui <leimaohui@cn.fujitsu.com> | ||
3 | Date: Tue, 19 Dec 2017 11:15:29 +0900 | ||
4 | Subject: [PATCH] To fix error when do_package | ||
5 | |||
6 | QA Issue: nativesdk-dnfdragora: Files/directories were installed but not shipped in any package: | ||
7 | /etc | ||
8 | /etc/dnfdragora | ||
9 | /etc/dnfdragora/dnfdragora.yaml | ||
10 | |||
11 | Signed-off-by: Lei Maohui <leimaohui@cn.fujitsu.com> | ||
12 | --- | ||
13 | CMakeLists.txt | 2 +- | ||
14 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
15 | |||
16 | diff --git a/CMakeLists.txt b/CMakeLists.txt | ||
17 | index 7c66b39..a5659f7 100644 | ||
18 | --- a/CMakeLists.txt | ||
19 | +++ b/CMakeLists.txt | ||
20 | @@ -52,7 +52,7 @@ endif(ENABLE_COMPS) | ||
21 | set(CMAKE_INSTALL_BINDIR "${CMAKE_INSTALL_PREFIX}/bin") | ||
22 | set(CMAKE_INSTALL_DATAROOTDIR "${CMAKE_INSTALL_PREFIX}/share") | ||
23 | set(CMAKE_INSTALL_LOCALEDIR "${CMAKE_INSTALL_DATAROOTDIR}/locale") | ||
24 | -set(CMAKE_INSTALL_FULL_SYSCONFDIR "/etc") | ||
25 | +set(CMAKE_INSTALL_FULL_SYSCONFDIR "${CMAKE_INSTALL_PREFIX}/../etc") | ||
26 | |||
27 | # Configure files | ||
28 | configure_file(${CMAKE_SOURCE_DIR}/etc/dnfdragora.yaml.in ${CMAKE_BINARY_DIR}/etc/dnfdragora.yaml @ONLY) | ||
29 | -- | ||
30 | 2.7.4 | ||
31 | |||
diff --git a/meta-oe/recipes-graphics/dnfdragora/dnfdragora/0001-disable-build-manpages.patch b/meta-oe/recipes-graphics/dnfdragora/dnfdragora/0001-disable-build-manpages.patch new file mode 100644 index 000000000..88bb63416 --- /dev/null +++ b/meta-oe/recipes-graphics/dnfdragora/dnfdragora/0001-disable-build-manpages.patch | |||
@@ -0,0 +1,25 @@ | |||
1 | From 2e6a0db24be373a5b7741dc5a0d322a28389fbf0 Mon Sep 17 00:00:00 2001 | ||
2 | From: Zheng Ruoqin <zhengrq.fnst@cn.fujitsu.com> | ||
3 | Date: Thu, 23 Nov 2017 16:35:44 +0900 | ||
4 | Subject: [PATCH] disable build manpages. | ||
5 | |||
6 | Signed-off-by: Zheng Ruoqin <zhengrq.fnst@cn.fujitsu.com> | ||
7 | --- | ||
8 | CMakeLists.txt | 1 - | ||
9 | 1 file changed, 1 deletion(-) | ||
10 | |||
11 | diff --git a/CMakeLists.txt b/CMakeLists.txt | ||
12 | index 7c66b39..fc32750 100644 | ||
13 | --- a/CMakeLists.txt | ||
14 | +++ b/CMakeLists.txt | ||
15 | @@ -65,7 +65,6 @@ endif(GETTEXT_FOUND) | ||
16 | |||
17 | # Build and install the man-pages | ||
18 | if(NOT SPHINX_EXECUTABLE-NOTFOUND) | ||
19 | - add_subdirectory(man) | ||
20 | endif(NOT SPHINX_EXECUTABLE-NOTFOUND) | ||
21 | |||
22 | # Installing application code | ||
23 | -- | ||
24 | 2.7.4 | ||
25 | |||
diff --git a/meta-oe/recipes-graphics/dnfdragora/dnfdragora_git.bb b/meta-oe/recipes-graphics/dnfdragora/dnfdragora_git.bb new file mode 100644 index 000000000..5678f7352 --- /dev/null +++ b/meta-oe/recipes-graphics/dnfdragora/dnfdragora_git.bb | |||
@@ -0,0 +1,30 @@ | |||
1 | SUMMARY = "dnfdragora is a DNF frontend, based on rpmdragora from Mageia (originally rpmdrake) Perl code." | ||
2 | LICENSE = "GPLv3" | ||
3 | LIC_FILES_CHKSUM = "file://LICENSE;md5=d32239bcb673463ab874e80d47fae504 \ | ||
4 | " | ||
5 | |||
6 | SRC_URI = "git://github.com/manatools/dnfdragora.git \ | ||
7 | file://0001-disable-build-manpages.patch \ | ||
8 | file://0001-Do-not-set-PYTHON_INSTALL_DIR-by-running-python.patch \ | ||
9 | file://0001-To-fix-error-when-do_package.patch \ | ||
10 | file://0001-Run-python-scripts-using-env.patch \ | ||
11 | " | ||
12 | |||
13 | PV = "1.0.1+git" | ||
14 | SRCREV = "4fef4ce889b8e4fa03191d414f63bfd50796152a" | ||
15 | |||
16 | S = "${WORKDIR}/git" | ||
17 | |||
18 | inherit cmake gettext pkgconfig python3-dir python3native distutils3-base | ||
19 | |||
20 | DEPENDS += "dnf python3 " | ||
21 | #DEPENDS_class-nativesdk += "nativesdk-python3" | ||
22 | |||
23 | RDEPENDS_${PN}_class-target = " python3-core libyui libyui-ncurses " | ||
24 | |||
25 | # manpages generation requires http://www.sphinx-doc.org/ | ||
26 | EXTRA_OECMAKE = " -DWITH_MAN=OFF -DPYTHON_INSTALL_DIR=${PYTHON_SITEPACKAGES_DIR} -DPYTHON_DESIRED=3" | ||
27 | |||
28 | BBCLASSEXTEND = "nativesdk" | ||
29 | |||
30 | FILES_${PN} = "${PYTHON_SITEPACKAGES_DIR}/ ${datadir}/ ${bindir}/ ${sysconfdir}/dnfdragora " | ||