summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-gnome
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2016-05-24 14:57:01 +0300
committerMartin Jansa <Martin.Jansa@gmail.com>2016-06-08 14:55:26 +0200
commitb4d7caaff9ee7e3ba2f5756b3d2ea2de498d4c2f (patch)
treea6c368b68b1a6181cca37fda37bf5444e20e4512 /meta-oe/recipes-gnome
parentf0de8ed2c3301b8629d87a4e3357d580d4db154a (diff)
downloadmeta-openembedded-b4d7caaff9ee7e3ba2f5756b3d2ea2de498d4c2f.tar.gz
gnome-doc-utils-stub: add a recipe
Real gnome-doc-utils can no longer be build (because it requires both python 2 and libxml2, which can only be build for one version of Python), so a stub recipe which provides just m4 macros is provided, and usage of gnome-doc-utils is disabled where needed. Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-gnome')
-rw-r--r--meta-oe/recipes-gnome/gnome-doc-utils-stub/files/gnome-doc-utils.m461
-rw-r--r--meta-oe/recipes-gnome/gnome-doc-utils-stub/gnome-doc-utils-stub_1.0.bb18
2 files changed, 79 insertions, 0 deletions
diff --git a/meta-oe/recipes-gnome/gnome-doc-utils-stub/files/gnome-doc-utils.m4 b/meta-oe/recipes-gnome/gnome-doc-utils-stub/files/gnome-doc-utils.m4
new file mode 100644
index 000000000..f8d160a9e
--- /dev/null
+++ b/meta-oe/recipes-gnome/gnome-doc-utils-stub/files/gnome-doc-utils.m4
@@ -0,0 +1,61 @@
1dnl Do not call GNOME_DOC_DEFINES directly. It is split out from
2dnl GNOME_DOC_INIT to allow gnome-doc-utils to bootstrap off itself.
3AC_DEFUN([GNOME_DOC_DEFINES],
4[
5AC_ARG_WITH([help-dir],
6 AC_HELP_STRING([--with-help-dir=DIR], [path to help docs]),,
7 [with_help_dir='${datadir}/gnome/help'])
8HELP_DIR="$with_help_dir"
9AC_SUBST(HELP_DIR)
10
11AC_ARG_WITH([omf-dir],
12 AC_HELP_STRING([--with-omf-dir=DIR], [path to OMF files]),,
13 [with_omf_dir='${datadir}/omf'])
14OMF_DIR="$with_omf_dir"
15AC_SUBST(OMF_DIR)
16
17AC_ARG_WITH([help-formats],
18 AC_HELP_STRING([--with-help-formats=FORMATS], [list of formats]),,
19 [with_help_formats=''])
20DOC_USER_FORMATS="$with_help_formats"
21AC_SUBST(DOC_USER_FORMATS)
22
23AC_ARG_ENABLE([scrollkeeper],
24 [AC_HELP_STRING([--disable-scrollkeeper],
25 [do not make updates to the scrollkeeper database])],,
26 enable_scrollkeeper=yes)
27AM_CONDITIONAL([ENABLE_SK],[test "$gdu_cv_have_gdu" = "yes" -a "$enable_scrollkeeper" = "yes"])
28
29dnl disable scrollkeeper automatically for distcheck
30DISTCHECK_CONFIGURE_FLAGS="--disable-scrollkeeper $DISTCHECK_CONFIGURE_FLAGS"
31AC_SUBST(DISTCHECK_CONFIGURE_FLAGS)
32
33AM_CONDITIONAL([HAVE_GNOME_DOC_UTILS],[test "$gdu_cv_have_gdu" = "yes"])
34])
35
36# GNOME_DOC_INIT ([MINIMUM-VERSION],[ACTION-IF-FOUND],[ACTION-IF-NOT-FOUND])
37#
38AC_DEFUN([GNOME_DOC_INIT],
39[AC_REQUIRE([AC_PROG_LN_S])dnl
40
41if test -z "$AM_DEFAULT_VERBOSITY"; then
42 AM_DEFAULT_VERBOSITY=1
43fi
44AC_SUBST([AM_DEFAULT_VERBOSITY])
45
46ifelse([$1],,[gdu_cv_version_required=0.3.2],[gdu_cv_version_required=$1])
47
48AC_MSG_CHECKING([gnome-doc-utils >= $gdu_cv_version_required])
49PKG_CHECK_EXISTS([gnome-doc-utils >= $gdu_cv_version_required],
50 [gdu_cv_have_gdu=yes],[gdu_cv_have_gdu=no])
51
52if test "$gdu_cv_have_gdu" = "yes"; then
53 AC_MSG_RESULT([yes])
54 ifelse([$2],,[:],[$2])
55else
56 AC_MSG_RESULT([no])
57 ifelse([$3],,[:],[$3])
58fi
59
60GNOME_DOC_DEFINES
61])
diff --git a/meta-oe/recipes-gnome/gnome-doc-utils-stub/gnome-doc-utils-stub_1.0.bb b/meta-oe/recipes-gnome/gnome-doc-utils-stub/gnome-doc-utils-stub_1.0.bb
new file mode 100644
index 000000000..d6da51b0d
--- /dev/null
+++ b/meta-oe/recipes-gnome/gnome-doc-utils-stub/gnome-doc-utils-stub_1.0.bb
@@ -0,0 +1,18 @@
1SUMMARY = "Stub implementation of gnome-doc-utils"
2DESCRIPTION = "This recipe provides m4 macros from gnome-doc-utils project, so \
3that dependent recipes can build. Gnome-doc-utils itself is no longer packaged because \
4it requires libxml2 and python 2 at the same time, which can no longer be satisfied. "
5LICENSE = "GPLv2 & LGPLv2.1"
6LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6 \
7 file://${COREBASE}/meta/files/common-licenses/LGPL-2.1;md5=1a6d268fd218675ffea8be556788b780"
8SRC_URI = "file://gnome-doc-utils.m4"
9
10PROVIDES = "gnome-doc-utils"
11
12do_install_append() {
13 install -d ${D}${datadir}/aclocal/
14 install ${WORKDIR}/gnome-doc-utils.m4 ${D}${datadir}/aclocal/
15}
16
17FILES_${PN} += "${datadir}"
18