summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-gnome/gnome
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-03-17 21:41:22 +0100
committerKoen Kooi <koen@dominion.thruhere.net>2011-03-17 21:41:22 +0100
commitc58cc7d3796dcee6e93885c835ed04cb566abeb2 (patch)
tree3eea4d4ef6a4ef79e0f4e025d7012c1a5cc38835 /meta-oe/recipes-gnome/gnome
parenteec6ab97f712e06eb52c9f7c99e19ffab3ce9d74 (diff)
downloadmeta-openembedded-c58cc7d3796dcee6e93885c835ed04cb566abeb2.tar.gz
move layer into meta-oe in preparation for future splits
As per TSC decision Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-gnome/gnome')
-rw-r--r--meta-oe/recipes-gnome/gnome/files/acinclude.m490
-rw-r--r--meta-oe/recipes-gnome/gnome/files/gtk-doc.m453
-rw-r--r--meta-oe/recipes-gnome/gnome/files/gtk-doc.make173
-rw-r--r--meta-oe/recipes-gnome/gnome/files/libproxy-move-define-__USE_BSD.patch17
-rw-r--r--meta-oe/recipes-gnome/gnome/files/tasn.m4161
-rw-r--r--meta-oe/recipes-gnome/gnome/gconf-native_2.6.1.bb17
-rw-r--r--meta-oe/recipes-gnome/gnome/gconf_2.28.0.bb40
-rw-r--r--meta-oe/recipes-gnome/gnome/orbit2-2.14.17/configure-lossage.patch37
-rw-r--r--meta-oe/recipes-gnome/gnome/orbit2-native_2.14.12.bb27
-rw-r--r--meta-oe/recipes-gnome/gnome/orbit2.inc32
-rw-r--r--meta-oe/recipes-gnome/gnome/orbit2/configure-lossage.patch35
-rw-r--r--meta-oe/recipes-gnome/gnome/orbit2/pkgconfig-fix.patch12
-rw-r--r--meta-oe/recipes-gnome/gnome/orbit2_2.14.17.bb5
13 files changed, 699 insertions, 0 deletions
diff --git a/meta-oe/recipes-gnome/gnome/files/acinclude.m4 b/meta-oe/recipes-gnome/gnome/files/acinclude.m4
new file mode 100644
index 000000000..53518fb2e
--- /dev/null
+++ b/meta-oe/recipes-gnome/gnome/files/acinclude.m4
@@ -0,0 +1,90 @@
1## this one is commonly used with AM_PATH_PYTHONDIR ...
2dnl AM_CHECK_PYMOD(MODNAME [,SYMBOL [,ACTION-IF-FOUND [,ACTION-IF-NOT-FOUND]]])
3dnl Check if a module containing a given symbol is visible to python.
4AC_DEFUN(AM_CHECK_PYMOD,
5[AC_REQUIRE([AM_PATH_PYTHON])
6py_mod_var=`echo $1['_']$2 | sed 'y%./+-%__p_%'`
7AC_MSG_CHECKING(for ifelse([$2],[],,[$2 in ])python module $1)
8AC_CACHE_VAL(py_cv_mod_$py_mod_var, [
9ifelse([$2],[], [prog="
10import sys
11try:
12 import $1
13except ImportError:
14 sys.exit(1)
15except:
16 sys.exit(0)
17sys.exit(0)"], [prog="
18import $1
19$1.$2"])
20if $PYTHON -c "$prog" 1>&AC_FD_CC 2>&AC_FD_CC
21 then
22 eval "py_cv_mod_$py_mod_var=yes"
23 else
24 eval "py_cv_mod_$py_mod_var=no"
25 fi
26])
27py_val=`eval "echo \`echo '$py_cv_mod_'$py_mod_var\`"`
28if test "x$py_val" != xno; then
29 AC_MSG_RESULT(yes)
30 ifelse([$3], [],, [$3
31])dnl
32else
33 AC_MSG_RESULT(no)
34 ifelse([$4], [],, [$4
35])dnl
36fi
37])
38
39dnl a macro to check for ability to create python extensions
40dnl AM_CHECK_PYTHON_HEADERS([ACTION-IF-POSSIBLE], [ACTION-IF-NOT-POSSIBLE])
41dnl function also defines PYTHON_INCLUDES
42AC_DEFUN([AM_CHECK_PYTHON_HEADERS],
43[AC_REQUIRE([AM_PATH_PYTHON])
44AC_MSG_CHECKING(for headers required to compile python extensions)
45dnl deduce PYTHON_INCLUDES
46AC_ARG_WITH(python-includes,
47 [ --with-python-includes=DIR path to Python includes], py_exec_prefix=$withval)
48if test x$py_exec_prefix != x; then
49PYTHON_INCLUDES="-I${py_exec_prefix}/include/python${PYTHON_VERSION}"
50else
51py_prefix=`$PYTHON -c "import sys; print sys.prefix"`
52py_exec_prefix=`$PYTHON -c "import sys; print sys.exec_prefix"`
53PYTHON_INCLUDES="-I${py_prefix}/include/python${PYTHON_VERSION}"
54if test "$py_prefix" != "$py_exec_prefix"; then
55 PYTHON_INCLUDES="$PYTHON_INCLUDES -I${py_exec_prefix}/include/python${PYTHON_VERSION}"
56fi
57fi
58AC_SUBST(PYTHON_INCLUDES)
59dnl check if the headers exist:
60save_CPPFLAGS="$CPPFLAGS"
61CPPFLAGS="$CPPFLAGS $PYTHON_INCLUDES"
62AC_TRY_CPP([#include <Python.h>],dnl
63[AC_MSG_RESULT(found)
64$1],dnl
65[AC_MSG_RESULT(not found)
66$2])
67CPPFLAGS="$save_CPPFLAGS"
68])
69
70dnl
71dnl JH_ADD_CFLAG(FLAG)
72dnl checks whether the C compiler supports the given flag, and if so, adds
73dnl it to $CFLAGS. If the flag is already present in the list, then the
74dnl check is not performed.
75AC_DEFUN([JH_ADD_CFLAG],
76[
77case " $CFLAGS " in
78*@<:@\ \ @:>@$1@<:@\ \ @:>@*)
79 ;;
80*)
81 save_CFLAGS="$CFLAGS"
82 CFLAGS="$CFLAGS $1"
83 AC_MSG_CHECKING([whether [$]CC understands $1])
84 AC_TRY_COMPILE([], [], [jh_has_option=yes], [jh_has_option=no])
85 AC_MSG_RESULT($jh_has_option)
86 if test $jh_has_option = no; then
87 CFLAGS="$save_CFLAGS"
88 fi
89 ;;
90esac])
diff --git a/meta-oe/recipes-gnome/gnome/files/gtk-doc.m4 b/meta-oe/recipes-gnome/gnome/files/gtk-doc.m4
new file mode 100644
index 000000000..3ec41666b
--- /dev/null
+++ b/meta-oe/recipes-gnome/gnome/files/gtk-doc.m4
@@ -0,0 +1,53 @@
1dnl -*- mode: autoconf -*-
2
3# serial 1
4
5dnl Usage:
6dnl GTK_DOC_CHECK([minimum-gtk-doc-version])
7AC_DEFUN([GTK_DOC_CHECK],
8[
9 AC_BEFORE([AC_PROG_LIBTOOL],[$0])dnl setup libtool first
10 AC_BEFORE([AM_PROG_LIBTOOL],[$0])dnl setup libtool first
11 dnl for overriding the documentation installation directory
12 AC_ARG_WITH(html-dir,
13 AC_HELP_STRING([--with-html-dir=PATH], [path to installed docs]),,
14 [with_html_dir='${datadir}/gtk-doc/html'])
15 HTML_DIR="$with_html_dir"
16 AC_SUBST(HTML_DIR)
17
18 dnl enable/disable documentation building
19 AC_ARG_ENABLE(gtk-doc,
20 AC_HELP_STRING([--enable-gtk-doc],
21 [use gtk-doc to build documentation [default=no]]),,
22 enable_gtk_doc=no)
23
24 have_gtk_doc=no
25 if test -z "$PKG_CONFIG"; then
26 AC_PATH_PROG(PKG_CONFIG, pkg-config, no)
27 fi
28 if test "$PKG_CONFIG" != "no" && $PKG_CONFIG --exists gtk-doc; then
29 have_gtk_doc=yes
30 fi
31
32 dnl do we want to do a version check?
33ifelse([$1],[],,
34 [gtk_doc_min_version=$1
35 if test "$have_gtk_doc" = yes; then
36 AC_MSG_CHECKING([gtk-doc version >= $gtk_doc_min_version])
37 if $PKG_CONFIG --atleast-version $gtk_doc_min_version gtk-doc; then
38 AC_MSG_RESULT(yes)
39 else
40 AC_MSG_RESULT(no)
41 have_gtk_doc=no
42 fi
43 fi
44])
45 if test x$enable_gtk_doc = xyes; then
46 if test "$have_gtk_doc" != yes; then
47 enable_gtk_doc=no
48 fi
49 fi
50
51 AM_CONDITIONAL(ENABLE_GTK_DOC, test x$enable_gtk_doc = xyes)
52 AM_CONDITIONAL(GTK_DOC_USE_LIBTOOL, test -n "$LIBTOOL")
53])
diff --git a/meta-oe/recipes-gnome/gnome/files/gtk-doc.make b/meta-oe/recipes-gnome/gnome/files/gtk-doc.make
new file mode 100644
index 000000000..354ffb7c6
--- /dev/null
+++ b/meta-oe/recipes-gnome/gnome/files/gtk-doc.make
@@ -0,0 +1,173 @@
1# -*- mode: makefile -*-
2
3####################################
4# Everything below here is generic #
5####################################
6
7if GTK_DOC_USE_LIBTOOL
8GTKDOC_CC = $(LIBTOOL) --mode=compile $(CC) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
9GTKDOC_LD = $(LIBTOOL) --mode=link $(CC) $(AM_CFLAGS) $(CFLAGS) $(AM_LDFLAGS) $(LDFLAGS)
10else
11GTKDOC_CC = $(CC) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
12GTKDOC_LD = $(CC) $(AM_CFLAGS) $(CFLAGS) $(AM_LDFLAGS) $(LDFLAGS)
13endif
14
15# We set GPATH here; this gives us semantics for GNU make
16# which are more like other make's VPATH, when it comes to
17# whether a source that is a target of one rule is then
18# searched for in VPATH/GPATH.
19#
20GPATH = $(srcdir)
21
22TARGET_DIR=$(HTML_DIR)/$(DOC_MODULE)
23
24EXTRA_DIST = \
25 $(content_files) \
26 $(HTML_IMAGES) \
27 $(DOC_MAIN_SGML_FILE) \
28 $(DOC_MODULE)-sections.txt \
29 $(DOC_MODULE)-overrides.txt
30
31DOC_STAMPS=scan-build.stamp tmpl-build.stamp sgml-build.stamp html-build.stamp \
32 $(srcdir)/tmpl.stamp $(srcdir)/sgml.stamp $(srcdir)/html.stamp
33
34SCANOBJ_FILES = \
35 $(DOC_MODULE).args \
36 $(DOC_MODULE).hierarchy \
37 $(DOC_MODULE).interfaces \
38 $(DOC_MODULE).prerequisites \
39 $(DOC_MODULE).signals
40
41REPORT_FILES = \
42 $(DOC_MODULE)-undocumented.txt \
43 $(DOC_MODULE)-undeclared.txt \
44 $(DOC_MODULE)-unused.txt
45
46CLEANFILES = $(SCANOBJ_FILES) $(REPORT_FILES) $(DOC_STAMPS)
47
48if ENABLE_GTK_DOC
49all-local: html-build.stamp
50else
51all-local:
52endif
53
54docs: html-build.stamp
55
56#### scan ####
57
58scan-build.stamp: $(HFILE_GLOB) $(CFILE_GLOB)
59 @echo 'gtk-doc: Scanning header files'
60 @-chmod -R u+w $(srcdir)
61 cd $(srcdir) && \
62 gtkdoc-scan --module=$(DOC_MODULE) --source-dir=$(DOC_SOURCE_DIR) --ignore-headers="$(IGNORE_HFILES)" $(SCAN_OPTIONS) $(EXTRA_HFILES)
63 if grep -l '^..*$$' $(srcdir)/$(DOC_MODULE).types > /dev/null 2>&1 ; then \
64 CC="$(GTKDOC_CC)" LD="$(GTKDOC_LD)" CFLAGS="$(GTKDOC_CFLAGS)" LDFLAGS="$(GTKDOC_LIBS)" gtkdoc-scangobj $(SCANGOBJ_OPTIONS) --module=$(DOC_MODULE) --output-dir=$(srcdir) ; \
65 else \
66 cd $(srcdir) ; \
67 for i in $(SCANOBJ_FILES) ; do \
68 test -f $$i || touch $$i ; \
69 done \
70 fi
71 touch scan-build.stamp
72
73$(DOC_MODULE)-decl.txt $(SCANOBJ_FILES) $(DOC_MODULE)-sections.txt $(DOC_MODULE)-overrides.txt: scan-build.stamp
74 @true
75
76#### templates ####
77
78tmpl-build.stamp: $(DOC_MODULE)-decl.txt $(SCANOBJ_FILES) $(DOC_MODULE)-sections.txt $(DOC_MODULE)-overrides.txt
79 @echo 'gtk-doc: Rebuilding template files'
80 @-chmod -R u+w $(srcdir)
81 cd $(srcdir) && gtkdoc-mktmpl --module=$(DOC_MODULE) $(MKTMPL_OPTIONS)
82 touch tmpl-build.stamp
83
84tmpl.stamp: tmpl-build.stamp
85 @true
86
87tmpl/*.sgml:
88 @true
89
90
91#### xml ####
92
93sgml-build.stamp: tmpl.stamp $(HFILE_GLOB) $(CFILE_GLOB) $(DOC_MODULE)-sections.txt $(srcdir)/tmpl/*.sgml $(expand_content_files)
94 @echo 'gtk-doc: Building XML'
95 @-chmod -R u+w $(srcdir)
96 cd $(srcdir) && \
97 gtkdoc-mkdb --module=$(DOC_MODULE) --source-dir=$(DOC_SOURCE_DIR) --output-format=xml --expand-content-files="$(expand_content_files)" --main-sgml-file=$(DOC_MAIN_SGML_FILE) $(MKDB_OPTIONS)
98 touch sgml-build.stamp
99
100sgml.stamp: sgml-build.stamp
101 @true
102
103#### html ####
104
105html-build.stamp: sgml.stamp $(DOC_MAIN_SGML_FILE) $(content_files)
106 @echo 'gtk-doc: Building HTML'
107 @-chmod -R u+w $(srcdir)
108 rm -rf $(srcdir)/html
109 mkdir $(srcdir)/html
110 cd $(srcdir)/html && gtkdoc-mkhtml $(DOC_MODULE) ../$(DOC_MAIN_SGML_FILE)
111 test "x$(HTML_IMAGES)" = "x" || ( cd $(srcdir) && cp $(HTML_IMAGES) html )
112 @echo 'gtk-doc: Fixing cross-references'
113 cd $(srcdir) && gtkdoc-fixxref --module-dir=html --html-dir=$(HTML_DIR) $(FIXXREF_OPTIONS)
114 touch html-build.stamp
115
116##############
117
118clean-local:
119 rm -f *~ *.bak
120 rm -rf .libs
121
122distclean-local:
123 cd $(srcdir) && \
124 rm -rf xml $(REPORT_FILES) \
125 $(DOC_MODULE)-decl-list.txt $(DOC_MODULE)-decl.txt
126
127maintainer-clean-local: clean
128 cd $(srcdir) && rm -rf xml html
129
130install-data-local:
131 -installfiles=`echo $(srcdir)/html/*`; \
132 if test "$$installfiles" = '$(srcdir)/html/*'; \
133 then echo '-- Nothing to install' ; \
134 else \
135 $(mkinstalldirs) $(DESTDIR)$(TARGET_DIR); \
136 for i in $$installfiles; do \
137 echo '-- Installing '$$i ; \
138 $(INSTALL_DATA) $$i $(DESTDIR)$(TARGET_DIR); \
139 done; \
140 echo '-- Installing $(srcdir)/html/index.sgml' ; \
141 $(INSTALL_DATA) $(srcdir)/html/index.sgml $(DESTDIR)$(TARGET_DIR) || :; \
142 which gtkdoc-rebase >/dev/null && \
143 gtkdoc-rebase --relative --dest-dir=$(DESTDIR) --html-dir=$(DESTDIR)$(TARGET_DIR) ; \
144 fi
145
146
147uninstall-local:
148 rm -f $(DESTDIR)$(TARGET_DIR)/*
149
150#
151# Require gtk-doc when making dist
152#
153if ENABLE_GTK_DOC
154dist-check-gtkdoc:
155else
156dist-check-gtkdoc:
157 @echo "*** gtk-doc must be installed and enabled in order to make dist"
158 @false
159endif
160
161dist-hook: dist-check-gtkdoc dist-hook-local
162 mkdir $(distdir)/tmpl
163 mkdir $(distdir)/xml
164 mkdir $(distdir)/html
165 -cp $(srcdir)/tmpl/*.sgml $(distdir)/tmpl
166 -cp $(srcdir)/xml/*.xml $(distdir)/xml
167 cp $(srcdir)/html/* $(distdir)/html
168 -cp $(srcdir)/$(DOC_MODULE).types $(distdir)/
169 -cp $(srcdir)/$(DOC_MODULE)-sections.txt $(distdir)/
170 cd $(distdir) && rm -f $(DISTCLEANFILES)
171 -gtkdoc-rebase --online --relative --html-dir=$(distdir)/html
172
173.PHONY : dist-hook-local docs
diff --git a/meta-oe/recipes-gnome/gnome/files/libproxy-move-define-__USE_BSD.patch b/meta-oe/recipes-gnome/gnome/files/libproxy-move-define-__USE_BSD.patch
new file mode 100644
index 000000000..b65b3608d
--- /dev/null
+++ b/meta-oe/recipes-gnome/gnome/files/libproxy-move-define-__USE_BSD.patch
@@ -0,0 +1,17 @@
1Index: libproxy-0.2.3/src/lib/dns.c
2===================================================================
3--- libproxy-0.2.3.orig/src/lib/dns.c 2009-08-14 14:13:21.123557812 -0700
4+++ libproxy-0.2.3/src/lib/dns.c 2009-08-14 14:13:31.954575500 -0700
5@@ -17,11 +17,11 @@
6 * Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA
7 ******************************************************************************/
8
9+#define __USE_BSD
10 #include <string.h>
11 #include <errno.h>
12 #include <stdio.h>
13 #include <netdb.h>
14-#define __USE_BSD
15 #include <unistd.h>
16
17 #include "misc.h"
diff --git a/meta-oe/recipes-gnome/gnome/files/tasn.m4 b/meta-oe/recipes-gnome/gnome/files/tasn.m4
new file mode 100644
index 000000000..6df32085a
--- /dev/null
+++ b/meta-oe/recipes-gnome/gnome/files/tasn.m4
@@ -0,0 +1,161 @@
1dnl Autoconf macros for libtasn1
2dnl $id$
3
4# Modified for LIBTASN1 -- nmav
5# Configure paths for LIBGCRYPT
6# Shamelessly stolen from the one of XDELTA by Owen Taylor
7# Werner Koch 99-12-09
8
9dnl AM_PATH_LIBTASN1([MINIMUM-VERSION, [ACTION-IF-FOUND [, ACTION-IF-NOT-FOUND ]]])
10dnl Test for libtasn1, and define LIBTASN1_CFLAGS and LIBTASN1_LIBS
11dnl
12AC_DEFUN([AM_PATH_LIBTASN1],
13[dnl
14dnl Get the cflags and libraries from the libtasn1-config script
15dnl
16AC_ARG_WITH(libtasn1-prefix,
17 [ --with-libtasn1-prefix=PFX Prefix where libtasn1 is installed (optional)],
18 libtasn1_config_prefix="$withval", libtasn1_config_prefix="")
19
20 if test x$libtasn1_config_prefix != x ; then
21 if test x${LIBTASN1_CONFIG+set} != xset ; then
22 LIBTASN1_CONFIG=$libtasn1_config_prefix/bin/libtasn1-config
23 fi
24 fi
25
26 AC_PATH_PROG(LIBTASN1_CONFIG, libtasn1-config, no)
27 min_libtasn1_version=ifelse([$1], ,0.1.0,$1)
28 AC_MSG_CHECKING(for libtasn1 - version >= $min_libtasn1_version)
29 no_libtasn1=""
30 if test "$LIBTASN1_CONFIG" = "no" ; then
31 no_libtasn1=yes
32 else
33 LIBTASN1_CFLAGS=`$LIBTASN1_CONFIG $libtasn1_config_args --cflags`
34 LIBTASN1_LIBS=`$LIBTASN1_CONFIG $libtasn1_config_args --libs`
35 libtasn1_config_version=`$LIBTASN1_CONFIG $libtasn1_config_args --version`
36
37
38 ac_save_CFLAGS="$CFLAGS"
39 ac_save_LIBS="$LIBS"
40 CFLAGS="$CFLAGS $LIBTASN1_CFLAGS"
41 LIBS="$LIBS $LIBTASN1_LIBS"
42dnl
43dnl Now check if the installed libtasn1 is sufficiently new. Also sanity
44dnl checks the results of libtasn1-config to some extent
45dnl
46 rm -f conf.libtasn1test
47 AC_TRY_RUN([
48#include <stdio.h>
49#include <stdlib.h>
50#include <string.h>
51#include <libtasn1.h>
52
53int
54main ()
55{
56 system ("touch conf.libtasn1test");
57
58 if( strcmp( asn1_check_version(NULL), "$libtasn1_config_version" ) )
59 {
60 printf("\n*** 'libtasn1-config --version' returned %s, but LIBTASN1 (%s)\n",
61 "$libtasn1_config_version", asn1_check_version(NULL) );
62 printf("*** was found! If libtasn1-config was correct, then it is best\n");
63 printf("*** to remove the old version of LIBTASN1. You may also be able to fix the error\n");
64 printf("*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing\n");
65 printf("*** /etc/ld.so.conf. Make sure you have run ldconfig if that is\n");
66 printf("*** required on your system.\n");
67 printf("*** If libtasn1-config was wrong, set the environment variable LIBTASN1_CONFIG\n");
68 printf("*** to point to the correct copy of libtasn1-config, and remove the file config.cache\n");
69 printf("*** before re-running configure\n");
70 }
71 else if ( strcmp(asn1_check_version(NULL), LIBTASN1_VERSION ) )
72 {
73 printf("\n*** LIBTASN1 header file (version %s) does not match\n", LIBTASN1_VERSION);
74 printf("*** library (version %s)\n", asn1_check_version(NULL) );
75 }
76 else
77 {
78 if ( asn1_check_version( "$min_libtasn1_version" ) )
79 {
80 return 0;
81 }
82 else
83 {
84 printf("no\n*** An old version of LIBTASN1 (%s) was found.\n",
85 asn1_check_version(NULL) );
86 printf("*** You need a version of LIBTASN1 newer than %s. The latest version of\n",
87 "$min_libtasn1_version" );
88 printf("*** LIBTASN1 is always available from ftp://gnutls.hellug.gr/pub/gnutls/libtasn1.\n");
89 printf("*** \n");
90 printf("*** If you have already installed a sufficiently new version, this error\n");
91 printf("*** probably means that the wrong copy of the libtasn1-config shell script is\n");
92 printf("*** being found. The easiest way to fix this is to remove the old version\n");
93 printf("*** of LIBTASN1, but you can also set the LIBTASN1_CONFIG environment to point to the\n");
94 printf("*** correct copy of libtasn1-config. (In this case, you will have to\n");
95 printf("*** modify your LD_LIBRARY_PATH enviroment variable, or edit /etc/ld.so.conf\n");
96 printf("*** so that the correct libraries are found at run-time))\n");
97 }
98 }
99 return 0;
100}
101],, no_libtasn1=yes,[echo $ac_n "cross compiling; assumed OK... $ac_c"])
102 CFLAGS="$ac_save_CFLAGS"
103 LIBS="$ac_save_LIBS"
104 fi
105
106 if test "x$no_libtasn1" = x ; then
107 AC_MSG_RESULT(yes)
108 ifelse([$2], , :, [$2])
109 else
110 if test -f conf.libtasn1test ; then
111 :
112 else
113 AC_MSG_RESULT(no)
114 fi
115 if test "$LIBTASN1_CONFIG" = "no" ; then
116 echo "*** The libtasn1-config script installed by LIBTASN1 could not be found"
117 echo "*** If LIBTASN1 was installed in PREFIX, make sure PREFIX/bin is in"
118 echo "*** your path, or set the LIBTASN1_CONFIG environment variable to the"
119 echo "*** full path to libtasn1-config."
120 else
121 if test -f conf.libtasn1test ; then
122 :
123 else
124 echo "*** Could not run libtasn1 test program, checking why..."
125 CFLAGS="$CFLAGS $LIBTASN1_CFLAGS"
126 LIBS="$LIBS $LIBTASN1_LIBS"
127 AC_TRY_LINK([
128#include <stdio.h>
129#include <stdlib.h>
130#include <string.h>
131#include <libtasn1.h>
132], [ return !!asn1_check_version(NULL); ],
133 [ echo "*** The test program compiled, but did not run. This usually means"
134 echo "*** that the run-time linker is not finding LIBTASN1 or finding the wrong"
135 echo "*** version of LIBTASN1. If it is not finding LIBTASN1, you'll need to set your"
136 echo "*** LD_LIBRARY_PATH environment variable, or edit /etc/ld.so.conf to point"
137 echo "*** to the installed location Also, make sure you have run ldconfig if that"
138 echo "*** is required on your system"
139 echo "***"
140 echo "*** If you have an old version installed, it is best to remove it, although"
141 echo "*** you may also be able to get things to work by modifying LD_LIBRARY_PATH"
142 echo "***" ],
143 [ echo "*** The test program failed to compile or link. See the file config.log for the"
144 echo "*** exact error that occured. This usually means LIBTASN1 was incorrectly installed"
145 echo "*** or that you have moved LIBTASN1 since it was installed. In the latter case, you"
146 echo "*** may want to edit the libtasn1-config script: $LIBTASN1_CONFIG" ])
147 CFLAGS="$ac_save_CFLAGS"
148 LIBS="$ac_save_LIBS"
149 fi
150 fi
151 LIBTASN1_CFLAGS=""
152 LIBTASN1_LIBS=""
153 ifelse([$3], , :, [$3])
154 fi
155 rm -f conf.libtasn1test
156 AC_SUBST(LIBTASN1_CFLAGS)
157 AC_SUBST(LIBTASN1_LIBS)
158])
159
160dnl *-*wedit:notab*-* Please keep this as the last line.
161
diff --git a/meta-oe/recipes-gnome/gnome/gconf-native_2.6.1.bb b/meta-oe/recipes-gnome/gnome/gconf-native_2.6.1.bb
new file mode 100644
index 000000000..fac712395
--- /dev/null
+++ b/meta-oe/recipes-gnome/gnome/gconf-native_2.6.1.bb
@@ -0,0 +1,17 @@
1NOTE = "This is just a dummy package to get packages stop complaining about gconftool-2 \
2 which they are not using anyway... :D"
3
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://${POKYBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
6
7PR = "r1"
8
9inherit native
10
11do_install() {
12 install -d ${D}${bindir}
13 echo "#!/bin/sh" >${D}${bindir}/gconftool-2
14 chmod a+rx ${D}${bindir}/gconftool-2
15}
16
17NATIVE_INSTALL_WORKS = "1"
diff --git a/meta-oe/recipes-gnome/gnome/gconf_2.28.0.bb b/meta-oe/recipes-gnome/gnome/gconf_2.28.0.bb
new file mode 100644
index 000000000..e167d8a6d
--- /dev/null
+++ b/meta-oe/recipes-gnome/gnome/gconf_2.28.0.bb
@@ -0,0 +1,40 @@
1DESCRIPTION = "GNOME configuration database system"
2SECTION = "x11/gnome"
3DEPENDS = "gtk+ orbit2 glib-2.0 libxml2 policykit"
4ORBIT_IDL_SRC = "${STAGING_BINDIR_NATIVE}/orbit-idl-2"
5
6LICENSE = "LGPLv2+"
7LIC_FILES_CHKSUM = "file://COPYING;md5=55ca817ccb7d5b5b66355690e9abc605"
8
9S = "${WORKDIR}/GConf-${PV}"
10
11SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/GConf/2.28/GConf-${PV}.tar.bz2;name=archive"
12SRC_URI[archive.md5sum] = "ad2aeb9c7d906b274954c51a615caeac"
13SRC_URI[archive.sha256sum] = "d057dcfe2bfb2a80e592349c2a78d7dce12d19542aeced466c64fb701c806ac8"
14
15PR = "r2"
16
17RDEPENDS_${PN} += "dbus-x11"
18
19EXTRA_OECONF = " --without-openldap --disable-gtk-doc --enable-gtk POLKIT_POLICY_FILE_VALIDATE=true"
20
21inherit autotools gettext
22
23EXTRA_OEMAKE = 'ORBIT_IDL="${ORBIT_IDL_SRC}"'
24
25do_install_append() {
26 # this directory need to be created to avoid an Error 256 at gdm launch
27 install -d ${D}${sysconfdir}/gconf/gconf.xml.system
28
29 # this stuff is unusable
30 rm ${D}${libdir}/GConf/*/*.*a
31}
32
33FILES_${PN} += "${libdir}/GConf/* \
34 ${datadir}/polkit* \
35 ${datadir}/dbus-1/services/*.service \
36 ${datadir}/dbus-1/system-services/*.service \
37"
38
39FILES_${PN}-dbg += "${libdir}/*/*/.debug"
40FILES_${PN}-dev += "${datadir}/sgml/gconf/gconf-1.0.dtd"
diff --git a/meta-oe/recipes-gnome/gnome/orbit2-2.14.17/configure-lossage.patch b/meta-oe/recipes-gnome/gnome/orbit2-2.14.17/configure-lossage.patch
new file mode 100644
index 000000000..5fc1de561
--- /dev/null
+++ b/meta-oe/recipes-gnome/gnome/orbit2-2.14.17/configure-lossage.patch
@@ -0,0 +1,37 @@
1--- ORBit2-2.14.17/configure.in-orig 2009-01-10 09:36:18.000000000 -0800
2+++ ORBit2-2.14.17/configure.in 2009-06-17 15:10:59.000000000 -0700
3@@ -217,20 +217,20 @@ dnl
4 dnl So many people with broken linking setups asked about this
5 dnl it turned out to be necessary to check for this.
6 dnl
7-dofus_save_libs="$LIBS"
8-LIBS="$ORBIT_LIBS $LIBS"
9-AC_TRY_RUN([ #include <stdio.h>
10- main ()
11- {
12- return 0;
13- } ],,
14- AC_MSG_ERROR([
15-Linking is badly borked on your system. Please ensure your library path is correct
16-Check config.log for details - check near the end of the log above 'failed program was'
17-Alternatively ensure that your /etc/ld.so.conf (and/or LD_LIBRARY_PATH) includes the
18-prefix you're compiling on: '${prefix}' ]),
19-AC_MSG_WARN([Could not check for borked linking while cross-compiling]))
20-LIBS="$dofus_save_libs"
21+dnl dofus_save_libs="$LIBS"
22+dnl LIBS="$ORBIT_LIBS $LIBS"
23+dnl AC_TRY_RUN([ #include <stdio.h>
24+dnl main ()
25+dnl {
26+dnl return 0;
27+dnl } ],,
28+dnl AC_MSG_ERROR([
29+dnl Linking is badly borked on your system. Please ensure your library path is correct
30+dnl Check config.log for details - check near the end of the log above 'failed program was'
31+dnl Alternatively ensure that your /etc/ld.so.conf (and/or LD_LIBRARY_PATH) includes the
32+dnl prefix you're compiling on: '${prefix}' ]),
33+dnl AC_MSG_WARN([Could not check for borked linking while cross-compiling]))
34+dnl LIBS="$dofus_save_libs"
35
36 orig_CPPFLAGS=$CPPFLAGS
37 CPPFLAGS="$CPPFLAGS $ORBIT_CFLAGS"
diff --git a/meta-oe/recipes-gnome/gnome/orbit2-native_2.14.12.bb b/meta-oe/recipes-gnome/gnome/orbit2-native_2.14.12.bb
new file mode 100644
index 000000000..1db2496c3
--- /dev/null
+++ b/meta-oe/recipes-gnome/gnome/orbit2-native_2.14.12.bb
@@ -0,0 +1,27 @@
1DESCRIPTION = "CORBA ORB"
2PR = "r0"
3LICENSE = "LGPL GPL"
4LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
5SECTION = "x11/gnome/libs"
6SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/ORBit2/2.14/ORBit2-${PV}.tar.bz2 \
7 file://configure-lossage.patch \
8 file://gtk-doc.m4 \
9 file://gtk-doc.make"
10DEPENDS = "libidl-native popt-native gtk-doc"
11
12S = "${WORKDIR}/ORBit2-${PV}"
13FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/orbit2"
14
15PARALLEL_MAKE = ""
16inherit autotools native pkgconfig
17
18EXTRA_OECONF = "--disable-gtk-doc"
19
20do_configure_prepend() {
21 mkdir -p m4
22 install ${WORKDIR}/gtk-doc.m4 ./m4/
23 install ${WORKDIR}/gtk-doc.make ./
24}
25
26SRC_URI[md5sum] = "6f4bf7d803d442e9d093a0daa203d506"
27SRC_URI[sha256sum] = "d60027a4a36e64d02723d00b76c08e8d92850cab6269b2edcda4a1bb30cc7723"
diff --git a/meta-oe/recipes-gnome/gnome/orbit2.inc b/meta-oe/recipes-gnome/gnome/orbit2.inc
new file mode 100644
index 000000000..51978909b
--- /dev/null
+++ b/meta-oe/recipes-gnome/gnome/orbit2.inc
@@ -0,0 +1,32 @@
1LICENSE = "GPL"
2DESCRIPTION = "CORBA ORB"
3SECTION = "x11/gnome/libs"
4SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/ORBit2/2.14/ORBit2-${PV}.tar.bz2 \
5 file://configure-lossage.patch \
6 file://pkgconfig-fix.patch \
7 file://gtk-doc.m4 \
8 file://gtk-doc.make"
9DEPENDS = "libidl popt orbit2-native gtk-doc"
10PARALLEL_MAKE = ""
11
12LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
13
14FILES_${PN} += "${libdir}/orbit-2.0/*.so"
15FILES_${PN}-dev += "${libdir}/orbit-2.0/*.a ${libdir}/orbit-2.0/*.la"
16FILES_${PN}-dbg += "${libdir}/orbit-2.0/.debug"
17
18S = "${WORKDIR}/ORBit2-${PV}"
19
20LEAD_SONAME = "libORBit-2.so"
21
22inherit autotools pkgconfig
23
24EXTRA_OECONF = "--disable-gtk-doc"
25EXTRA_OEMAKE = "IDL_COMPILER='${STAGING_BINDIR_NATIVE}/orbit-idl-2'"
26
27do_configure_prepend() {
28 mkdir -p m4
29 install ${WORKDIR}/gtk-doc.m4 ./m4/
30 install ${WORKDIR}/gtk-doc.make ./
31}
32
diff --git a/meta-oe/recipes-gnome/gnome/orbit2/configure-lossage.patch b/meta-oe/recipes-gnome/gnome/orbit2/configure-lossage.patch
new file mode 100644
index 000000000..7485a0ce0
--- /dev/null
+++ b/meta-oe/recipes-gnome/gnome/orbit2/configure-lossage.patch
@@ -0,0 +1,35 @@
1--- orbit/configure.in~ 2004-05-07 09:31:32.000000000 +0100
2+++ orbit/configure.in 2004-05-08 19:27:35.000000000 +0100
3@@ -193,19 +193,19 @@
4 dnl So many people with broken linking setups asked about this
5 dnl it turned out to be necessary to check for this.
6 dnl
7-dofus_save_libs="$LIBS"
8-LIBS="$ORBIT_LIBS $LIBS"
9-AC_TRY_RUN([ #include <stdio.h>
10- main ()
11- {
12- return 0;
13- } ],,
14- AC_MSG_ERROR([
15-Linking is badly borked on your system. Please ensure your library path is correct
16-Check config.log for details - check near the end of the log above 'failed program was'
17-Alternatively ensure that your /etc/ld.so.conf (and/or LD_LIBRARY_PATH) includes the
18-prefix you're compiling on: '${prefix}' ]))
19-LIBS="$dofus_save_libs"
20+dnl dofus_save_libs="$LIBS"
21+dnl LIBS="$ORBIT_LIBS $LIBS"
22+dnl AC_TRY_RUN([ #include <stdio.h>
23+dnl main ()
24+dnl {
25+dnl return 0;
26+dnl } ],,
27+dnl AC_MSG_ERROR([
28+dnl Linking is badly borked on your system. Please ensure your library path is correct
29+dnl Check config.log for details - check near the end of the log above 'failed program was'
30+dnl Alternatively ensure that your /etc/ld.so.conf (and/or LD_LIBRARY_PATH) includes the
31+dnl prefix you're compiling on: '${prefix}' ]))
32+dnl LIBS="$dofus_save_libs"
33
34 orig_CPPFLAGS=$CPPFLAGS
35 CPPFLAGS="$CPPFLAGS $ORBIT_CFLAGS"
diff --git a/meta-oe/recipes-gnome/gnome/orbit2/pkgconfig-fix.patch b/meta-oe/recipes-gnome/gnome/orbit2/pkgconfig-fix.patch
new file mode 100644
index 000000000..f629e506d
--- /dev/null
+++ b/meta-oe/recipes-gnome/gnome/orbit2/pkgconfig-fix.patch
@@ -0,0 +1,12 @@
1diff -urN ORBit2-2.14.12.orig/ORBit-2.0.pc.in ORBit2-2.14.12/ORBit-2.0.pc.in
2--- ORBit2-2.14.12.orig/ORBit-2.0.pc.in 2008-01-29 13:45:22.000000000 +0100
3+++ ORBit2-2.14.12/ORBit-2.0.pc.in 2008-09-23 20:13:07.000000000 +0200
4@@ -2,7 +2,7 @@
5 exec_prefix=@exec_prefix@
6 libdir=@libdir@
7 includedir=@includedir@
8-orbit_idl=@bindir@/orbit-idl-2@EXEEXT@
9+orbit_idl=@exec_prefix@/bin/orbit-idl-2@EXEEXT@
10
11
12 Name: ORBit-2.0
diff --git a/meta-oe/recipes-gnome/gnome/orbit2_2.14.17.bb b/meta-oe/recipes-gnome/gnome/orbit2_2.14.17.bb
new file mode 100644
index 000000000..47f632793
--- /dev/null
+++ b/meta-oe/recipes-gnome/gnome/orbit2_2.14.17.bb
@@ -0,0 +1,5 @@
1require orbit2.inc
2
3
4SRC_URI[md5sum] = "10bfb957fa4a8935a0b4afaee7d71df7"
5SRC_URI[sha256sum] = "62bfce3f678f9347a19c766944e8aef7b89bc32b25ac23eb3e4c25929ce8974c"