summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2014-09-25 16:48:38 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2014-09-26 05:42:54 +0200
commit0d01e1b72333f49c29d1a27ad844c4cd9f90341c (patch)
tree7fd294922793df3548be50bcf2b1815db01794fb /meta-oe/recipes-extended
parent3468c59c5cc382a66621bace78648479dc853db0 (diff)
downloadmeta-openembedded-0d01e1b72333f49c29d1a27ad844c4cd9f90341c.tar.gz
smartmontools: add systemd service file
Add systemd service file for smartmontools. The service is disabled by default. Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended')
-rw-r--r--meta-oe/recipes-extended/smartmontools/files/smartd.service12
-rw-r--r--meta-oe/recipes-extended/smartmontools/smartmontools_6.2.bb14
2 files changed, 25 insertions, 1 deletions
diff --git a/meta-oe/recipes-extended/smartmontools/files/smartd.service b/meta-oe/recipes-extended/smartmontools/files/smartd.service
new file mode 100644
index 000000000..f3db946c8
--- /dev/null
+++ b/meta-oe/recipes-extended/smartmontools/files/smartd.service
@@ -0,0 +1,12 @@
1[Unit]
2Description=Self Monitoring and Reporting Technology (SMART) Daemon
3After=syslog.target
4
5[Service]
6EnvironmentFile=-@SYSCONFDIR@/smartmontools
7ExecStart=@SBINDIR@/smartd -n $smart_opts
8ExecReload=@BASE_BINDIR@/kill -HUP $MAINPID
9StandardOutput=syslog
10
11[Install]
12WantedBy=multi-user.target
diff --git a/meta-oe/recipes-extended/smartmontools/smartmontools_6.2.bb b/meta-oe/recipes-extended/smartmontools/smartmontools_6.2.bb
index b64b96191..fd7b1b8c5 100644
--- a/meta-oe/recipes-extended/smartmontools/smartmontools_6.2.bb
+++ b/meta-oe/recipes-extended/smartmontools/smartmontools_6.2.bb
@@ -15,6 +15,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
15SRC_URI = "${SOURCEFORGE_MIRROR}/smartmontools/smartmontools-${PV}.tar.gz \ 15SRC_URI = "${SOURCEFORGE_MIRROR}/smartmontools/smartmontools-${PV}.tar.gz \
16 file://initd.smartd \ 16 file://initd.smartd \
17 file://smartmontools.default \ 17 file://smartmontools.default \
18 file://smartd.service \
18 " 19 "
19 20
20PACKAGECONFIG ??= "${@base_contains('DISTRO_FEATURES', 'libcap-ng', 'libcap-ng', '', d)} \ 21PACKAGECONFIG ??= "${@base_contains('DISTRO_FEATURES', 'libcap-ng', 'libcap-ng', '', d)} \
@@ -26,7 +27,10 @@ PACKAGECONFIG[selinux] = "--with-selinux=yes,--with-selinux=no,libselinux"
26SRC_URI[md5sum] = "d44f84081a12cef79cd17f78044351fc" 27SRC_URI[md5sum] = "d44f84081a12cef79cd17f78044351fc"
27SRC_URI[sha256sum] = "486f660579bb0fb4f6b927ded7531cb1f99685c666397377761c5b04dd96065b" 28SRC_URI[sha256sum] = "486f660579bb0fb4f6b927ded7531cb1f99685c666397377761c5b04dd96065b"
28 29
29inherit autotools update-rc.d 30inherit autotools update-rc.d systemd
31
32SYSTEMD_SERVICE_${PN} = "smartd.service"
33SYSTEMD_AUTO_ENABLE = "disable"
30 34
31do_install_append () { 35do_install_append () {
32 #install the init.d/smartd 36 #install the init.d/smartd
@@ -34,6 +38,14 @@ do_install_append () {
34 install -p -m 0755 ${WORKDIR}/initd.smartd ${D}${sysconfdir}/init.d/smartd 38 install -p -m 0755 ${WORKDIR}/initd.smartd ${D}${sysconfdir}/init.d/smartd
35 install -d ${D}${sysconfdir}/default 39 install -d ${D}${sysconfdir}/default
36 install -p -m 0644 ${WORKDIR}/smartmontools.default ${D}${sysconfdir}/default/smartmontools 40 install -p -m 0644 ${WORKDIR}/smartmontools.default ${D}${sysconfdir}/default/smartmontools
41
42 #install systemd service file
43 install -d ${D}${systemd_unitdir}/system
44 install -m 0644 ${WORKDIR}/smartd.service ${D}${systemd_unitdir}/system
45 sed -i -e 's,@BASE_BINDIR@,${base_bindir},g' \
46 -e 's,@SYSCONFDIR@,${sysconfdir},g' \
47 -e 's,@SBINDIR@,${sbindir},g' \
48 ${D}${systemd_unitdir}/system/smartd.service
37} 49}
38 50
39INITSCRIPT_NAME = "smartd" 51INITSCRIPT_NAME = "smartd"