summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended
diff options
context:
space:
mode:
authorWenzong Fan <wenzong.fan@windriver.com>2016-09-20 01:57:25 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2016-09-26 08:29:13 +0200
commitb2d3dacc5e56de23195a98929cb21e5abf1e2812 (patch)
treea4a184d5b6d157031f8613d284778524109e2ff6 /meta-oe/recipes-extended
parent0de66c207c0b633401ab88fe66bbf478b3ac7754 (diff)
downloadmeta-openembedded-b2d3dacc5e56de23195a98929cb21e5abf1e2812.tar.gz
rsyslog: upgrade to 7.6.7
* fix CVEs CVE-2014-3634, CVE-2014-3683 * rebase the patch use-pkgconfig-to-check-libgcrypt.patch * backport fixes for build error: lexer.l:34:14: error: expected identifier or '(' before '__extension__' * replace the old configure option '--enable-cached-man-pages' with '--disable-generate-man-pages' Signed-off-by: Wenzong Fan <wenzong.fan@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended')
-rw-r--r--meta-oe/recipes-extended/rsyslog/rsyslog/bugfix-include-config.h-before-any-other-headers.patch51
-rw-r--r--meta-oe/recipes-extended/rsyslog/rsyslog/use-pkgconfig-to-check-libgcrypt.patch25
-rw-r--r--meta-oe/recipes-extended/rsyslog/rsyslog_7.6.7.bb (renamed from meta-oe/recipes-extended/rsyslog/rsyslog_7.6.1.bb)7
3 files changed, 66 insertions, 17 deletions
diff --git a/meta-oe/recipes-extended/rsyslog/rsyslog/bugfix-include-config.h-before-any-other-headers.patch b/meta-oe/recipes-extended/rsyslog/rsyslog/bugfix-include-config.h-before-any-other-headers.patch
new file mode 100644
index 000000000..1048b423d
--- /dev/null
+++ b/meta-oe/recipes-extended/rsyslog/rsyslog/bugfix-include-config.h-before-any-other-headers.patch
@@ -0,0 +1,51 @@
1Backport below commit for fixing:
2
3lexer.l:34:14: error: expected identifier or '(' before '__extension__'
4
5From 876bdd1c85353f7e254f4b4c3e228484860cea57 Mon Sep 17 00:00:00 2001
6From: Tomas Heinrich <theinric@redhat.com>
7Date: Mon, 17 Nov 2014 20:53:22 +0100
8Subject: [PATCH] bugfix: include config.h before any other headers
9
10For some reason, flex used to prepend several standard headers before
11config.h. This prevented some conditional extension in these headers
12from being defined.
13
14The explicit prototype for strdup() shouldn't be required anymore as
15it should be provided by string.h.
16
17Upstream-Status: Backport
18---
19 grammar/lexer.l | 7 +++++--
20 1 file changed, 5 insertions(+), 2 deletions(-)
21
22diff --git a/grammar/lexer.l b/grammar/lexer.l
23index 359cf9f..c834ef7 100644
24--- a/grammar/lexer.l
25+++ b/grammar/lexer.l
26@@ -28,10 +28,12 @@
27 * limitations under the License.
28 */
29
30-%{
31+%top{
32 #include "config.h"
33+}
34+
35+%{
36 #include "parserif.h"
37-extern char *strdup(__const char*); /* somehow we may not get this from string.h... */
38 %}
39
40 %option noyywrap nodefault case-insensitive yylineno
41@@ -67,6 +69,7 @@ extern char *strdup(__const char*); /* somehow we may not get this from string.h
42 #include <ctype.h>
43 #include <stdio.h>
44 #include <stdlib.h>
45+#include <string.h>
46 #include <strings.h>
47 #include <libestr.h>
48 #include "rainerscript.h"
49--
502.7.4
51
diff --git a/meta-oe/recipes-extended/rsyslog/rsyslog/use-pkgconfig-to-check-libgcrypt.patch b/meta-oe/recipes-extended/rsyslog/rsyslog/use-pkgconfig-to-check-libgcrypt.patch
index ebc10707c..46eddd604 100644
--- a/meta-oe/recipes-extended/rsyslog/rsyslog/use-pkgconfig-to-check-libgcrypt.patch
+++ b/meta-oe/recipes-extended/rsyslog/rsyslog/use-pkgconfig-to-check-libgcrypt.patch
@@ -9,34 +9,31 @@ libgcrypt does no longer provide libgcrypt-config, and provide
9*.pc, so we should use pkgconfig to check 9*.pc, so we should use pkgconfig to check
10 10
11Signed-off-by: Roy Li <rongqing.li@windriver.com> 11Signed-off-by: Roy Li <rongqing.li@windriver.com>
12Signed-off-by: Wenzong Fan <wenzong.fan@windriver.com>
12--- 13---
13 configure.ac | 19 +------------------ 14 configure.ac | 15 +--------------
14 1 file changed, 1 insertion(+), 18 deletions(-) 15 1 file changed, 1 insertion(+), 14 deletions(-)
15 16
16diff --git a/configure.ac b/configure.ac 17diff --git a/configure.ac b/configure.ac
17index 017116e..1b880f8 100644 18index 0f31869..d35db42 100644
18--- a/configure.ac 19--- a/configure.ac
19+++ b/configure.ac 20+++ b/configure.ac
20@@ -784,24 +784,7 @@ AC_ARG_ENABLE(libgcrypt, 21@@ -777,20 +777,7 @@ AC_ARG_ENABLE(libgcrypt,
21 [enable_libgcrypt=yes] 22 [enable_libgcrypt=yes]
22 ) 23 )
23 if test "x$enable_libgcrypt" = "xyes"; then 24 if test "x$enable_libgcrypt" = "xyes"; then
24- AC_CHECK_PROG( 25- AC_PATH_PROG([LIBGCRYPT_CONFIG],[libgcrypt-config],[no])
25- [HAVE_LIBGCRYPT_CONFIG], 26- if test "x${LIBGCRYPT_CONFIG}" = "xno"; then
26- [libgcrypt-config],
27- [yes],,,
28- )
29- if test "x${HAVE_LIBGCRYPT_CONFIG}" != "xyes"; then
30- AC_MSG_FAILURE([libgcrypt-config not found in PATH]) 27- AC_MSG_FAILURE([libgcrypt-config not found in PATH])
31- fi 28- fi
32- AC_CHECK_LIB( 29- AC_CHECK_LIB(
33- [gcrypt], 30- [gcrypt],
34- [gcry_cipher_open], 31- [gcry_cipher_open],
35- [LIBGCRYPT_CFLAGS="`libgcrypt-config --cflags`" 32- [LIBGCRYPT_CFLAGS="`${LIBGCRYPT_CONFIG} --cflags`"
36- LIBGCRYPT_LIBS="`libgcrypt-config --libs`" 33- LIBGCRYPT_LIBS="`${LIBGCRYPT_CONFIG} --libs`"
37- ], 34- ],
38- [AC_MSG_FAILURE([libgcrypt is missing])], 35- [AC_MSG_FAILURE([libgcrypt is missing])],
39- [`libgcrypt-config --libs --cflags`] 36- [`${LIBGCRYPT_CONFIG} --libs --cflags`]
40- ) 37- )
41- AC_DEFINE([ENABLE_LIBGCRYPT], [1], [Indicator that LIBGCRYPT is present]) 38- AC_DEFINE([ENABLE_LIBGCRYPT], [1], [Indicator that LIBGCRYPT is present])
42+ PKG_CHECK_MODULES(LIBGCRYPT, libgcrypt) 39+ PKG_CHECK_MODULES(LIBGCRYPT, libgcrypt)
@@ -44,5 +41,5 @@ index 017116e..1b880f8 100644
44 AM_CONDITIONAL(ENABLE_LIBGCRYPT, test x$enable_libgcrypt = xyes) 41 AM_CONDITIONAL(ENABLE_LIBGCRYPT, test x$enable_libgcrypt = xyes)
45 AC_SUBST(LIBGCRYPT_CFLAGS) 42 AC_SUBST(LIBGCRYPT_CFLAGS)
46-- 43--
471.7.9.5 442.8.1
48 45
diff --git a/meta-oe/recipes-extended/rsyslog/rsyslog_7.6.1.bb b/meta-oe/recipes-extended/rsyslog/rsyslog_7.6.7.bb
index c1d923c75..664ab9ff7 100644
--- a/meta-oe/recipes-extended/rsyslog/rsyslog_7.6.1.bb
+++ b/meta-oe/recipes-extended/rsyslog/rsyslog_7.6.7.bb
@@ -27,15 +27,16 @@ SRC_URI = "http://www.rsyslog.com/download/files/download/rsyslog/${BPN}-${PV}.t
27 file://json-0.12-fix.patch \ 27 file://json-0.12-fix.patch \
28 file://replace_deprecated_GnuTLS_functions.patch \ 28 file://replace_deprecated_GnuTLS_functions.patch \
29 file://use_gnutls_certificate_type_set_priority_only_if_available.patch \ 29 file://use_gnutls_certificate_type_set_priority_only_if_available.patch \
30 file://bugfix-include-config.h-before-any-other-headers.patch \
30 file://enable_tls_ptests.patch \ 31 file://enable_tls_ptests.patch \
31" 32"
32 33
33SRC_URI[md5sum] = "093c462a5245012bd9e7b82dd8aedffb" 34SRC_URI[md5sum] = "fa78a6e675fe78a811edcdf7eb6f1975"
34SRC_URI[sha256sum] = "357f089d866c351d5fe5b7139fa85b010223d77b3c21f29b2a1baa8688926111" 35SRC_URI[sha256sum] = "fc29d2d9cbf3396091dd0bab2eb6f847aed4a44ef73138a97ddf9447446125ee"
35 36
36inherit autotools pkgconfig systemd update-rc.d update-alternatives ptest 37inherit autotools pkgconfig systemd update-rc.d update-alternatives ptest
37 38
38EXTRA_OECONF += "--enable-cached-man-pages" 39EXTRA_OECONF += "--disable-generate-man-pages"
39 40
40# first line is default yes in configure 41# first line is default yes in configure
41PACKAGECONFIG ??= " \ 42PACKAGECONFIG ??= " \