summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2016-10-18 22:38:22 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2016-10-26 10:28:38 +0200
commit2280f696f85d1a751b0163770599e227b62a3b55 (patch)
tree0d94455a9f62e7259f0ec841047e80181b2d2fcc /meta-oe/recipes-extended
parent577604b93c14a2ecc96ad26f85f9baea29bf5bda (diff)
downloadmeta-openembedded-2280f696f85d1a751b0163770599e227b62a3b55.tar.gz
libplist: Squash warnings found by clang
Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended')
-rw-r--r--meta-oe/recipes-extended/libimobiledevice/files/0001-Fix-warnings-found-with-clang.patch51
-rw-r--r--meta-oe/recipes-extended/libimobiledevice/libplist_1.8.bb3
2 files changed, 53 insertions, 1 deletions
diff --git a/meta-oe/recipes-extended/libimobiledevice/files/0001-Fix-warnings-found-with-clang.patch b/meta-oe/recipes-extended/libimobiledevice/files/0001-Fix-warnings-found-with-clang.patch
new file mode 100644
index 000000000..f8114a063
--- /dev/null
+++ b/meta-oe/recipes-extended/libimobiledevice/files/0001-Fix-warnings-found-with-clang.patch
@@ -0,0 +1,51 @@
1From ad1be542b87b3186f8ef7bee2c594daefe5bb4c8 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Tue, 18 Oct 2016 21:31:40 +0000
4Subject: [PATCH] Fix warnings found with clang
5
6| /mnt/oe/openembedded-core/build/workspace/sources/libplist/src/base64.c:107:12: error: non-void function 'base64decode' should return a value [-Wreturn-type]
7| if (!buf) return;
8| ^
9| /mnt/oe/openembedded-core/build/workspace/sources/libplist/src/base64.c:109:16: error: non-void function 'base64decode' should return a value [-Wreturn-type]
10| if (len <= 0) return;
11
12Upstream-Status: Pending
13
14Signed-off-by: Khem Raj <raj.khem@gmail.com>
15---
16 libcnary/node.c | 2 +-
17 src/base64.c | 4 ++--
18 2 files changed, 3 insertions(+), 3 deletions(-)
19
20diff --git a/libcnary/node.c b/libcnary/node.c
21index 1f9f669..d6f3f63 100644
22--- a/libcnary/node.c
23+++ b/libcnary/node.c
24@@ -104,7 +104,7 @@ int node_detach(node_t* parent, node_t* child) {
25
26 int node_insert(node_t* parent, unsigned int index, node_t* child)
27 {
28- if (!parent || !child) return;
29+ if (!parent || !child) return -1;
30 child->isLeaf = TRUE;
31 child->isRoot = FALSE;
32 child->parent = parent;
33diff --git a/src/base64.c b/src/base64.c
34index 65c6061..531a06a 100644
35--- a/src/base64.c
36+++ b/src/base64.c
37@@ -104,9 +104,9 @@ static int base64decode_block(unsigned char *target, const char *data, size_t da
38
39 unsigned char *base64decode(const char *buf, size_t *size)
40 {
41- if (!buf) return;
42+ if (!buf) return 0;
43 size_t len = strlen(buf);
44- if (len <= 0) return;
45+ if (len <= 0) return 0;
46 unsigned char *outbuf = (unsigned char*)malloc((len/4)*3+3);
47
48 unsigned char *line;
49--
501.9.1
51
diff --git a/meta-oe/recipes-extended/libimobiledevice/libplist_1.8.bb b/meta-oe/recipes-extended/libimobiledevice/libplist_1.8.bb
index 6e8d69f60..10d40fbaf 100644
--- a/meta-oe/recipes-extended/libimobiledevice/libplist_1.8.bb
+++ b/meta-oe/recipes-extended/libimobiledevice/libplist_1.8.bb
@@ -10,7 +10,8 @@ inherit cmake pkgconfig
10 10
11SRC_URI = "http://www.libimobiledevice.org/downloads/libplist-${PV}.tar.bz2 \ 11SRC_URI = "http://www.libimobiledevice.org/downloads/libplist-${PV}.tar.bz2 \
12 file://fix-parallel-make.patch \ 12 file://fix-parallel-make.patch \
13" 13 file://0001-Fix-warnings-found-with-clang.patch \
14 "
14 15
15SRC_URI[md5sum] = "2a9e0258847d50f9760dc3ece25f4dc6" 16SRC_URI[md5sum] = "2a9e0258847d50f9760dc3ece25f4dc6"
16SRC_URI[sha256sum] = "a418da3880308199b74766deef2a760a9b169b81a868a6a9032f7614e20500ec" 17SRC_URI[sha256sum] = "a418da3880308199b74766deef2a760a9b169b81a868a6a9032f7614e20500ec"