summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2022-04-20 11:38:04 -0700
committerKhem Raj <raj.khem@gmail.com>2022-04-21 07:14:38 -0700
commita4e7ad4568ff4bb35155fe67d58e0c175cae89f9 (patch)
tree9980bde4e81f6d4fdde25e9619b19f8018955414 /meta-oe/recipes-extended
parentcc8efa1fe957a83452089a082cc23a76bae64c52 (diff)
downloadmeta-openembedded-a4e7ad4568ff4bb35155fe67d58e0c175cae89f9.tar.gz
mozjs-91: Add option to use system ICU
ARM needs to use system icu, otherwise build fails with gcc-12 firefox-91.8.0/intl/icu/source/common/stringtriebuilder.cpp:388: more undefined references to `std::type_info::operator==(std::type_info const&) const' follow | collect2: error: ld returned 1 exit status Keep using vendored ICU on mips since this breaks build for gjs introspection code which is run under qemu-user Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended')
-rw-r--r--meta-oe/recipes-extended/mozjs/mozjs-91_91.8.0.bb10
1 files changed, 6 insertions, 4 deletions
diff --git a/meta-oe/recipes-extended/mozjs/mozjs-91_91.8.0.bb b/meta-oe/recipes-extended/mozjs/mozjs-91_91.8.0.bb
index d0accfaae..af9256860 100644
--- a/meta-oe/recipes-extended/mozjs/mozjs-91_91.8.0.bb
+++ b/meta-oe/recipes-extended/mozjs/mozjs-91_91.8.0.bb
@@ -22,7 +22,8 @@ S = "${WORKDIR}/firefox-${@d.getVar("PV").replace("esr", "")}"
22 22
23inherit pkgconfig perlnative python3native rust 23inherit pkgconfig perlnative python3native rust
24 24
25DEPENDS += "zlib cargo-native python3" 25DEPENDS += "zlib cargo-native python3 icu"
26DEPENDS:remove:mipsarch = "icu"
26 27
27B = "${WORKDIR}/build" 28B = "${WORKDIR}/build"
28 29
@@ -39,8 +40,9 @@ export AS = "${CC}"
39export RUSTFLAGS 40export RUSTFLAGS
40 41
41JIT ?= "" 42JIT ?= ""
42
43JIT:mipsarch = "--disable-jit" 43JIT:mipsarch = "--disable-jit"
44ICU ?= "--with-system-icu"
45ICU:mipsarch = ""
44 46
45do_configure() { 47do_configure() {
46 cd ${B} 48 cd ${B}
@@ -52,8 +54,8 @@ do_configure() {
52 --libdir=${libdir} \ 54 --libdir=${libdir} \
53 --disable-jemalloc \ 55 --disable-jemalloc \
54 --disable-strip \ 56 --disable-strip \
55 ${JIT} 57 ${JIT} \
56 58 ${ICU}
57} 59}
58 60
59do_install() { 61do_install() {