summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2020-09-28 13:01:37 +0100
committerKhem Raj <raj.khem@gmail.com>2020-09-28 09:17:18 -0700
commit916158a379a71062daa42606a87d5e04659ec157 (patch)
tree6b24d8b1b5bed4bf1bec8a5ac42f4057656ab255 /meta-oe/recipes-extended
parenta8bc9fb94f5da7eaed9631634e06e058d613543c (diff)
downloadmeta-openembedded-916158a379a71062daa42606a87d5e04659ec157.tar.gz
minifi-cpp: Adapt to potential psuedo changes
If we do adopt path filtering for pseudo, we may filter out ${B} as not needing to be tracked for "root" permissions. We do need to track the data installed by do_install though, so move the temp directory this recipe uses out of ${B} and place it in WORKDIR. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended')
-rw-r--r--meta-oe/recipes-extended/minifi-cpp/minifi-cpp_0.7.0.bb8
1 files changed, 4 insertions, 4 deletions
diff --git a/meta-oe/recipes-extended/minifi-cpp/minifi-cpp_0.7.0.bb b/meta-oe/recipes-extended/minifi-cpp/minifi-cpp_0.7.0.bb
index 926dd755b..5127e11d8 100644
--- a/meta-oe/recipes-extended/minifi-cpp/minifi-cpp_0.7.0.bb
+++ b/meta-oe/recipes-extended/minifi-cpp/minifi-cpp_0.7.0.bb
@@ -66,10 +66,10 @@ TARGET_CXXFLAGS_append_riscv32 += "-fpic"
66TARGET_CFLAGS_append_riscv64 += "-fpic" 66TARGET_CFLAGS_append_riscv64 += "-fpic"
67TARGET_CXXFLAGS_append_riscv64 += "-fpic" 67TARGET_CXXFLAGS_append_riscv64 += "-fpic"
68 68
69do_install[cleandirs] += "${WORKDIR}/minifi-install"
69 70
70do_install() { 71do_install() {
71 DESTDIR='${B}/minifi-install' cmake_runcmake_build --target ${OECMAKE_TARGET_INSTALL} 72 DESTDIR='${WORKDIR}/minifi-install' cmake_runcmake_build --target ${OECMAKE_TARGET_INSTALL}
72
73 MINIFI_BIN=${bindir} 73 MINIFI_BIN=${bindir}
74 MINIFI_HOME=${sysconfdir}/minifi 74 MINIFI_HOME=${sysconfdir}/minifi
75 MINIFI_RUN=${localstatedir}/lib/minifi 75 MINIFI_RUN=${localstatedir}/lib/minifi
@@ -78,8 +78,8 @@ do_install() {
78 install -d ${D}${MINIFI_BIN} 78 install -d ${D}${MINIFI_BIN}
79 install -d ${D}${MINIFI_HOME}/conf 79 install -d ${D}${MINIFI_HOME}/conf
80 install -m 755 -d ${D}${localstatedir}/lib/minifi 80 install -m 755 -d ${D}${localstatedir}/lib/minifi
81 cp -a ${B}/minifi-install/usr/bin/* ${D}${MINIFI_BIN}/ 81 cp -a ${WORKDIR}/minifi-install/usr/bin/* ${D}${MINIFI_BIN}/
82 cp -a ${B}/minifi-install/usr/conf/* ${D}${MINIFI_HOME}/conf/ 82 cp -a ${WORKDIR}/minifi-install/usr/conf/* ${D}${MINIFI_HOME}/conf/
83 83
84 sed -i 's|#appender.rolling.directory=.*|appender.rolling.directory='${MINIFI_LOG}'|g' \ 84 sed -i 's|#appender.rolling.directory=.*|appender.rolling.directory='${MINIFI_LOG}'|g' \
85 ${D}${MINIFI_HOME}/conf/minifi-log.properties 85 ${D}${MINIFI_HOME}/conf/minifi-log.properties