summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-08-30 13:51:23 -0700
committerKhem Raj <raj.khem@gmail.com>2020-08-31 08:30:19 -0700
commit7de0bbbbaa5064dbb72db769060a7a93ccf2d654 (patch)
tree2f77fe87f67b74836db6a36fc4eb07db45174484 /meta-oe/recipes-extended
parent874a6c7a994c5ed8753fa51d746ccc5dc10d176c (diff)
downloadmeta-openembedded-7de0bbbbaa5064dbb72db769060a7a93ccf2d654.tar.gz
canutils: Use update-alternatives
canutils provides applications which conflict with can-utils recipe. update-alternatives helps fix this when both are installed Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended')
-rw-r--r--meta-oe/recipes-extended/socketcan/can-utils_git.bb6
-rw-r--r--meta-oe/recipes-extended/socketcan/canutils_4.0.6.bb7
2 files changed, 12 insertions, 1 deletions
diff --git a/meta-oe/recipes-extended/socketcan/can-utils_git.bb b/meta-oe/recipes-extended/socketcan/can-utils_git.bb
index 519368817..e3ad04f59 100644
--- a/meta-oe/recipes-extended/socketcan/can-utils_git.bb
+++ b/meta-oe/recipes-extended/socketcan/can-utils_git.bb
@@ -12,4 +12,8 @@ PV = "2020.02.04"
12 12
13S = "${WORKDIR}/git" 13S = "${WORKDIR}/git"
14 14
15inherit autotools pkgconfig 15inherit autotools pkgconfig update-alternatives
16
17ALTERNATIVE_${PN} = "candump cansend"
18ALTERNATIVE_LINK_NAME[candump] = "${bindir}/candump"
19ALTERNATIVE_LINK_NAME[cansend] = "${bindir}/cansend"
diff --git a/meta-oe/recipes-extended/socketcan/canutils_4.0.6.bb b/meta-oe/recipes-extended/socketcan/canutils_4.0.6.bb
index e1508af85..aaa265348 100644
--- a/meta-oe/recipes-extended/socketcan/canutils_4.0.6.bb
+++ b/meta-oe/recipes-extended/socketcan/canutils_4.0.6.bb
@@ -12,9 +12,16 @@ SRC_URI = "git://git.pengutronix.de/git/tools/canutils.git;protocol=git \
12 file://0001-canutils-candump-Add-error-frame-s-handling.patch \ 12 file://0001-canutils-candump-Add-error-frame-s-handling.patch \
13" 13"
14 14
15inherit update-alternatives
16
15S = "${WORKDIR}/git" 17S = "${WORKDIR}/git"
16 18
17inherit autotools pkgconfig 19inherit autotools pkgconfig
18 20
19# Busybox ip doesn't support can interface configuration, use the real thing 21# Busybox ip doesn't support can interface configuration, use the real thing
20RDEPENDS_${PN} += "iproute2" 22RDEPENDS_${PN} += "iproute2"
23
24ALTERNATIVE_PRIORITY = "90"
25ALTERNATIVE_${PN} = "candump cansend"
26ALTERNATIVE_LINK_NAME[candump] = "${bindir}/candump"
27ALTERNATIVE_LINK_NAME[cansend] = "${bindir}/cansend"