diff options
author | Yann Dirson <yann@blade-group.com> | 2020-09-09 10:45:37 +0200 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2020-09-10 01:24:33 -0700 |
commit | 5d28b4ec75fc5836c8d7acefd5fbeb2d70367e33 (patch) | |
tree | 85ee4576b5be744c5e32de965a323666f689d86f /meta-oe/recipes-extended | |
parent | a2409e6cd12d584d32fbdc062976e9db05d18017 (diff) | |
download | meta-openembedded-5d28b4ec75fc5836c8d7acefd5fbeb2d70367e33.tar.gz |
libcec: workaround wrong choice of PYTHON_PKG_DIR when building on Debian
As described in https://github.com/Pulse-Eight/libcec/issues/530 the
cmake code looks at the host to make decisions about the target, and
we can't even override this with a flag.
Signed-off-by: Yann Dirson <yann@blade-group.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended')
-rw-r--r-- | meta-oe/recipes-extended/libcec/libcec/0001-Remove-buggy-test-confusing-host-and-target.patch | 31 | ||||
-rw-r--r-- | meta-oe/recipes-extended/libcec/libcec_6.0.2.bb | 1 |
2 files changed, 32 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/libcec/libcec/0001-Remove-buggy-test-confusing-host-and-target.patch b/meta-oe/recipes-extended/libcec/libcec/0001-Remove-buggy-test-confusing-host-and-target.patch new file mode 100644 index 000000000..7c29e15e2 --- /dev/null +++ b/meta-oe/recipes-extended/libcec/libcec/0001-Remove-buggy-test-confusing-host-and-target.patch | |||
@@ -0,0 +1,31 @@ | |||
1 | From 8ce50bf569ec2d931735180079bbe507730626c8 Mon Sep 17 00:00:00 2001 | ||
2 | From: Yann Dirson <yann@blade-group.com> | ||
3 | Date: Mon, 7 Sep 2020 18:17:21 +0200 | ||
4 | Subject: [PATCH] Remove buggy test confusing host and target | ||
5 | |||
6 | --- | ||
7 | src/libcec/cmake/CheckPlatformSupport.cmake | 8 -------- | ||
8 | 1 file changed, 8 deletions(-) | ||
9 | |||
10 | diff --git a/src/libcec/cmake/CheckPlatformSupport.cmake b/src/libcec/cmake/CheckPlatformSupport.cmake | ||
11 | index 1d99bd8..31dac4f 100644 | ||
12 | --- a/src/libcec/cmake/CheckPlatformSupport.cmake | ||
13 | +++ b/src/libcec/cmake/CheckPlatformSupport.cmake | ||
14 | @@ -266,14 +266,6 @@ else() | ||
15 | DESTINATION python/cec) | ||
16 | endif() | ||
17 | else() | ||
18 | - if(EXISTS "/etc/os-release") | ||
19 | - file(READ "/etc/os-release" OS_RELEASE) | ||
20 | - string(REGEX MATCH "ID(_LIKE)?=debian" IS_DEBIAN ${OS_RELEASE}) | ||
21 | - if (IS_DEBIAN) | ||
22 | - SET(PYTHON_PKG_DIR "dist-packages") | ||
23 | - endif() | ||
24 | - endif() | ||
25 | - | ||
26 | if (NOT PYTHON_PKG_DIR) | ||
27 | SET(PYTHON_PKG_DIR "site-packages") | ||
28 | endif() | ||
29 | -- | ||
30 | 2.28.0 | ||
31 | |||
diff --git a/meta-oe/recipes-extended/libcec/libcec_6.0.2.bb b/meta-oe/recipes-extended/libcec/libcec_6.0.2.bb index 894ee52f9..c4aeb8c55 100644 --- a/meta-oe/recipes-extended/libcec/libcec_6.0.2.bb +++ b/meta-oe/recipes-extended/libcec/libcec_6.0.2.bb | |||
@@ -13,6 +13,7 @@ SRCREV = "29d82c80bcc62be2878a9ac080de7eb286c4beb9" | |||
13 | SRC_URI = "git://github.com/Pulse-Eight/libcec.git;branch=release \ | 13 | SRC_URI = "git://github.com/Pulse-Eight/libcec.git;branch=release \ |
14 | file://0001-CheckPlatformSupport.cmake-Do-not-hardcode-lib-path.patch \ | 14 | file://0001-CheckPlatformSupport.cmake-Do-not-hardcode-lib-path.patch \ |
15 | file://0001-Enhance-reproducibility.patch \ | 15 | file://0001-Enhance-reproducibility.patch \ |
16 | file://0001-Remove-buggy-test-confusing-host-and-target.patch \ | ||
16 | " | 17 | " |
17 | 18 | ||
18 | S = "${WORKDIR}/git" | 19 | S = "${WORKDIR}/git" |