diff options
author | Khem Raj <raj.khem@gmail.com> | 2020-04-27 18:30:16 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2020-04-28 16:24:07 -0700 |
commit | 1df2d272c38419ecc2ae52238802a2e74ac0e020 (patch) | |
tree | 61d3d58ebe1747c84b6575d99f577e3c20985c1b /meta-oe/recipes-extended | |
parent | 2b30970845c5671433c7cca66d39aeb39c7cb535 (diff) | |
download | meta-openembedded-1df2d272c38419ecc2ae52238802a2e74ac0e020.tar.gz |
libcec: Update to 5.0.0
License-Update: Changed Copyright years [1]
Add a patch to fix reproducibile builds
[1] https://github.com/Pulse-Eight/libcec/commit/d5e5200ed1a998af24fa5290ad764e0a2ed086c6#diff-7116ef0705885343c9e1b2171a06be0e
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended')
-rw-r--r-- | meta-oe/recipes-extended/libcec/libcec/0001-Enhance-reproducibility.patch | 33 | ||||
-rw-r--r-- | meta-oe/recipes-extended/libcec/libcec_git.bb | 9 |
2 files changed, 38 insertions, 4 deletions
diff --git a/meta-oe/recipes-extended/libcec/libcec/0001-Enhance-reproducibility.patch b/meta-oe/recipes-extended/libcec/libcec/0001-Enhance-reproducibility.patch new file mode 100644 index 000000000..f08887b88 --- /dev/null +++ b/meta-oe/recipes-extended/libcec/libcec/0001-Enhance-reproducibility.patch | |||
@@ -0,0 +1,33 @@ | |||
1 | From 240727d3142700af779ca6f5c4677419787bca28 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Tue, 28 Apr 2020 16:15:20 -0700 | ||
4 | Subject: [PATCH] Enhance reproducibility | ||
5 | |||
6 | SetBuildInfo.cmake groks information from build system and emits that | ||
7 | into sourcecode ( header file ) which is then compiled into binary, this | ||
8 | string is build system dependent, therefore can cause reproducibility | ||
9 | issues, here we set static string for LIB_INFO | ||
10 | |||
11 | Upstream-Status: Inappropriate [OE-specific] | ||
12 | |||
13 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
14 | --- | ||
15 | src/libcec/CMakeLists.txt | 2 +- | ||
16 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
17 | |||
18 | diff --git a/src/libcec/CMakeLists.txt b/src/libcec/CMakeLists.txt | ||
19 | index 19a070b..4b3c827 100644 | ||
20 | --- a/src/libcec/CMakeLists.txt | ||
21 | +++ b/src/libcec/CMakeLists.txt | ||
22 | @@ -133,7 +133,7 @@ set(CEC_HEADERS devices/CECRecordingDevice.h | ||
23 | source_group("Header Files" FILES ${CEC_HEADERS}) | ||
24 | |||
25 | # platform and device specific | ||
26 | -include(cmake/SetBuildInfo.cmake) | ||
27 | +set(LIB_INFO "compiled on ${CMAKE_SYSTEM} ... ") | ||
28 | include(cmake/CheckPlatformSupport.cmake) | ||
29 | |||
30 | ## create project groups | ||
31 | -- | ||
32 | 2.26.2 | ||
33 | |||
diff --git a/meta-oe/recipes-extended/libcec/libcec_git.bb b/meta-oe/recipes-extended/libcec/libcec_git.bb index 8d5a82455..39ceb489e 100644 --- a/meta-oe/recipes-extended/libcec/libcec_git.bb +++ b/meta-oe/recipes-extended/libcec/libcec_git.bb | |||
@@ -2,18 +2,19 @@ SUMMARY = "USB CEC Adaptor communication Library" | |||
2 | HOMEPAGE = "http://libcec.pulse-eight.com/" | 2 | HOMEPAGE = "http://libcec.pulse-eight.com/" |
3 | 3 | ||
4 | LICENSE = "GPLv2+" | 4 | LICENSE = "GPLv2+" |
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=e61fd86f9c947b430126181da2c6c715" | 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=b3a719e97f49e4841e90573f9b1a98ac" |
6 | 6 | ||
7 | DEPENDS = "p8platform udev ncurses swig-native python3" | 7 | DEPENDS = "p8platform udev ncurses swig-native python3" |
8 | 8 | ||
9 | DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libx11 libxrandr', '', d)}" | 9 | DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libx11 libxrandr', '', d)}" |
10 | DEPENDS_append_rpi = "${@bb.utils.contains('MACHINE_FEATURES', 'vc4graphics', '', ' userland', d)}" | 10 | DEPENDS_append_rpi = "${@bb.utils.contains('MACHINE_FEATURES', 'vc4graphics', '', ' userland', d)}" |
11 | 11 | ||
12 | PV = "4.0.4" | 12 | PV = "5.0.0" |
13 | 13 | ||
14 | SRCREV = "3bbd4321618503d14008387a72fabb6743878831" | 14 | SRCREV = "43bc27fe7be491149e6f57d14110e02abdac2f24" |
15 | SRC_URI = "git://github.com/Pulse-Eight/libcec.git \ | 15 | SRC_URI = "git://github.com/Pulse-Eight/libcec.git;branch=release \ |
16 | file://0001-CheckPlatformSupport.cmake-Do-not-hardcode-lib-path.patch \ | 16 | file://0001-CheckPlatformSupport.cmake-Do-not-hardcode-lib-path.patch \ |
17 | file://0001-Enhance-reproducibility.patch \ | ||
17 | " | 18 | " |
18 | 19 | ||
19 | S = "${WORKDIR}/git" | 20 | S = "${WORKDIR}/git" |