summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-05-11 18:07:01 -0700
committerKhem Raj <raj.khem@gmail.com>2020-05-12 12:33:42 -0700
commit1bc3ceeb2b3961f6b0a39c103ad893b07b1f63e7 (patch)
treef0618c570177fff13d7c01adfa0b3f0352aa1386 /meta-oe/recipes-extended
parent22a3ff957ad1ac08239ca84e074af367c8fdf0dc (diff)
downloadmeta-openembedded-1bc3ceeb2b3961f6b0a39c103ad893b07b1f63e7.tar.gz
pmdk: Update to 1.8
Licence-Update: Update copyright headers and drop jeamalloc [1] * Drop upstreamed patch * Drop jemalloc patch, its no longer applicable * Fix build with gcc10 [1] https://github.com/pmem/pmdk/commit/bd13816e7c784430343bcc2a7b53314ab998bf62#diff-9879d6db96fd29134fc802214163b95a Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended')
-rw-r--r--meta-oe/recipes-extended/pmdk/files/0001-examples-Initialize-child_idx.patch47
-rw-r--r--meta-oe/recipes-extended/pmdk/files/0001-jemalloc-jemalloc.cfg-Specify-the-host-when-building.patch29
-rw-r--r--meta-oe/recipes-extended/pmdk/files/0001-os_posix-Use-__FreeBSD__-to-control-secure_getenv-de.patch33
-rw-r--r--meta-oe/recipes-extended/pmdk/pmdk_1.8.bb (renamed from meta-oe/recipes-extended/pmdk/pmdk_1.7.bb)11
4 files changed, 54 insertions, 66 deletions
diff --git a/meta-oe/recipes-extended/pmdk/files/0001-examples-Initialize-child_idx.patch b/meta-oe/recipes-extended/pmdk/files/0001-examples-Initialize-child_idx.patch
new file mode 100644
index 000000000..8e2b3c7cb
--- /dev/null
+++ b/meta-oe/recipes-extended/pmdk/files/0001-examples-Initialize-child_idx.patch
@@ -0,0 +1,47 @@
1From 721a48e5397bd4ab454482041e55671eae7b189f Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Mon, 11 May 2020 18:01:11 -0700
4Subject: [PATCH] examples: Initialize child_idx
5
6Assign UINT_MAX and assert it
7
8Fixes warning
9rtree_map.c:358:12: error: 'child_idx' may be used uninitialized
10in this function [-Werror=maybe-uninitialized]
11
12Upstream-Status: Submitted [https://github.com/pmem/pmdk/pull/4802]
13Signed-off-by: Khem Raj <raj.khem@gmail.com>
14---
15 src/examples/libpmemobj/tree_map/rtree_map.c | 4 +++-
16 1 file changed, 3 insertions(+), 1 deletion(-)
17
18diff --git a/src/examples/libpmemobj/tree_map/rtree_map.c b/src/examples/libpmemobj/tree_map/rtree_map.c
19index 995e22bb9..6b3ead65c 100644
20--- a/src/examples/libpmemobj/tree_map/rtree_map.c
21+++ b/src/examples/libpmemobj/tree_map/rtree_map.c
22@@ -8,6 +8,7 @@
23 #include <ex_common.h>
24 #include <assert.h>
25 #include <errno.h>
26+#include <limits.h>
27 #include <stdlib.h>
28 #include <stdbool.h>
29
30@@ -320,12 +321,13 @@ has_only_one_child(TOID(struct tree_map_node) node, unsigned *child_idx)
31 static void
32 remove_extra_node(TOID(struct tree_map_node) *node)
33 {
34- unsigned child_idx;
35+ unsigned child_idx = UINT_MAX;
36 TOID(struct tree_map_node) tmp, tmp_child;
37
38 /* Our node has child with only one child. */
39 tmp = *node;
40 has_only_one_child(tmp, &child_idx);
41+ assert(child_idx != UINT_MAX);
42 tmp_child = D_RO(tmp)->slots[child_idx];
43
44 /*
45--
462.26.2
47
diff --git a/meta-oe/recipes-extended/pmdk/files/0001-jemalloc-jemalloc.cfg-Specify-the-host-when-building.patch b/meta-oe/recipes-extended/pmdk/files/0001-jemalloc-jemalloc.cfg-Specify-the-host-when-building.patch
deleted file mode 100644
index ca2a1f643..000000000
--- a/meta-oe/recipes-extended/pmdk/files/0001-jemalloc-jemalloc.cfg-Specify-the-host-when-building.patch
+++ /dev/null
@@ -1,29 +0,0 @@
1From 231eb4c75fbfaaf90bca7702bdaf55cf701a3527 Mon Sep 17 00:00:00 2001
2From: Alistair Francis <alistair.francis@wdc.com>
3Date: Mon, 23 Jul 2018 11:23:39 -0700
4Subject: [PATCH] jemalloc/jemalloc.cfg: Specify the host when building
5 jemalloc
6
7To avoid this error:
8 configure: error: cannot run C compiled programs.
9 If you meant to cross compile, use `--host'.
10when cross compiling specify the host when configuring jemalloc.
11
12Signed-off-by: Alistair Francis <alistair.francis@wdc.com>
13Upstream-Status: Inappropriate [configuration]
14---
15 src/jemalloc/jemalloc.cfg | 1 +
16 1 file changed, 1 insertion(+)
17
18diff --git a/src/jemalloc/jemalloc.cfg b/src/jemalloc/jemalloc.cfg
19index 196129de6..79ebbab1c 100644
20--- a/src/jemalloc/jemalloc.cfg
21+++ b/src/jemalloc/jemalloc.cfg
22@@ -3,3 +3,4 @@
23 --with-private-namespace=je_vmem_
24 --disable-xmalloc
25 --disable-munmap
26+--host=${HOST_SYS}
27--
282.14.4
29
diff --git a/meta-oe/recipes-extended/pmdk/files/0001-os_posix-Use-__FreeBSD__-to-control-secure_getenv-de.patch b/meta-oe/recipes-extended/pmdk/files/0001-os_posix-Use-__FreeBSD__-to-control-secure_getenv-de.patch
deleted file mode 100644
index 33f25b6a6..000000000
--- a/meta-oe/recipes-extended/pmdk/files/0001-os_posix-Use-__FreeBSD__-to-control-secure_getenv-de.patch
+++ /dev/null
@@ -1,33 +0,0 @@
1From 7d0732d69a774e28bc46b8b487d9f61bdd8afbff Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sun, 6 Oct 2019 18:15:44 -0700
4Subject: [PATCH] os_posix: Use __FreeBSD__ to control secure_getenv definition
5
6__USE_GNU does not cover all Linux platforms, e.g. when using musl as C
7library, __USE_GNU may not be defined but it does provide secure_getenv
8so instead of narrowing the else condition, lets speicifically check for
9FreeBSD being the platform, since that seems to be the intention here
10anyway
11
12Upstream-Status: Submitted [https://github.com/pmem/pmdk/pull/3999]
13Signed-off-by: Khem Raj <raj.khem@gmail.com>
14---
15 src/common/os_posix.c | 2 +-
16 1 file changed, 1 insertion(+), 1 deletion(-)
17
18diff --git a/src/common/os_posix.c b/src/common/os_posix.c
19index a9a37ef84..052db2383 100644
20--- a/src/common/os_posix.c
21+++ b/src/common/os_posix.c
22@@ -346,7 +346,7 @@ os_setenv(const char *name, const char *value, int overwrite)
23 /*
24 * secure_getenv -- provide GNU secure_getenv for FreeBSD
25 */
26-#ifndef __USE_GNU
27+#if defined(__FreeBSD__)
28 static char *
29 secure_getenv(const char *name)
30 {
31--
322.23.0
33
diff --git a/meta-oe/recipes-extended/pmdk/pmdk_1.7.bb b/meta-oe/recipes-extended/pmdk/pmdk_1.8.bb
index f5066da0d..fe7b760e2 100644
--- a/meta-oe/recipes-extended/pmdk/pmdk_1.7.bb
+++ b/meta-oe/recipes-extended/pmdk/pmdk_1.8.bb
@@ -3,7 +3,7 @@ DESCRIPTION = "Persistent Memory Development Kit"
3HOMEPAGE = "http://pmem.io" 3HOMEPAGE = "http://pmem.io"
4SECTION = "libs" 4SECTION = "libs"
5LICENSE = "BSD-3-Clause" 5LICENSE = "BSD-3-Clause"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=7db1106255a1baa80391fd2e21eebab7" 6LIC_FILES_CHKSUM = "file://LICENSE;md5=1b8430f251523f1bff0c9fb95da7e0ca"
7DEPENDS = "ndctl" 7DEPENDS = "ndctl"
8 8
9# Required to have the fts.h header for musl 9# Required to have the fts.h header for musl
@@ -12,12 +12,11 @@ DEPENDS_append_libc-musl = " fts"
12S = "${WORKDIR}/git" 12S = "${WORKDIR}/git"
13 13
14SRC_URI = "git://github.com/pmem/pmdk.git \ 14SRC_URI = "git://github.com/pmem/pmdk.git \
15 file://0001-jemalloc-jemalloc.cfg-Specify-the-host-when-building.patch \ 15 file://0001-examples-Initialize-child_idx.patch \
16 file://0002-Makefile-Don-t-install-the-docs.patch \ 16 file://0002-Makefile-Don-t-install-the-docs.patch \
17 file://0001-os_posix-Use-__FreeBSD__-to-control-secure_getenv-de.patch \
18 " 17 "
19 18
20SRCREV = "bc5e309485df61c452d08367e4b13ba9dfed5071" 19SRCREV = "0245d75eaf0f6106c86a7926a45fdf2149e37eaa"
21 20
22inherit autotools-brokensep pkgconfig 21inherit autotools-brokensep pkgconfig
23 22
@@ -31,6 +30,10 @@ EXTRA_OEMAKE = "BUILD_EXAMPLES='n' HOST_SYS='${HOST_SYS}' EXTRA_CFLAGS='${SELECT
31# Fix the missing fts libs when using musl 30# Fix the missing fts libs when using musl
32EXTRA_OEMAKE_append_libc-musl = " EXTRA_LIBS='-lfts'" 31EXTRA_OEMAKE_append_libc-musl = " EXTRA_LIBS='-lfts'"
33 32
33do_configure_prepend() {
34 touch .skip-doc
35}
36
34do_install() { 37do_install() {
35 oe_runmake prefix=${prefix} DESTDIR=${D} install 38 oe_runmake prefix=${prefix} DESTDIR=${D} install
36 39