summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended
diff options
context:
space:
mode:
authorJackie Huang <jackie.huang@windriver.com>2017-08-24 11:19:53 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2017-08-28 11:06:04 +0200
commitd853932c664edaed63d5491a7cee1e1031f41ff4 (patch)
treed1fa05672d3234862132268009966ba8b4f81306 /meta-oe/recipes-extended
parent8530df3ff6e1b3609926035677b6422da9445d22 (diff)
downloadmeta-openembedded-d853932c664edaed63d5491a7cee1e1031f41ff4.tar.gz
logcheck: update to 1.3.18 and move to meta-perl
- logcheck depends on mime-construct which is in meta-perl, so move it to meta-perl to avoid that meta-oe depends on meta-perl. - logcheck should not be run as root, so inherit useradd and add proper user and group. - Add missing runtime dependencies according to the file debian/control and simple test by running "logcheck -ot". - For syslog, debian directly depends on rsyslog, but logcheck works with any syslog and we have busybox-syslog, sysklogd, syslog-ng and rsyslog, so use VIRTUAL-RUNTIME_syslog for the syslog dependency and set rsyslog as the default, which can be easily overridden in distro conf file or local.conf. - Don't install /var/lock when populating rootfs. Do it through volatile. - install header.txt for generated mails Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended')
-rw-r--r--meta-oe/recipes-extended/logcheck/logcheck_1.3.17.bb38
1 files changed, 0 insertions, 38 deletions
diff --git a/meta-oe/recipes-extended/logcheck/logcheck_1.3.17.bb b/meta-oe/recipes-extended/logcheck/logcheck_1.3.17.bb
deleted file mode 100644
index ba4c2ab9a..000000000
--- a/meta-oe/recipes-extended/logcheck/logcheck_1.3.17.bb
+++ /dev/null
@@ -1,38 +0,0 @@
1SUMMARY = "Analyzes log files and sends noticeable events as email"
2DESCRIPTION = "\
3Logcheck is a simple utility which is designed to allow a system administrator \
4to view the log-files which are produced upon hosts under their control. \
5It does this by mailing summaries of the log-files to them, after first \
6filtering out "normal" entries. \
7Normal entries are entries which match one of the many included regular \
8expression files contain in the database."
9SECTION = "Applications/System"
10LICENSE = "GPLv2"
11LIC_FILES_CHKSUM = "file://LICENSE;md5=c93c0550bd3173f4504b2cbd8991e50b"
12
13SRC_URI = "git://git.debian.org/git/logcheck/logcheck.git"
14SRCREV = "2429e67ad875fee8a0234c64d504277b038c89cd"
15
16S = "${WORKDIR}/git"
17
18do_install() {
19 # Fix QA Issue
20 sed -i '/install -d $(DESTDIR)\/var\/lock\/logcheck/s/^/#/' Makefile
21
22 # "make install" do not install the manpages. Install them manually.
23 install -m 755 -d ${D}${mandir}/man1
24 install -m 755 -d ${D}${mandir}/man8
25 install -m 644 docs/logcheck-test.1 ${D}${mandir}/man1/
26 install -m 644 docs/logtail.8 ${D}${mandir}/man8/
27 install -m 644 docs/logtail2.8 ${D}${mandir}/man8/
28 sed -i "s/syslog/messages/" etc/logcheck.logfiles
29 sed -i "s/auth\.log/secure/" etc/logcheck.logfiles
30 install -m 755 -d ${D}${sysconfdir}/cron.d
31 install -m 644 debian/logcheck.cron.d ${D}${sysconfdir}/cron.d/logcheck
32 install -m 755 -d ${D}/var/lib/logcheck
33 oe_runmake install DESTDIR=${D}
34}
35
36RDEPENDS_${PN} = "perl"
37
38FILES_${PN} += "${datadir}/logtail"