summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2017-10-03 08:40:09 +1300
committerMartin Jansa <Martin.Jansa@gmail.com>2017-10-04 14:53:31 +0000
commitc2a7348684763fffa7558b67cbc4fc8c88d0b137 (patch)
tree6e550797792bed84a6cd427c85283ae6e163cf5d /meta-oe/recipes-extended
parent5221b9a45673a4860eb3281096c3f306d951a419 (diff)
downloadmeta-openembedded-c2a7348684763fffa7558b67cbc4fc8c88d0b137.tar.gz
mraa: move recipe from meta-refkit-core
Make this recipe a little more widely visible (has previously appeared in meta-refkit-core and meta-intel-iot-middleware). Also make couple of minor tweaks: * Make SUMMARY more accurate by borrowing the first part of the short description now in the mraa github repo * Set HOMEPAGE * Drop AUTHOR as this is field is only really intended for older software where there is no real point of contact for upstream other than an author's email address. * Set COMPATIBLE_HOST to match what is checked by mraa's CMakeLists.txt Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended')
-rw-r--r--meta-oe/recipes-extended/mraa/mraa_git.bb51
1 files changed, 51 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/mraa/mraa_git.bb b/meta-oe/recipes-extended/mraa/mraa_git.bb
new file mode 100644
index 000000000..616048fac
--- /dev/null
+++ b/meta-oe/recipes-extended/mraa/mraa_git.bb
@@ -0,0 +1,51 @@
1SUMMARY = "Linux Library for low speed I/O Communication"
2HOMEPAGE = "https://github.com/intel-iot-devkit/mraa"
3SECTION = "libs"
4
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://COPYING;md5=66493d54e65bfc12c7983ff2e884f37f"
7
8SRCREV = "8ddbcde84e2d146bc0f9e38504d6c89c14291480"
9PV = "1.7.0-git${SRCPV}"
10
11SRC_URI = "git://github.com/intel-iot-devkit/${BPN}.git;protocol=http"
12
13S = "${WORKDIR}/git"
14
15# CMakeLists.txt checks the architecture, only x86 and ARM supported for now
16COMPATIBLE_HOST = "(x86_64.*|i.86.*|aarch64.*|arm.*)-linux"
17
18inherit cmake distutils3-base
19
20DEPENDS += "json-c"
21
22EXTRA_OECMAKE_append = " -DINSTALLTOOLS:BOOL=ON -DFIRMATA=ON -DCMAKE_SKIP_RPATH=ON"
23
24# Prepend mraa-utils to make sure bindir ends up in there
25PACKAGES =+ "${PN}-utils"
26
27FILES_${PN}-doc += "${datadir}/mraa/examples/"
28
29FILES_${PN}-utils = "${bindir}/"
30
31# override this in local.conf to get needed bindings.
32# BINDINGS_pn-mraa="python"
33# will result in only the python bindings being built/packaged.
34BINDINGS ??= "python ${@ 'nodejs' if oe.types.boolean(d.getVar('HAVE_NODEJS') or '0') else '' }"
35
36PACKAGECONFIG ??= "${@bb.utils.contains('PACKAGES', 'node-${PN}', 'nodejs', '', d)} \
37 ${@bb.utils.contains('PACKAGES', '${PYTHON_PN}-${PN}', 'python', '', d)}"
38
39PACKAGECONFIG[python] = "-DBUILDSWIGPYTHON=ON, -DBUILDSWIGPYTHON=OFF, swig-native ${PYTHON_PN},"
40PACKAGECONFIG[nodejs] = "-DBUILDSWIGNODE=ON, -DBUILDSWIGNODE=OFF, swig-native nodejs-native,"
41PACKAGECONFIG[ft4222] = "-DUSBPLAT=ON -DFTDI4222=ON, -DUSBPLAT=OFF -DFTDI4222=OFF,, libft4222"
42
43FILES_${PYTHON_PN}-${PN} = "${PYTHON_SITEPACKAGES_DIR}/"
44RDEPENDS_${PYTHON_PN}-${PN} += "${PYTHON_PN}"
45
46FILES_node-${PN} = "${prefix}/lib/node_modules/"
47RDEPENDS_node-${PN} += "nodejs"
48
49### Include desired language bindings ###
50PACKAGES =+ "${@bb.utils.contains('BINDINGS', 'nodejs', 'node-${PN}', '', d)}"
51PACKAGES =+ "${@bb.utils.contains('BINDINGS', 'python', '${PYTHON_PN}-${PN}', '', d)}"