summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2016-11-03 11:47:39 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2016-11-23 15:24:02 +0100
commit35f77c6250d1123e4af3ac01a539477163c89bdf (patch)
tree240ef981c6235737ba6de79fb69130462ca5e2b9 /meta-oe/recipes-extended
parent1d01458df9a3271a22b70c3767cf2499d58ec478 (diff)
downloadmeta-openembedded-35f77c6250d1123e4af3ac01a539477163c89bdf.tar.gz
libcec: Update to 3.1.0+
Depends on p8platform therefore add recipe for p8platform Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended')
-rw-r--r--meta-oe/recipes-extended/libcec/libcec_git.bb18
-rw-r--r--meta-oe/recipes-extended/p8platform/p8platform_git.bb18
2 files changed, 30 insertions, 6 deletions
diff --git a/meta-oe/recipes-extended/libcec/libcec_git.bb b/meta-oe/recipes-extended/libcec/libcec_git.bb
index 0f2a64eda..32ab4b907 100644
--- a/meta-oe/recipes-extended/libcec/libcec_git.bb
+++ b/meta-oe/recipes-extended/libcec/libcec_git.bb
@@ -2,18 +2,24 @@ SUMMARY = "USB CEC Adaptor communication Library"
2HOMEPAGE = "http://libcec.pulse-eight.com/" 2HOMEPAGE = "http://libcec.pulse-eight.com/"
3 3
4LICENSE = "GPLv2+" 4LICENSE = "GPLv2+"
5LIC_FILES_CHKSUM = "file://COPYING;md5=5e8e16396992369f73f3d28875f846da" 5LIC_FILES_CHKSUM = "file://COPYING;md5=e61fd86f9c947b430126181da2c6c715"
6 6
7DEPENDS = "udev lockdev" 7DEPENDS = "p8platform udev lockdev"
8 8
9PV = "2.1.4" 9DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libx11 libxrandr', '', d)}"
10 10
11SRCREV = "81e38211724bc6e8bd7a60f484433053ed682635" 11PV = "3.1.0+gitr${SRCPV}"
12SRC_URI = "git://github.com/Pulse-Eight/libcec.git;branch=release" 12
13SRCREV = "6d68d21243aa92862592435e8396b4280ea46c3f"
14SRC_URI = "git://github.com/Pulse-Eight/libcec.git"
13 15
14S = "${WORKDIR}/git" 16S = "${WORKDIR}/git"
15 17
16inherit autotools pkgconfig 18inherit cmake pkgconfig
19
20# Disable python wrapper, it doesn't have crosscompiles
21EXTRA_OECMAKE = "-DCMAKE_INSTALL_LIBDIR=${libdir} -DCMAKE_INSTALL_LIBDIR_NOARCH=${libdir} \
22 -DSKIP_PYTHON_WRAPPER=1"
17 23
18# cec-client and xbmc need the .so present to work :( 24# cec-client and xbmc need the .so present to work :(
19FILES_${PN} += "${libdir}/*.so" 25FILES_${PN} += "${libdir}/*.so"
diff --git a/meta-oe/recipes-extended/p8platform/p8platform_git.bb b/meta-oe/recipes-extended/p8platform/p8platform_git.bb
new file mode 100644
index 000000000..f6347c2a4
--- /dev/null
+++ b/meta-oe/recipes-extended/p8platform/p8platform_git.bb
@@ -0,0 +1,18 @@
1SUMMARY = "Platform support library used by libCEC and binary add-ons for Kodi"
2HOMEPAGE = "http://libcec.pulse-eight.com/"
3
4LICENSE = "GPLv2+"
5LIC_FILES_CHKSUM = "file://src/os.h;md5=752555fa94e82005d45fd201fee5bd33"
6
7PV = "2.1.0"
8
9SRC_URI = "git://github.com/Pulse-Eight/platform.git"
10SRCREV = "d7bceb64541cb046421cbcd4c98d91e9bf24822f"
11
12S = "${WORKDIR}/git"
13
14inherit cmake pkgconfig
15
16EXTRA_OECMAKE += "-DCMAKE_INSTALL_LIBDIR=${libdir} -DCMAKE_INSTALL_LIBDIR_NOARCH=${libdir}"
17
18FILES_${PN}-dev += "${libdir}/p8-platform"