summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended
diff options
context:
space:
mode:
authorMikko Ylinen <mikko.ylinen@linux.intel.com>2017-09-08 14:10:39 +0300
committerMartin Jansa <Martin.Jansa@gmail.com>2017-09-13 11:13:22 +0200
commit09a285db6125f923d6a7dcaf6a31c898c811238e (patch)
tree5d1f0143dfde05075718705821a306f7aac3f59b /meta-oe/recipes-extended
parent2ff76a705a16b356916e91102adbf3f632019654 (diff)
downloadmeta-openembedded-09a285db6125f923d6a7dcaf6a31c898c811238e.tar.gz
efivar: fix build when host gcc version is < 4.9
efivar v27 started using C11 _Generic keyword in macros but that is not implemented in gcc until 4.9. This makes efivar-native (which is a dependency to efivar) build to fail if the builder host gcc version is < 4.9. It turns out only 'makeguids' generator needs to be built for the build arch to generate GENERATED_SOURCES for efivar target build. 'makeguids' sources/includes have no gcc version dependencies so to fix efivar build when host gcc < 4.9, we simply build 'makeguids' target for efivar-native. Signed-off-by: Mikko Ylinen <mikko.ylinen@linux.intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended')
-rw-r--r--meta-oe/recipes-extended/efivar/efivar_0.31.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta-oe/recipes-extended/efivar/efivar_0.31.bb b/meta-oe/recipes-extended/efivar/efivar_0.31.bb
index 6ad3b361d..9d4cdc97b 100644
--- a/meta-oe/recipes-extended/efivar/efivar_0.31.bb
+++ b/meta-oe/recipes-extended/efivar/efivar_0.31.bb
@@ -35,11 +35,15 @@ do_compile_prepend() {
35 sed -i -e s:-Werror::g ${S}/gcc.specs 35 sed -i -e s:-Werror::g ${S}/gcc.specs
36} 36}
37 37
38do_compile_class-native() {
39 oe_runmake -C src makeguids
40}
41
38do_install() { 42do_install() {
39 oe_runmake install DESTDIR=${D} 43 oe_runmake install DESTDIR=${D}
40} 44}
41 45
42do_install_append_class-native() { 46do_install_class-native() {
43 install -D -m 0755 ${B}/src/makeguids ${D}${bindir}/makeguids 47 install -D -m 0755 ${B}/src/makeguids ${D}${bindir}/makeguids
44} 48}
45 49