summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2016-12-16 19:55:28 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2016-12-26 08:24:07 +0100
commita2e1a14961b9fe9aede61fa91a29272bd70071f6 (patch)
treeef446828cc0efb155dd3910008e7305d69235b6f /meta-oe/recipes-extended
parenta21cdb62c6c454c8c837b558ba11043f362c76e9 (diff)
downloadmeta-openembedded-a2e1a14961b9fe9aede61fa91a29272bd70071f6.tar.gz
hplip: Fix build with clang
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended')
-rw-r--r--meta-oe/recipes-extended/hplip/hplip-3.12.6/0001-include-cups-ppd.h-for-missing-ppd-definitions.patch42
-rw-r--r--meta-oe/recipes-extended/hplip/hplip_3.12.6.bb1
2 files changed, 43 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/hplip/hplip-3.12.6/0001-include-cups-ppd.h-for-missing-ppd-definitions.patch b/meta-oe/recipes-extended/hplip/hplip-3.12.6/0001-include-cups-ppd.h-for-missing-ppd-definitions.patch
new file mode 100644
index 000000000..f259b5f05
--- /dev/null
+++ b/meta-oe/recipes-extended/hplip/hplip-3.12.6/0001-include-cups-ppd.h-for-missing-ppd-definitions.patch
@@ -0,0 +1,42 @@
1From 7ef9c040dd959105c16d4dc67e14f3bbea25e77f Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Fri, 16 Dec 2016 19:51:19 +0000
4Subject: [PATCH] include cups/ppd.h for missing ppd definitions
5
6Fixes errors spotted by clang
7
8| prnt/hpcups/HPCupsFilter.cpp:365:18: error: use of undeclared identifier 'ppdFindAttr'
9| if (((attr = ppdFindAttr(m_ppd, "hpPrinterLanguage", NULL)) == NULL) ||
10| ^
11| prnt/hpcups/HPCupsFilter.cpp:368:13: error: use of undeclared identifier 'ppdClose'
12| ppdClose(m_ppd);
13| ^
14| prnt/hpcups/HPCupsFilter.cpp:444:9: error: use of undeclared identifier 'ppdClose'
15| ppdClose(m_ppd);
16| ^
17| prnt/hpcups/HPCupsFilter.cpp:497:13: error: use of undeclared identifier 'ppdOpenFile'
18| m_ppd = ppdOpenFile(getenv("PPD"));
19| ^
20
21Signed-off-by: Khem Raj <raj.khem@gmail.com>
22---
23Upstream-Status: Pending
24
25 prnt/hpcups/HPCupsFilter.h | 1 +
26 1 file changed, 1 insertion(+)
27
28diff --git a/prnt/hpcups/HPCupsFilter.h b/prnt/hpcups/HPCupsFilter.h
29index 0431a7a..eb0cad6 100644
30--- a/prnt/hpcups/HPCupsFilter.h
31+++ b/prnt/hpcups/HPCupsFilter.h
32@@ -37,6 +37,7 @@
33 #include "Job.h"
34
35 #include "dbuscomm.h"
36+#include <cups/ppd.h>
37
38 #define DBITMAPFILEHEADER 14
39 #define DBITMAPINFOHEADER 40
40--
411.9.1
42
diff --git a/meta-oe/recipes-extended/hplip/hplip_3.12.6.bb b/meta-oe/recipes-extended/hplip/hplip_3.12.6.bb
index 9848e5ac1..1f1e80ce8 100644
--- a/meta-oe/recipes-extended/hplip/hplip_3.12.6.bb
+++ b/meta-oe/recipes-extended/hplip/hplip_3.12.6.bb
@@ -9,6 +9,7 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BP}.tar.gz \
9 file://fix-libusb-paths.patch \ 9 file://fix-libusb-paths.patch \
10 file://cups-1.6.patch \ 10 file://cups-1.6.patch \
11 file://configure.patch \ 11 file://configure.patch \
12 file://0001-include-cups-ppd.h-for-missing-ppd-definitions.patch \
12" 13"
13 14
14DEPENDS += "cups python libusb" 15DEPENDS += "cups python libusb"