summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended
diff options
context:
space:
mode:
authorPascal Bach <pascal.bach@nextrem.ch>2017-03-10 18:30:11 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2017-03-16 23:32:32 +0100
commit9a3e69fe84a38c8b9a95ce110ed90ea5814aba0a (patch)
tree8d2f4e4a04f255f125aa379ccee99882d00a4ebd /meta-oe/recipes-extended
parent1dff2351aa6cdafa5a501e8956cb853ab17ed9ae (diff)
downloadmeta-openembedded-9a3e69fe84a38c8b9a95ce110ed90ea5814aba0a.tar.gz
libcec: update to version 4.0.1 and provide package for python3 wrapper
Signed-off-by: Pascal Bach <pascal.bach@nextrem.ch> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended')
-rw-r--r--meta-oe/recipes-extended/libcec/files/python-install-location.patch28
-rw-r--r--meta-oe/recipes-extended/libcec/libcec_git.bb15
2 files changed, 36 insertions, 7 deletions
diff --git a/meta-oe/recipes-extended/libcec/files/python-install-location.patch b/meta-oe/recipes-extended/libcec/files/python-install-location.patch
new file mode 100644
index 000000000..b6be78dd4
--- /dev/null
+++ b/meta-oe/recipes-extended/libcec/files/python-install-location.patch
@@ -0,0 +1,28 @@
1From 330fa6777d51d41eefacff8e98e4250d210fde35 Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Javi=20Mart=C3=ADnez?= <javi@flamingalah.net>
3Date: Tue, 13 Dec 2016 22:31:13 +0100
4Subject: [PATCH] Improve/fix installation of Python bindings
5
6Upstream-Status: Backport
7
8dist-packages is a Debian-specific directory for distribution packages (and used in derivatives such as Ubuntu). Therefore changed to site-packages.
9---
10 src/libcec/cmake/CheckPlatformSupport.cmake | 4 ++--
11 1 file changed, 2 insertions(+), 2 deletions(-)
12
13diff --git a/src/libcec/cmake/CheckPlatformSupport.cmake b/src/libcec/cmake/CheckPlatformSupport.cmake
14index fcd0ef7..7661107 100644
15--- a/src/libcec/cmake/CheckPlatformSupport.cmake
16+++ b/src/libcec/cmake/CheckPlatformSupport.cmake
17@@ -195,9 +195,9 @@ else()
18 RENAME __init__.py)
19 else()
20 install(TARGETS ${SWIG_MODULE_cec_REAL_NAME}
21- DESTINATION lib/python${PYTHON_VERSION}/dist-packages/cec)
22+ DESTINATION lib/python${PYTHON_VERSION}/site-packages/cec)
23 install(FILES ${CMAKE_BINARY_DIR}/src/libcec/cec.py
24- DESTINATION lib/python${PYTHON_VERSION}/dist-packages/cec
25+ DESTINATION lib/python${PYTHON_VERSION}/site-packages/cec
26 RENAME __init__.py)
27 endif()
28 endif()
diff --git a/meta-oe/recipes-extended/libcec/libcec_git.bb b/meta-oe/recipes-extended/libcec/libcec_git.bb
index 0ce7ea1c0..cb65caad8 100644
--- a/meta-oe/recipes-extended/libcec/libcec_git.bb
+++ b/meta-oe/recipes-extended/libcec/libcec_git.bb
@@ -4,23 +4,24 @@ HOMEPAGE = "http://libcec.pulse-eight.com/"
4LICENSE = "GPLv2+" 4LICENSE = "GPLv2+"
5LIC_FILES_CHKSUM = "file://COPYING;md5=e61fd86f9c947b430126181da2c6c715" 5LIC_FILES_CHKSUM = "file://COPYING;md5=e61fd86f9c947b430126181da2c6c715"
6 6
7DEPENDS = "p8platform udev lockdev ncurses" 7DEPENDS = "p8platform udev lockdev ncurses swig-native python3"
8 8
9DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libx11 libxrandr', '', d)}" 9DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libx11 libxrandr', '', d)}"
10DEPENDS_append_rpi = "${@bb.utils.contains('MACHINE_FEATURES', 'vc4graphics', '', ' userland', d)}" 10DEPENDS_append_rpi = "${@bb.utils.contains('MACHINE_FEATURES', 'vc4graphics', '', ' userland', d)}"
11 11
12PV = "3.1.0+gitr${SRCPV}" 12PV = "4.0.1+gitr${SRCPV}"
13 13
14SRCREV = "6d68d21243aa92862592435e8396b4280ea46c3f" 14SRCREV = "2fc92b5f02dca702da92ccc5ed7b805b240ef5df"
15SRC_URI = "git://github.com/Pulse-Eight/libcec.git" 15SRC_URI = "git://github.com/Pulse-Eight/libcec.git \
16 file://python-install-location.patch"
16 17
17S = "${WORKDIR}/git" 18S = "${WORKDIR}/git"
18 19
19inherit cmake pkgconfig 20inherit cmake pkgconfig
20 21
21# Disable python wrapper, it doesn't have crosscompiles 22# Create the wrapper for python3
22EXTRA_OECMAKE = "-DCMAKE_INSTALL_LIBDIR=${libdir} -DCMAKE_INSTALL_LIBDIR_NOARCH=${libdir} \ 23PACKAGES += "python3-${BPN}"
23 -DSKIP_PYTHON_WRAPPER=1" 24FILES_python3-${BPN} = "${libdir}/python3*"
24 25
25# cec-client and xbmc need the .so present to work :( 26# cec-client and xbmc need the .so present to work :(
26FILES_${PN} += "${libdir}/*.so" 27FILES_${PN} += "${libdir}/*.so"