summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended
diff options
context:
space:
mode:
authorSven Ebenfeld <sven.ebenfeld@gmail.com>2014-08-25 12:48:11 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2014-08-28 19:55:38 +0200
commit59a7c659e8d59e3caa5aeddf1ba45e8704174730 (patch)
tree09772c676ac79b02b0a6a2c4dc52b7cf50b868dd /meta-oe/recipes-extended
parent46698617eb3ee7a5a2c638759654b6076a7bc058 (diff)
downloadmeta-openembedded-59a7c659e8d59e3caa5aeddf1ba45e8704174730.tar.gz
md5deep: Add recipe for md5deep package version 4.4
I need to build hashdeep/md5deep within OE to include it in my images. This recipe enables OE to cross-compile md5deep. I needed to add the patch as do_configure_qa is complaining about cross-compilation errors otherwise. I added a pull request for the issue with the variable expansion to hashdeep as well. Signed-off-by: Sven Ebenfeld <sven.ebenfeld@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended')
-rw-r--r--meta-oe/recipes-extended/md5deep/files/wrong-variable-expansion.patch39
-rw-r--r--meta-oe/recipes-extended/md5deep/md5deep_4.4.bb16
2 files changed, 55 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/md5deep/files/wrong-variable-expansion.patch b/meta-oe/recipes-extended/md5deep/files/wrong-variable-expansion.patch
new file mode 100644
index 000000000..3a4c4f4c2
--- /dev/null
+++ b/meta-oe/recipes-extended/md5deep/files/wrong-variable-expansion.patch
@@ -0,0 +1,39 @@
1--- a/configure.ac 2014-08-22 12:22:54.290884351 +0200
2+++ b/configure.ac 2014-08-22 12:23:15.822306295 +0200
3@@ -42,18 +42,6 @@
4 ;;
5 esac
6
7-
8-# Bring additional directories where things might be found into our
9-# search path. I don't know why autoconf doesn't do this by default
10-if test x"${mingw}" == "xno" ; then
11- for spfx in /usr/local /opt/local /sw ; do
12- echo checking ${spfx}/include
13- if test -d ${spfx}/include; then
14- CPPFLAGS="-I${spfx}/include $CPPFLAGS"
15- LDFLAGS="-L${spfx}/lib $LDFLAGS"
16- fi
17- done
18-fi
19 #
20 #
21 ################################################################
22@@ -71,7 +59,7 @@
23
24 if test $mingw = "no" ; then
25 # add the warnings we don't want to do on mingw
26- $WARNINGS_TO_TEST="$WARNINGS_TO_TEST -Wall -Wstrict-prototypes -Weffc++"
27+ WARNINGS_TO_TEST="$WARNINGS_TO_TEST -Wall -Wstrict-prototypes -Weffc++"
28 fi
29
30 for option in $WARNINGS_TO_TEST
31@@ -105,7 +93,7 @@
32
33 if test $mingw = "no" ; then
34 # add the warnings we don't want to do on mingw
35- $WARNINGS_TO_TEST="$WARNINGS_TO_TEST -Weffc++"
36+ WARNINGS_TO_TEST="$WARNINGS_TO_TEST -Weffc++"
37 fi
38
39 for option in $WARNINGS_TO_TEST
diff --git a/meta-oe/recipes-extended/md5deep/md5deep_4.4.bb b/meta-oe/recipes-extended/md5deep/md5deep_4.4.bb
new file mode 100644
index 000000000..960e00f61
--- /dev/null
+++ b/meta-oe/recipes-extended/md5deep/md5deep_4.4.bb
@@ -0,0 +1,16 @@
1SUMMARY = "md5deep and hashdeep to compute and audit hashsets of amounts of files."
2DESCRIPTION = "md5deep is a set of programs to compute MD5, SHA-1, SHA-256, Tiger, or Whirlpool message digests on an arbitrary number of files. This package also includes hashdeep which is also able to audit hashsets."
3AUTHOR = "Jesse Kornblum, Simson L. Garfinkel"
4HOMEPAGE = "http://md5deep.sourceforge.net"
5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=9190f660105b9a56cdb272309bfd5491"
7# Release 4.4
8SRCREV = "cd2ed7416685a5e83eb10bb659d6e9bec01244ae"
9
10SRC_URI = "git://github.com/jessek/hashdeep.git \
11 file://wrong-variable-expansion.patch \
12 "
13
14S = "${WORKDIR}/git"
15
16inherit autotools