diff options
author | Martin Jansa <Martin.Jansa@gmail.com> | 2017-04-04 14:24:29 +0200 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2017-04-05 19:28:32 +0200 |
commit | 0e1d1787ede735e7ce4034125283607e3ed2ba52 (patch) | |
tree | f34cb5fa41e27026b0bc0ba41c53783e459315da /meta-oe/recipes-extended | |
parent | ad9c16bb7be00593dd7276f2ea90a19d70c6f2b1 (diff) | |
download | meta-openembedded-0e1d1787ede735e7ce4034125283607e3ed2ba52.tar.gz |
dlm: fix ldflags QA warning
* fixes:
dlm-4.0.2: No GNU_HASH in the elf binary:
'/home/jenkins/oe/world/shr-core/tmp-glibc/work/armv5te-oe-linux-gnueabi/dlm/4.0.2-r0/packages-split/dlm/usr/lib/libdlmcontrol.so.3.1'
No GNU_HASH in the elf binary:
'/home/jenkins/oe/world/shr-core/tmp-glibc/work/armv5te-oe-linux-gnueabi/dlm/4.0.2-r0/packages-split/dlm/usr/sbin/dlm_tool'
No GNU_HASH in the elf binary:
'/home/jenkins/oe/world/shr-core/tmp-glibc/work/armv5te-oe-linux-gnueabi/dlm/4.0.2-r0/packages-split/dlm/usr/sbin/dlm_controld'
[ldflags]
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended')
-rw-r--r-- | meta-oe/recipes-extended/dlm/dlm/respect-ldflags-also-from-bin_ldflags.patch | 36 | ||||
-rw-r--r-- | meta-oe/recipes-extended/dlm/dlm_4.0.2.bb | 4 |
2 files changed, 39 insertions, 1 deletions
diff --git a/meta-oe/recipes-extended/dlm/dlm/respect-ldflags-also-from-bin_ldflags.patch b/meta-oe/recipes-extended/dlm/dlm/respect-ldflags-also-from-bin_ldflags.patch new file mode 100644 index 000000000..69b2f903c --- /dev/null +++ b/meta-oe/recipes-extended/dlm/dlm/respect-ldflags-also-from-bin_ldflags.patch | |||
@@ -0,0 +1,36 @@ | |||
1 | diff -uNr dlm-4.0.2.orig/dlm_controld/Makefile dlm-4.0.2/dlm_controld/Makefile | ||
2 | --- dlm-4.0.2.orig/dlm_controld/Makefile 2017-04-04 10:49:23.661320260 +0200 | ||
3 | +++ dlm-4.0.2/dlm_controld/Makefile 2017-04-04 10:50:36.121326429 +0200 | ||
4 | @@ -55,7 +55,7 @@ | ||
5 | BIN_CFLAGS += -fPIE -DPIE | ||
6 | BIN_CFLAGS += -I../include -I../libdlm | ||
7 | |||
8 | -BIN_LDFLAGS += -Wl,-z,now -Wl,-z,relro -pie | ||
9 | +BIN_LDFLAGS += $(LDFLAGS) -Wl,-z,now -Wl,-z,relro -pie | ||
10 | BIN_LDFLAGS += -lpthread -lrt -lcpg -lcmap -lcfg -lquorum | ||
11 | |||
12 | LIB_CFLAGS += $(BIN_CFLAGS) | ||
13 | diff -uNr dlm-4.0.2.orig/dlm_tool/Makefile dlm-4.0.2/dlm_tool/Makefile | ||
14 | --- dlm-4.0.2.orig/dlm_tool/Makefile 2013-07-31 17:50:26.000000000 +0200 | ||
15 | +++ dlm-4.0.2/dlm_tool/Makefile 2017-04-04 10:50:44.617327153 +0200 | ||
16 | @@ -32,7 +32,7 @@ | ||
17 | BIN_CFLAGS += -fPIE -DPIE | ||
18 | BIN_CFLAGS += -I../include -I../libdlm -I../dlm_controld | ||
19 | |||
20 | -BIN_LDFLAGS += -Wl,-z,now -Wl,-z,relro -pie | ||
21 | +BIN_LDFLAGS += $(LDFLAGS) -Wl,-z,now -Wl,-z,relro -pie | ||
22 | BIN_LDFLAGS += -L../libdlm -L../dlm_controld | ||
23 | BIN_LDFLAGS += -lpthread -ldlm -ldlmcontrol | ||
24 | |||
25 | diff -uNr dlm-4.0.2.orig/dlm_controld/Makefile dlm-4.0.2/dlm_controld/Makefile | ||
26 | --- dlm-4.0.2.orig/dlm_controld/Makefile 2017-04-04 11:02:58.578389641 +0200 | ||
27 | +++ dlm-4.0.2/dlm_controld/Makefile 2017-04-04 11:07:55.672414935 +0200 | ||
28 | @@ -59,7 +59,7 @@ | ||
29 | BIN_LDFLAGS += -lpthread -lrt -lcpg -lcmap -lcfg -lquorum | ||
30 | |||
31 | LIB_CFLAGS += $(BIN_CFLAGS) | ||
32 | -LIB_LDFLAGS += -Wl,-z,relro -pie | ||
33 | +LIB_LDFLAGS += $(LDFLAGS) -Wl,-z,relro -pie | ||
34 | |||
35 | ifeq ($(USE_SD_NOTIFY),yes) | ||
36 | BIN_CFLAGS += $(shell pkg-config --cflags libsystemd-daemon) \ | ||
diff --git a/meta-oe/recipes-extended/dlm/dlm_4.0.2.bb b/meta-oe/recipes-extended/dlm/dlm_4.0.2.bb index ff3730563..31e411e86 100644 --- a/meta-oe/recipes-extended/dlm/dlm_4.0.2.bb +++ b/meta-oe/recipes-extended/dlm/dlm_4.0.2.bb | |||
@@ -5,7 +5,9 @@ HOMEPAGE = "https://fedorahosted.org/cluster/wiki/HomePage" | |||
5 | 5 | ||
6 | REQUIRED_DISTRO_FEATURES = "systemd" | 6 | REQUIRED_DISTRO_FEATURES = "systemd" |
7 | 7 | ||
8 | SRC_URI = "https://git.fedorahosted.org/cgit/dlm.git/snapshot/${BP}.tar.xz" | 8 | SRC_URI = "https://git.fedorahosted.org/cgit/dlm.git/snapshot/${BP}.tar.xz \ |
9 | file://respect-ldflags-also-from-bin_ldflags.patch \ | ||
10 | " | ||
9 | 11 | ||
10 | SRC_URI[md5sum] = "efc2ee6093aa6aa0a88aaad83e998a3f" | 12 | SRC_URI[md5sum] = "efc2ee6093aa6aa0a88aaad83e998a3f" |
11 | SRC_URI[sha256sum] = "b89bc557aaffbab0ac005398025f247718a5589cff6574d902eaffe2b20e683e" | 13 | SRC_URI[sha256sum] = "b89bc557aaffbab0ac005398025f247718a5589cff6574d902eaffe2b20e683e" |