summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended
diff options
context:
space:
mode:
authorPeter Kjellerstedt <peter.kjellerstedt@axis.com>2017-03-01 18:30:49 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2017-03-07 13:30:26 +0100
commit0c31f55bcfd6630d894dd2dda6ca483bea5de4ab (patch)
tree362ae6300bfa295709e24a4879639fb4c0fb5116 /meta-oe/recipes-extended
parentb4524eb786472e69e28212a58a329a5e44e40547 (diff)
downloadmeta-openembedded-0c31f55bcfd6630d894dd2dda6ca483bea5de4ab.tar.gz
Make use of the new bb.utils.filter() function
Signed-off-by: Peter Kjellerstedt <peter.kjellerstedt@axis.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended')
-rw-r--r--meta-oe/recipes-extended/cfengine/cfengine_3.9.0.bb3
-rw-r--r--meta-oe/recipes-extended/corosync/corosync_2.4.0.bb2
-rw-r--r--meta-oe/recipes-extended/liblogging/liblogging_1.0.5.bb2
-rw-r--r--meta-oe/recipes-extended/mozjs/mozjs_17.0.0.bb2
-rw-r--r--meta-oe/recipes-extended/polkit/polkit_0.113.bb4
-rw-r--r--meta-oe/recipes-extended/rarpd/rarpd_ss981107.bb2
-rw-r--r--meta-oe/recipes-extended/rrdtool/rrdtool_1.6.0.bb2
-rw-r--r--meta-oe/recipes-extended/rsyslog/rsyslog_8.22.0.bb3
-rw-r--r--meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb_1.4.9.bb2
-rw-r--r--meta-oe/recipes-extended/smartmontools/smartmontools_6.5.bb4
10 files changed, 11 insertions, 15 deletions
diff --git a/meta-oe/recipes-extended/cfengine/cfengine_3.9.0.bb b/meta-oe/recipes-extended/cfengine/cfengine_3.9.0.bb
index 68a15f897..4aa8dedc4 100644
--- a/meta-oe/recipes-extended/cfengine/cfengine_3.9.0.bb
+++ b/meta-oe/recipes-extended/cfengine/cfengine_3.9.0.bb
@@ -31,8 +31,7 @@ SYSTEMD_SERVICE_${PN} = "cfengine3.service cfengine3-web.service"
31SYSTEMD_AUTO_ENABLE_${PN} = "disable" 31SYSTEMD_AUTO_ENABLE_${PN} = "disable"
32 32
33PACKAGECONFIG ??= "libpcre openssl \ 33PACKAGECONFIG ??= "libpcre openssl \
34 ${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'pam', '', d)} \ 34 ${@bb.utils.filter('DISTRO_FEATURES', 'pam systemd', d)} \
35 ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)} \
36" 35"
37PACKAGECONFIG[libxml2] = "--with-libxml2=yes,--with-libxml2=no,libxml2," 36PACKAGECONFIG[libxml2] = "--with-libxml2=yes,--with-libxml2=no,libxml2,"
38PACKAGECONFIG[mysql] = "--with-mysql=yes,--with-mysql=no,mysql," 37PACKAGECONFIG[mysql] = "--with-mysql=yes,--with-mysql=no,mysql,"
diff --git a/meta-oe/recipes-extended/corosync/corosync_2.4.0.bb b/meta-oe/recipes-extended/corosync/corosync_2.4.0.bb
index a213a2726..c168e0c88 100644
--- a/meta-oe/recipes-extended/corosync/corosync_2.4.0.bb
+++ b/meta-oe/recipes-extended/corosync/corosync_2.4.0.bb
@@ -21,7 +21,7 @@ SYSTEMD_AUTO_ENABLE = "enable"
21 21
22INITSCRIPT_NAME = "corosync-daemon" 22INITSCRIPT_NAME = "corosync-daemon"
23 23
24PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)}" 24PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
25 25
26PACKAGECONFIG[systemd] = "--enable-systemd --with-systemddir=${systemd_unitdir}/system/,--with-systemddir=" 26PACKAGECONFIG[systemd] = "--enable-systemd --with-systemddir=${systemd_unitdir}/system/,--with-systemddir="
27 27
diff --git a/meta-oe/recipes-extended/liblogging/liblogging_1.0.5.bb b/meta-oe/recipes-extended/liblogging/liblogging_1.0.5.bb
index 3488b19a3..64a258b01 100644
--- a/meta-oe/recipes-extended/liblogging/liblogging_1.0.5.bb
+++ b/meta-oe/recipes-extended/liblogging/liblogging_1.0.5.bb
@@ -19,5 +19,5 @@ inherit autotools pkgconfig
19 19
20EXTRA_OECONF = "--disable-man-pages" 20EXTRA_OECONF = "--disable-man-pages"
21 21
22PACKAGECONFIG ??= "${@bb.utils.contains("DISTRO_FEATURES", "systemd", "systemd", "", d)}" 22PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
23PACKAGECONFIG[systemd] = "--enable-journal, --disable-journal, systemd" 23PACKAGECONFIG[systemd] = "--enable-journal, --disable-journal, systemd"
diff --git a/meta-oe/recipes-extended/mozjs/mozjs_17.0.0.bb b/meta-oe/recipes-extended/mozjs/mozjs_17.0.0.bb
index 24631e4ea..3424669b8 100644
--- a/meta-oe/recipes-extended/mozjs/mozjs_17.0.0.bb
+++ b/meta-oe/recipes-extended/mozjs/mozjs_17.0.0.bb
@@ -42,7 +42,7 @@ EXTRA_OECONF_append_armv4 = " \
42 --disable-methodjit \ 42 --disable-methodjit \
43" 43"
44 44
45PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', '', d)}" 45PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}"
46PACKAGECONFIG[x11] = "--with-x --x-includes=${STAGING_INCDIR} --x-libraries=${STAGING_LIBDIR},--without-x,virtual/libx11" 46PACKAGECONFIG[x11] = "--with-x --x-includes=${STAGING_INCDIR} --x-libraries=${STAGING_LIBDIR},--without-x,virtual/libx11"
47 47
48# mozjs requires autoreconf 2.13 48# mozjs requires autoreconf 2.13
diff --git a/meta-oe/recipes-extended/polkit/polkit_0.113.bb b/meta-oe/recipes-extended/polkit/polkit_0.113.bb
index daafaf5c8..326c9340e 100644
--- a/meta-oe/recipes-extended/polkit/polkit_0.113.bb
+++ b/meta-oe/recipes-extended/polkit/polkit_0.113.bb
@@ -9,8 +9,8 @@ DEPENDS = "expat glib-2.0 intltool-native mozjs"
9 9
10inherit autotools gtk-doc pkgconfig useradd systemd gobject-introspection 10inherit autotools gtk-doc pkgconfig useradd systemd gobject-introspection
11 11
12PACKAGECONFIG = "${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'pam', '', d)} \ 12PACKAGECONFIG = "${@bb.utils.filter('DISTRO_FEATURES', 'pam', d)} \
13 ${@bb.utils.contains('DISTRO_FEATURES','systemd','systemd','consolekit',d)}" 13 ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', 'consolekit', d)}"
14 14
15PACKAGECONFIG[pam] = "--with-authfw=pam,--with-authfw=shadow,libpam,libpam" 15PACKAGECONFIG[pam] = "--with-authfw=pam,--with-authfw=shadow,libpam,libpam"
16PACKAGECONFIG[systemd] = "--enable-libsystemd-login=yes --with-systemdsystemunitdir=${systemd_unitdir}/system/,--enable-libsystemd-login=no --with-systemdsystemunitdir=,systemd" 16PACKAGECONFIG[systemd] = "--enable-libsystemd-login=yes --with-systemdsystemunitdir=${systemd_unitdir}/system/,--enable-libsystemd-login=no --with-systemdsystemunitdir=,systemd"
diff --git a/meta-oe/recipes-extended/rarpd/rarpd_ss981107.bb b/meta-oe/recipes-extended/rarpd/rarpd_ss981107.bb
index a1121686c..4025b8087 100644
--- a/meta-oe/recipes-extended/rarpd/rarpd_ss981107.bb
+++ b/meta-oe/recipes-extended/rarpd/rarpd_ss981107.bb
@@ -44,7 +44,7 @@ do_install() {
44 fi 44 fi
45} 45}
46 46
47inherit ${@bb.utils.contains('VIRTUAL-RUNTIME_init_manager','systemd','systemd','',d)} 47inherit ${@bb.utils.filter('VIRTUAL-RUNTIME_init_manager', 'systemd', d)}
48 48
49SYSTEMD_PACKAGES = "${PN}" 49SYSTEMD_PACKAGES = "${PN}"
50SYSTEMD_SERVICE_${PN} = "rarpd.service" 50SYSTEMD_SERVICE_${PN} = "rarpd.service"
diff --git a/meta-oe/recipes-extended/rrdtool/rrdtool_1.6.0.bb b/meta-oe/recipes-extended/rrdtool/rrdtool_1.6.0.bb
index f168c169f..a3aac45dd 100644
--- a/meta-oe/recipes-extended/rrdtool/rrdtool_1.6.0.bb
+++ b/meta-oe/recipes-extended/rrdtool/rrdtool_1.6.0.bb
@@ -24,7 +24,7 @@ SYSTEMD_SERVICE_rrdcached = "rrdcached.socket rrdcached.service"
24 24
25EXTRA_AUTORECONF = "-I m4" 25EXTRA_AUTORECONF = "-I m4"
26 26
27PACKAGECONFIG ??= "python perl ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)}" 27PACKAGECONFIG ??= "python perl ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
28 28
29PACKAGECONFIG[python] = "--enable-python=yes \ 29PACKAGECONFIG[python] = "--enable-python=yes \
30am_cv_python_pythondir=${STAGING_LIBDIR}/python${PYTHON_BASEVERSION}/site-packages \ 30am_cv_python_pythondir=${STAGING_LIBDIR}/python${PYTHON_BASEVERSION}/site-packages \
diff --git a/meta-oe/recipes-extended/rsyslog/rsyslog_8.22.0.bb b/meta-oe/recipes-extended/rsyslog/rsyslog_8.22.0.bb
index 62126f8fb..70abb18dd 100644
--- a/meta-oe/recipes-extended/rsyslog/rsyslog_8.22.0.bb
+++ b/meta-oe/recipes-extended/rsyslog/rsyslog_8.22.0.bb
@@ -37,8 +37,7 @@ EXTRA_OECONF += "--disable-generate-man-pages ap_cv_atomic_builtins=yes"
37PACKAGECONFIG ??= " \ 37PACKAGECONFIG ??= " \
38 rsyslogd rsyslogrt klog inet regexp uuid libgcrypt \ 38 rsyslogd rsyslogrt klog inet regexp uuid libgcrypt \
39 imdiag gnutls imfile \ 39 imdiag gnutls imfile \
40 ${@bb.utils.contains('DISTRO_FEATURES', 'snmp', 'snmp', '', d)} \ 40 ${@bb.utils.filter('DISTRO_FEATURES', 'snmp systemd', d)} \
41 ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)} \
42 ${@bb.utils.contains('DISTRO_FEATURES', 'ptest', 'testbench relp ${VALGRIND}', '', d)} \ 41 ${@bb.utils.contains('DISTRO_FEATURES', 'ptest', 'testbench relp ${VALGRIND}', '', d)} \
43" 42"
44 43
diff --git a/meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb_1.4.9.bb b/meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb_1.4.9.bb
index 84e465d85..fa75fcc16 100644
--- a/meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb_1.4.9.bb
+++ b/meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb_1.4.9.bb
@@ -25,7 +25,7 @@ SRC_URI[md5sum] = "28021cdabc73690a94f4f9d57254ce30"
25SRC_URI[sha256sum] = "634a67b2f7ac3b386a79160eb44413d618e33e4e7fc74ae68b0240484af149dd" 25SRC_URI[sha256sum] = "634a67b2f7ac3b386a79160eb44413d618e33e4e7fc74ae68b0240484af149dd"
26 26
27inherit autotools 27inherit autotools
28inherit ${@bb.utils.contains('VIRTUAL-RUNTIME_init_manager','systemd','systemd','', d)} 28inherit ${@bb.utils.filter('VIRTUAL-RUNTIME_init_manager', 'systemd', d)}
29 29
30SYSTEMD_PACKAGES = "${PN}" 30SYSTEMD_PACKAGES = "${PN}"
31SYSTEMD_SERVICE_${PN} = "sblim-sfcb.service" 31SYSTEMD_SERVICE_${PN} = "sblim-sfcb.service"
diff --git a/meta-oe/recipes-extended/smartmontools/smartmontools_6.5.bb b/meta-oe/recipes-extended/smartmontools/smartmontools_6.5.bb
index 55d366e2e..0970d2a30 100644
--- a/meta-oe/recipes-extended/smartmontools/smartmontools_6.5.bb
+++ b/meta-oe/recipes-extended/smartmontools/smartmontools_6.5.bb
@@ -18,9 +18,7 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/smartmontools/smartmontools-${PV}.tar.gz \
18 file://smartd.service \ 18 file://smartd.service \
19" 19"
20 20
21PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'libcap-ng', 'libcap-ng', '', d)} \ 21PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'libcap-ng selinux', d)}"
22 ${@bb.utils.contains('DISTRO_FEATURES', 'selinux', 'selinux', '', d)} \
23"
24PACKAGECONFIG[libcap-ng] = "--with-libcap-ng=yes,--with-libcap-ng=no,libcap-ng" 22PACKAGECONFIG[libcap-ng] = "--with-libcap-ng=yes,--with-libcap-ng=no,libcap-ng"
25PACKAGECONFIG[selinux] = "--with-selinux=yes,--with-selinux=no,libselinux" 23PACKAGECONFIG[selinux] = "--with-selinux=yes,--with-selinux=no,libselinux"
26 24