diff options
author | Koen Kooi <koen.kooi@linaro.org> | 2016-05-10 12:19:36 -0400 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2016-05-19 12:02:38 +0200 |
commit | d68c687673a42afe5047481e9efe8c13de088f80 (patch) | |
tree | 5ef3fb4ba3f87aa90da6d35c315436665f7ae9ec /meta-oe/recipes-extended | |
parent | fe4cb8b07265edc8de476f5e8ebb0a883323919b (diff) | |
download | meta-openembedded-d68c687673a42afe5047481e9efe8c13de088f80.tar.gz |
efibootmgr: update and unblacklist
Also fix style issues.
Signed-off-by: Koen Kooi <koen.kooi@linaro.org>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended')
-rw-r--r-- | meta-oe/recipes-extended/efibootmgr/efibootmgr_0.12.bb | 14 | ||||
-rw-r--r-- | meta-oe/recipes-extended/efibootmgr/files/ldflags.patch | 17 |
2 files changed, 7 insertions, 24 deletions
diff --git a/meta-oe/recipes-extended/efibootmgr/efibootmgr_0.12.bb b/meta-oe/recipes-extended/efibootmgr/efibootmgr_0.12.bb index 9b611ce1d..d80c89fe4 100644 --- a/meta-oe/recipes-extended/efibootmgr/efibootmgr_0.12.bb +++ b/meta-oe/recipes-extended/efibootmgr/efibootmgr_0.12.bb | |||
@@ -10,20 +10,20 @@ DEPENDS = "pciutils zlib efivar" | |||
10 | 10 | ||
11 | COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux" | 11 | COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux" |
12 | 12 | ||
13 | SRC_URI = "https://github.com/rhinstaller/efibootmgr/releases/download/${BP}/${BP}.tar.bz2 \ | 13 | SRCREV = "eb6e36c9064eae256cd60df24a977e3abd87fd16" |
14 | file://ldflags.patch \ | 14 | SRC_URI = "git://github.com/rhinstaller/efibootmgr.git;protocol=https \ |
15 | " | 15 | " |
16 | 16 | ||
17 | SRC_URI[md5sum] = "6647f5cd807bc8484135ba74fcbcc39a" | 17 | S = "${WORKDIR}/git" |
18 | SRC_URI[sha256sum] = "a66f5850677e86255d93cb1cead04c3c48a823a2b864c579321f2a07f00256e6" | 18 | |
19 | |||
20 | inherit pkgconfig | ||
19 | 21 | ||
20 | EXTRA_OEMAKE = "'CC=${CC}' 'CFLAGS=${CFLAGS} -I${S}/src/include `pkg-config --cflags efivar` \ | 22 | EXTRA_OEMAKE = "'CC=${CC}' 'CFLAGS=${CFLAGS} -I${S}/src/include `pkg-config --cflags efivar` \ |
21 | -DEFIBOOTMGR_VERSION=\"$(RELEASE_MAJOR).$(RELEASE_MINOR)\" '" | 23 | -DEFIBOOTMGR_VERSION=\"$(RELEASE_MAJOR).$(RELEASE_MINOR)\" '" |
22 | 24 | ||
23 | do_install () { | 25 | do_install () { |
24 | install -D -p -m0755 src/efibootmgr/efibootmgr ${D}/${sbindir}/efibootmgr | 26 | install -D -p -m0755 src/efibootmgr ${D}/${sbindir}/efibootmgr |
25 | } | 27 | } |
26 | 28 | ||
27 | inherit pkgconfig | ||
28 | 29 | ||
29 | PNBLACKLIST[efibootmgr] ?= "Depends on blacklisted efivar" | ||
diff --git a/meta-oe/recipes-extended/efibootmgr/files/ldflags.patch b/meta-oe/recipes-extended/efibootmgr/files/ldflags.patch deleted file mode 100644 index 0d5594a31..000000000 --- a/meta-oe/recipes-extended/efibootmgr/files/ldflags.patch +++ /dev/null | |||
@@ -1,17 +0,0 @@ | |||
1 | Upstream-Status: Pending | ||
2 | |||
3 | Import this patch from meta-linaro. | ||
4 | |||
5 | Signed-off-by: Kai Kang <kai.kang@windriver.com> | ||
6 | |||
7 | --- efibootmgr-0.5.4.orig/Makefile | ||
8 | +++ efibootmgr-0.5.4/Makefile | ||
9 | @@ -11,6 +11,8 @@ | ||
10 | CFLAGS = $(EXTRA_CFLAGS) -DEFIBOOTMGR_VERSION=\"$(RELEASE_MAJOR).$(RELEASE_MINOR).$(RELEASE_SUBLEVEL)$(RELEASE_EXTRALEVEL)\" \ | ||
11 | -Wall -g -D_FILE_OFFSET_BITS=64 | ||
12 | |||
13 | + LDFLAGS += -lz | ||
14 | + | ||
15 | MODULES := src | ||
16 | |||
17 | BINDIR := /usr/sbin | ||