diff options
author | Khem Raj <raj.khem@gmail.com> | 2021-03-27 01:28:07 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2021-03-28 12:12:58 -0700 |
commit | 81ab62c975ba9658b6d3e4e68e081ac4cdca94b8 (patch) | |
tree | 36aec69b27eab9fb76028ef42a3db11996bf8081 /meta-oe/recipes-extended | |
parent | 6946f40707ed43426cd05ada1933e4867c7f6d4f (diff) | |
download | meta-openembedded-81ab62c975ba9658b6d3e4e68e081ac4cdca94b8.tar.gz |
sysdig: Upgrade to 0.27.1
Drop upstreamed patches
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended')
3 files changed, 2 insertions, 69 deletions
diff --git a/meta-oe/recipes-extended/sysdig/sysdig/0001-Fix-build-with-musl-backtrace-APIs-are-glibc-specifi.patch b/meta-oe/recipes-extended/sysdig/sysdig/0001-Fix-build-with-musl-backtrace-APIs-are-glibc-specifi.patch deleted file mode 100644 index cb8061157..000000000 --- a/meta-oe/recipes-extended/sysdig/sysdig/0001-Fix-build-with-musl-backtrace-APIs-are-glibc-specifi.patch +++ /dev/null | |||
@@ -1,49 +0,0 @@ | |||
1 | From 290703a5d21f34ea5ec23efc815a9f4df241e7e8 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Fri, 23 Oct 2015 00:33:32 -0700 | ||
4 | Subject: [PATCH] Fix build with musl, backtrace() APIs are glibc specific | ||
5 | |||
6 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
7 | --- | ||
8 | userspace/libsinsp/utils.cpp | 4 +++- | ||
9 | userspace/libsinsp/utils.h | 2 +- | ||
10 | 2 files changed, 4 insertions(+), 2 deletions(-) | ||
11 | |||
12 | --- a/userspace/libsinsp/utils.cpp | ||
13 | +++ b/userspace/libsinsp/utils.cpp | ||
14 | @@ -22,7 +22,7 @@ limitations under the License. | ||
15 | #include <limits.h> | ||
16 | #include <stdlib.h> | ||
17 | #include <sys/time.h> | ||
18 | -#ifndef CYGWING_AGENT | ||
19 | +#if !defined(CYGWING_AGENT) || defined(__GLIBC__) | ||
20 | #include <execinfo.h> | ||
21 | #endif | ||
22 | #include <unistd.h> | ||
23 | @@ -780,6 +780,7 @@ bool sinsp_utils::glob_match(const char | ||
24 | |||
25 | #ifndef CYGWING_AGENT | ||
26 | #ifndef _WIN32 | ||
27 | +#ifdef __GLIBC__ | ||
28 | void sinsp_utils::bt(void) | ||
29 | { | ||
30 | static const char start[] = "BACKTRACE ------------"; | ||
31 | @@ -801,6 +802,7 @@ void sinsp_utils::bt(void) | ||
32 | |||
33 | free(bt_syms); | ||
34 | } | ||
35 | +#endif // Glibc | ||
36 | #endif // _WIN32 | ||
37 | #endif // CYGWING_AGENT | ||
38 | |||
39 | --- a/userspace/libsinsp/utils.h | ||
40 | +++ b/userspace/libsinsp/utils.h | ||
41 | @@ -104,7 +104,7 @@ public: | ||
42 | |||
43 | static bool glob_match(const char *pattern, const char *string); | ||
44 | |||
45 | -#ifndef _WIN32 | ||
46 | +#if not defined(_WIN32) && defined(__GLIBC__) | ||
47 | // | ||
48 | // Print the call stack | ||
49 | // | ||
diff --git a/meta-oe/recipes-extended/sysdig/sysdig/fix-uint64-const.patch b/meta-oe/recipes-extended/sysdig/sysdig/fix-uint64-const.patch deleted file mode 100644 index 5c756294b..000000000 --- a/meta-oe/recipes-extended/sysdig/sysdig/fix-uint64-const.patch +++ /dev/null | |||
@@ -1,16 +0,0 @@ | |||
1 | Fix x86 build | ||
2 | |||
3 | Upstream-Status: Pending | ||
4 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
5 | |||
6 | --- a/userspace/libsinsp/cgroup_limits.cpp | ||
7 | +++ b/userspace/libsinsp/cgroup_limits.cpp | ||
8 | @@ -9,7 +9,7 @@ namespace { | ||
9 | // This reports extremely large values (e.g. almost-but-not-quite 9EiB as set by k8s) as unlimited. | ||
10 | // Note: we use the same maximum value for cpu shares/quotas as well; the typical values are much lower | ||
11 | // and so should never exceed CGROUP_VAL_MAX either | ||
12 | -constexpr const int64_t CGROUP_VAL_MAX = (1UL << 42u) - 1; | ||
13 | +constexpr const int64_t CGROUP_VAL_MAX = (1ULL << 42u) - 1; | ||
14 | |||
15 | /** | ||
16 | * \brief Read a single int64_t value from cgroupfs | ||
diff --git a/meta-oe/recipes-extended/sysdig/sysdig_git.bb b/meta-oe/recipes-extended/sysdig/sysdig_git.bb index 04a022af4..bb9f2da7c 100644 --- a/meta-oe/recipes-extended/sysdig/sysdig_git.bb +++ b/meta-oe/recipes-extended/sysdig/sysdig_git.bb | |||
@@ -20,12 +20,10 @@ RDEPENDS_${PN} = "bash" | |||
20 | 20 | ||
21 | SRC_URI = "git://github.com/draios/sysdig.git;branch=dev \ | 21 | SRC_URI = "git://github.com/draios/sysdig.git;branch=dev \ |
22 | file://0001-fix-build-with-LuaJIT-2.1-betas.patch \ | 22 | file://0001-fix-build-with-LuaJIT-2.1-betas.patch \ |
23 | file://0001-Fix-build-with-musl-backtrace-APIs-are-glibc-specifi.patch \ | ||
24 | file://fix-uint64-const.patch \ | ||
25 | file://aarch64.patch \ | 23 | file://aarch64.patch \ |
26 | " | 24 | " |
27 | SRCREV = "8daeef8da752c5f07f439391bc20c5948eb11470" | 25 | SRCREV = "67833b2aca06bd9d11cff7cb29f04fbf4ef96cad" |
28 | PV = "0.26.6" | 26 | PV = "0.27.1" |
29 | 27 | ||
30 | S = "${WORKDIR}/git" | 28 | S = "${WORKDIR}/git" |
31 | 29 | ||