summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended
diff options
context:
space:
mode:
authorQi.Chen@windriver.com <Qi.Chen@windriver.com>2015-10-21 15:47:39 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2015-10-23 12:56:41 +0200
commit8e26d2cddf21dc7c187bd65ae90e7f4189e504bb (patch)
treee5927af000111ae2a3b0e8267326f9bfce0dee98 /meta-oe/recipes-extended
parent2f5eb8f1b87a1ac3765cabc73e520ea643087ab4 (diff)
downloadmeta-openembedded-8e26d2cddf21dc7c187bd65ae90e7f4189e504bb.tar.gz
rrdtool: add systemd support and fix QA issue
When building rrdtool in a building directory where systemd is configured to be the init system, we would meet the following error. ERROR: QA Issue: rrdtool: Files/directories were installed but not shipped in any package: /lib /lib/systemd /lib/systemd/system /lib/systemd/system/rrdcached.socket /lib/systemd/system/rrdcached.service Fix this problem by adding systemd support to the rrdtool recipe. Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended')
-rw-r--r--meta-oe/recipes-extended/rrdtool/rrdtool_1.5.4.bb8
1 files changed, 6 insertions, 2 deletions
diff --git a/meta-oe/recipes-extended/rrdtool/rrdtool_1.5.4.bb b/meta-oe/recipes-extended/rrdtool/rrdtool_1.5.4.bb
index 14e196656..9b54deb22 100644
--- a/meta-oe/recipes-extended/rrdtool/rrdtool_1.5.4.bb
+++ b/meta-oe/recipes-extended/rrdtool/rrdtool_1.5.4.bb
@@ -15,11 +15,13 @@ SRC_URI = "\
15 15
16S = "${WORKDIR}/git" 16S = "${WORKDIR}/git"
17 17
18inherit autotools-brokensep gettext pythonnative perlnative python-dir cpan-base 18inherit autotools-brokensep gettext pythonnative perlnative python-dir cpan-base systemd
19
20SYSTEMD_SERVICE_${PN} = "rrdcached.socket rrdcached.service"
19 21
20EXTRA_AUTORECONF = "-I m4" 22EXTRA_AUTORECONF = "-I m4"
21 23
22PACKAGECONFIG ??= "python perl" 24PACKAGECONFIG ??= "python perl ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)}"
23 25
24PACKAGECONFIG[python] = "--enable-python=yes \ 26PACKAGECONFIG[python] = "--enable-python=yes \
25am_cv_python_pythondir=${STAGING_LIBDIR}/python${PYTHON_BASEVERSION}/site-packages \ 27am_cv_python_pythondir=${STAGING_LIBDIR}/python${PYTHON_BASEVERSION}/site-packages \
@@ -33,6 +35,8 @@ ac_cv_path_PERL_CC='${CC}', \
33 35
34PACKAGECONFIG[dbi] = "--enable-libdbi,--disable-libdbi,libdbi" 36PACKAGECONFIG[dbi] = "--enable-libdbi,--disable-libdbi,libdbi"
35 37
38PACKAGECONFIG[systemd] = "--with-systemdsystemunitdir=${systemd_unitdir}/system/,--without-systemdsystemunitdir,systemd,"
39
36EXTRA_OECONF = " \ 40EXTRA_OECONF = " \
37 --enable-shared \ 41 --enable-shared \
38 --disable-libwrap \ 42 --disable-libwrap \