summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended
diff options
context:
space:
mode:
authorleimaohui <leimaohui@cn.fujitsu.com>2015-08-25 13:19:54 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2015-08-31 19:11:11 +0200
commit0f2b4f7281865ead770335195c5f913eb7523057 (patch)
treeb016ff7ded398e057c5800a6e0015333b3ab6257 /meta-oe/recipes-extended
parent3aa61fb9512449477546320ec46cebf7e39daed0 (diff)
downloadmeta-openembedded-0f2b4f7281865ead770335195c5f913eb7523057.tar.gz
sblim-sfcb: add new recipe for openlmi
Sblim-sfcb is dependence of openlmi. Signed-off-by: Lei Maohui <leimaohui@cn.fujitsu.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended')
-rw-r--r--meta-oe/recipes-extended/sblim-sfcb/files/sfcb.service11
-rw-r--r--meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb-1.4.8/sblim-sfcb-1.3.15-fix-provider-debugging.patch12
-rw-r--r--meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb-1.4.8/sblim-sfcb-1.3.16-maxMsgLen.patch14
-rw-r--r--meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb-1.4.8/sblim-sfcb-1.3.16-multilib-man-cfg.patch41
-rw-r--r--meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb-1.4.8/sblim-sfcb-1.3.9-sfcbrepos-schema-location.patch42
-rw-r--r--meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb-1.4.8/sblim-sfcb-1.4.5-service.patch27
-rw-r--r--meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb-1.4.8/sblim-sfcb-1.4.8-default-ecdh-curve-name.patch26
-rw-r--r--meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb-1.4.8/sblim-sfcb-1.4.9-fix-ftbfs.patch12
-rw-r--r--meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb_1.4.8.bb83
9 files changed, 268 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/sblim-sfcb/files/sfcb.service b/meta-oe/recipes-extended/sblim-sfcb/files/sfcb.service
new file mode 100644
index 000000000..5adf63c8a
--- /dev/null
+++ b/meta-oe/recipes-extended/sblim-sfcb/files/sfcb.service
@@ -0,0 +1,11 @@
1[Unit]
2Description=Small Footprint CIM Broker Service
3After=syslog.target
4
5[Service]
6Type=oneshot
7ExecStart=/usr/sbin/sfcbd -d
8RemainAfterExit=yes
9
10[Install]
11WantedBy=multi-user.target
diff --git a/meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb-1.4.8/sblim-sfcb-1.3.15-fix-provider-debugging.patch b/meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb-1.4.8/sblim-sfcb-1.3.15-fix-provider-debugging.patch
new file mode 100644
index 000000000..4fbecaa63
--- /dev/null
+++ b/meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb-1.4.8/sblim-sfcb-1.3.15-fix-provider-debugging.patch
@@ -0,0 +1,12 @@
1diff -up sblim-sfcb-1.4.5/providerDrv.c.orig sblim-sfcb-1.4.5/providerDrv.c
2--- sblim-sfcb-1.4.5/providerDrv.c.orig 2013-09-04 12:59:22.140813239 +0200
3+++ sblim-sfcb-1.4.5/providerDrv.c 2013-09-04 12:59:40.511870274 +0200
4@@ -3585,7 +3585,7 @@ processProviderInvocationRequests(char *
5 rc = spRecvReq(&providerSockets.receive, &parms->requestor,
6 (void **) &parms->req, &rl, &mqg);
7 if (mqg.rdone) {
8- int debug_break = 0;
9+ volatile int debug_break = 0;
10 if (rc != 0) {
11 mlogf(M_ERROR,M_SHOW, "spRecvReq returned error %d. Skipping message.\n", rc);
12 free(parms);
diff --git a/meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb-1.4.8/sblim-sfcb-1.3.16-maxMsgLen.patch b/meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb-1.4.8/sblim-sfcb-1.3.16-maxMsgLen.patch
new file mode 100644
index 000000000..a0dd81653
--- /dev/null
+++ b/meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb-1.4.8/sblim-sfcb-1.3.16-maxMsgLen.patch
@@ -0,0 +1,14 @@
1diff -up sblim-sfcb-1.3.16/sfcb.cfg.pre.in.old sblim-sfcb-1.3.16/sfcb.cfg.pre.in
2--- sblim-sfcb-1.3.16/sfcb.cfg.pre.in.old 2012-06-13 23:21:09.000000000 +0200
3+++ sblim-sfcb-1.3.16/sfcb.cfg.pre.in 2013-06-24 15:34:38.881992781 +0200
4@@ -113,8 +113,8 @@ provProcs: 32
5
6 ## Max message length, in bytes. This is a limit on the size of messages
7 ## written across sockets, for instance, between providers and SFCB.
8-## Default is 10000000
9-maxMsgLen: 10000000
10+## Default is 100000000
11+maxMsgLen: 100000000
12
13 ## Location of the registration directory, where providerRegister can be found
14 ## Default is @localstatedir@/lib/sfcb/registration
diff --git a/meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb-1.4.8/sblim-sfcb-1.3.16-multilib-man-cfg.patch b/meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb-1.4.8/sblim-sfcb-1.3.16-multilib-man-cfg.patch
new file mode 100644
index 000000000..c8cece2c2
--- /dev/null
+++ b/meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb-1.4.8/sblim-sfcb-1.3.16-multilib-man-cfg.patch
@@ -0,0 +1,41 @@
1diff -up sblim-sfcb-1.3.16/man/sfcbd.1.pre.in.orig sblim-sfcb-1.3.16/man/sfcbd.1.pre.in
2--- sblim-sfcb-1.3.16/man/sfcbd.1.pre.in.orig 2014-02-26 14:05:32.213091734 +0100
3+++ sblim-sfcb-1.3.16/man/sfcbd.1.pre.in 2014-02-26 15:10:54.476196379 +0100
4@@ -151,7 +151,7 @@ Default=\fI@localstatedir@/lib/sfcb/regi
5 .TP
6 .B providerDirs
7 A space separated list of directories where sfcb is looking for provider
8-libraries. Default=\fI@libdir@\ @libdir@/cmpi\fR
9+libraries. Default=\fI/usr/lib\ /usr/lib/cmpi /usr/lib64\ /usr/lib64/cmpi\fR
10 .TP
11 .B providerSampleInterval
12 The interval in seconds at which the provider manager is checking for
13@@ -275,11 +275,11 @@ SSL private key file for sfcb.
14 SSL client certificate / trust store for sfcb.
15 .SH LIBRARIES
16 .TP
17-.I @libdir@/libsfc*
18+.I /usr/lib/libsfc* /usr/lib64/libsfc*
19 Binaries for sfcb runtime libraries.
20 .TP
21-.I @libdir@/cmpi/*
22-Binaries for providers
23+.I /usr/lib/cmpi/* /usr/lib64/cmpi/*
24+Binaries for providers.
25 .SH AUTHOR
26 Adrian Schuur <schuur@de.ibm.com>
27 .SH CONRIBUTORS
28diff -up sblim-sfcb-1.3.16/sfcb.cfg.pre.in.orig sblim-sfcb-1.3.16/sfcb.cfg.pre.in
29--- sblim-sfcb-1.3.16/sfcb.cfg.pre.in.orig 2014-02-26 15:35:43.133869718 +0100
30+++ sblim-sfcb-1.3.16/sfcb.cfg.pre.in 2014-02-26 15:38:12.794240532 +0100
31@@ -121,8 +121,8 @@ maxMsgLen: 100000000
32 registrationDir: @localstatedir@/lib/sfcb/registration
33
34 ## Locations to look for provider libraries. Delimit paths with a space.
35-## Default is @libdir@/sfcb @libdir@ @libdir@/cmpi
36-providerDirs: @libdir@/sfcb @libdir@ @libdir@/cmpi
37+## Default is /usr/lib/sfcb /usr/lib64/sfcb /usr/lib /usr/lib64 /usr/lib/cmpi /usr/lib64/cmpi
38+providerDirs: /usr/lib/sfcb /usr/lib64/sfcb /usr/lib /usr/lib64 /usr/lib/cmpi /usr/lib64/cmpi
39
40 ## Enable the root/interop namespace (affects indications)
41 ## Default: true
diff --git a/meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb-1.4.8/sblim-sfcb-1.3.9-sfcbrepos-schema-location.patch b/meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb-1.4.8/sblim-sfcb-1.3.9-sfcbrepos-schema-location.patch
new file mode 100644
index 000000000..7f95a9da3
--- /dev/null
+++ b/meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb-1.4.8/sblim-sfcb-1.3.9-sfcbrepos-schema-location.patch
@@ -0,0 +1,42 @@
1diff -up sblim-sfcb-1.3.9/man/sfcbrepos.1.pre.in.orig sblim-sfcb-1.3.9/man/sfcbrepos.1.pre.in
2--- sblim-sfcb-1.3.9/man/sfcbrepos.1.pre.in.orig 2009-10-13 21:54:13.000000000 +0200
3+++ sblim-sfcb-1.3.9/man/sfcbrepos.1.pre.in 2010-09-06 14:01:57.294564062 +0200
4@@ -26,7 +26,7 @@ Supported command line options are:
5 .TP
6 \fB\-c\fR \fIschemadir\fR
7 Path to obtain the CIM Schema classes.
8-Default is \fI@datadir@/sfcb\fR
9+Default is \fI@datadir@/mof/cim-current\fR
10 .TP
11 \fB\-s\fR \fIstagingdir\fR
12 Path to sfcb staging area containing class MOFs and registration files
13@@ -58,7 +58,7 @@ Alias of \fB-b\fR
14 Display usage information and exit.
15 .SH FILES
16 .TP
17-\fI@datadir@/sfcb/CIM/CIM_Schema.mof\fR
18+\fI@datadir@/mof/cim-current/CIM_Schema.mof\fR
19 CIM Schema
20 .TP
21 \fI@localstatedir@/lib/sfcb/registration/providerRegister\fR
22diff -up sblim-sfcb-1.3.9/sfcbrepos.sh.in.orig sblim-sfcb-1.3.9/sfcbrepos.sh.in
23--- sblim-sfcb-1.3.9/sfcbrepos.sh.in.orig 2009-12-22 01:18:29.000000000 +0100
24+++ sblim-sfcb-1.3.9/sfcbrepos.sh.in 2010-09-06 13:45:28.671491648 +0200
25@@ -59,7 +59,7 @@ then
26 echo -e "\t-X create repository in non-native format as specifed by argument"
27 echo -e "\t-s specify staging directory [@localstatedir@/lib/sfcb/stage]"
28 echo -e "\t-r specify repository directory [@localstatedir@/lib/sfcb/registration]"
29- echo -e "\t-c specify directory containing CIM Schema MOFs [@datadir@/sfcb/CIM]"
30+ echo -e "\t-c specify directory containing CIM Schema MOFs [@datadir@/mof/cim-current]"
31 echo -e "\t-t create tiny class repository by omitting inheritance information"
32 echo -e "\t-z compress repository with gzip"
33 echo
34@@ -99,7 +99,7 @@ fi
35
36 if [ -z "$cimschemadir" ]
37 then
38- cimschemadir=${DESTDIR}@datadir@/sfcb/CIM
39+ cimschemadir=${DESTDIR}@datadir@/mof/cim-current
40 fi
41
42 if [ -d $stagingdir ] && [ -f $stagingdir/default.reg ] &&
diff --git a/meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb-1.4.8/sblim-sfcb-1.4.5-service.patch b/meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb-1.4.8/sblim-sfcb-1.4.5-service.patch
new file mode 100644
index 000000000..eaccfa594
--- /dev/null
+++ b/meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb-1.4.8/sblim-sfcb-1.4.5-service.patch
@@ -0,0 +1,27 @@
1diff -up sblim-sfcb-1.4.6/Makefile.in.orig sblim-sfcb-1.4.6/Makefile.in
2--- sblim-sfcb-1.4.6/Makefile.in.orig 2013-10-07 10:43:34.783228137 +0200
3+++ sblim-sfcb-1.4.6/Makefile.in 2013-10-07 10:44:30.178533289 +0200
4@@ -627,7 +627,6 @@ initdir = $(sysconfdir)/init.d
5 pamdir = $(sysconfdir)/pam.d
6 sfcblibdir = $(libdir)/sfcb
7 cmpilibdir = $(libdir)/cmpi
8-systemddir = $(DESTDIR)@SYSTEMDDIR@
9 MANFILES = man/genSslCert.1 man/getSchema.1 man/sfcbd.1 man/sfcbmof.1 \
10 man/sfcbrepos.1 man/sfcbstage.1 man/sfcbunstage.1 man/sfcbuuid.1 \
11 man/wbemcat.1 man/xmltest.1
12@@ -2366,7 +2365,6 @@ unittest:
13 cd test && sh check_all.sh
14
15 install-data-local:
16- if test -d $(systemddir); then cp $(srcdir)/sblim-sfcb.service $(systemddir); fi;
17 test -d $(DESTDIR)$(sfcbstatedir)/registration/repository || $(mkdir_p) $(DESTDIR)$(sfcbstatedir)/registration/repository
18 test -d $(DESTDIR)$(sfcbstatedir)/stage/mofs/root/interop || $(mkdir_p) $(DESTDIR)$(sfcbstatedir)/stage/mofs/root/interop
19 test -d $(DESTDIR)$(sfcbstatedir)/stage/regs || $(mkdir_p) $(DESTDIR)$(sfcbstatedir)/stage/regs
20@@ -2384,7 +2382,6 @@ install-data-local:
21 uninstall-local:
22 rm -f $(DESTDIR)$(sfcbstatedir)/stage/default.reg
23 rm -f $(DESTDIR)$(sfcbstatedir)/stage/mofs/root/interop/10_interop.mof
24- rm -f $(systemddir)/sblim-sfcb.service
25 @INDICATIONS_TRUE@ rm -f $(DESTDIR)$(sfcbstatedir)/stage/mofs/root/interop/20_indication.mof
26 @INDICATIONS_TRUE@ rm -f $(DESTDIR)$(sfcbstatedir)/stage/mofs/indication.mof
27 @DOCS_TRUE@ rm -rf $(DESTDIR)$(sfcbdocdir)/html
diff --git a/meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb-1.4.8/sblim-sfcb-1.4.8-default-ecdh-curve-name.patch b/meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb-1.4.8/sblim-sfcb-1.4.8-default-ecdh-curve-name.patch
new file mode 100644
index 000000000..3268d49f4
--- /dev/null
+++ b/meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb-1.4.8/sblim-sfcb-1.4.8-default-ecdh-curve-name.patch
@@ -0,0 +1,26 @@
1diff -up sblim-sfcb-1.4.8/control.c.orig sblim-sfcb-1.4.8/control.c
2--- sblim-sfcb-1.4.8/control.c.orig 2014-03-27 00:46:28.000000000 +0100
3+++ sblim-sfcb-1.4.8/control.c 2014-05-15 12:31:38.304169409 +0200
4@@ -170,7 +170,7 @@ static Control init[] = {
5 {"sslCertList", CTL_STRING, SFCB_CONFDIR "/clist.pem", {0}},
6 {"sslCiphers", CTL_STRING, "ALL:!ADH:!LOW:!EXP:!MD5:@STRENGTH", {0}},
7 {"sslDhParamsFilePath", CTL_STRING, NULL, {0}},
8- {"sslEcDhCurveName", CTL_STRING, "secp224r1", {0}},
9+ {"sslEcDhCurveName", CTL_STRING, "secp384r1", {0}},
10 {"enableSslCipherServerPref", CTL_BOOL, NULL, {.b=0}},
11
12 {"registrationDir", CTL_STRING, SFCB_STATEDIR "/registration", {0}},
13diff -up sblim-sfcb-1.4.8/sfcb.cfg.pre.in.orig sblim-sfcb-1.4.8/sfcb.cfg.pre.in
14--- sblim-sfcb-1.4.8/sfcb.cfg.pre.in.orig 2014-05-15 12:31:59.188244865 +0200
15+++ sblim-sfcb-1.4.8/sfcb.cfg.pre.in 2014-05-15 12:32:45.554408412 +0200
16@@ -293,8 +293,8 @@ sslCiphers: ALL:!ADH:!LOW:!EXP:!MD5:@STR
17 ## environment. If this value is not set, the indicated default is in effect.
18 ## If the value is set but the curve name is not recognized by the underlying
19 ## openssl implementation, SFCB will abort.
20-## Default is secp224r1
21-#sslEcDhCurveName: secp224r1
22+## Default is secp384r1
23+#sslEcDhCurveName: secp384r1
24
25 ## When set to true, sets the SSL_OP_CIPHER_SERVER_PREFERENCE flag for the ssl
26 ## context, to enforce server's preference instead of the client preference for
diff --git a/meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb-1.4.8/sblim-sfcb-1.4.9-fix-ftbfs.patch b/meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb-1.4.8/sblim-sfcb-1.4.9-fix-ftbfs.patch
new file mode 100644
index 000000000..9548b3c06
--- /dev/null
+++ b/meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb-1.4.8/sblim-sfcb-1.4.9-fix-ftbfs.patch
@@ -0,0 +1,12 @@
1diff -up sblim-sfcb-1.4.9/control.c.orig sblim-sfcb-1.4.9/control.c
2--- sblim-sfcb-1.4.9/control.c.orig 2015-07-13 15:06:21.331660336 +0200
3+++ sblim-sfcb-1.4.9/control.c 2015-07-13 15:08:38.031308917 +0200
4@@ -83,7 +83,7 @@ long httpReqHandlerTimeout;
5 * Kindly null terminate, always, even if might overwrite
6 * the last char of the truncated string.
7 */
8-inline char *strncpy_kind(char *to, char *from, size_t size) {
9+char *strncpy_kind(char *to, char *from, size_t size) {
10 strncpy(to, from, size);
11 *(to + size - 1) = '\0';
12 return to;
diff --git a/meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb_1.4.8.bb b/meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb_1.4.8.bb
new file mode 100644
index 000000000..5474fc64c
--- /dev/null
+++ b/meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb_1.4.8.bb
@@ -0,0 +1,83 @@
1SUMMARY = "Small Footprint CIM Broker"
2DESCRIPTION = "\
3Small Footprint CIM Broker (sfcb) is a CIM server conforming to the CIM \
4Operations over HTTP protocol. It is robust, with low resource consumption \
5and therefore specifically suited for embedded and resource constrained \
6environments. sfcb supports providers written against the Common \
7Manageability Programming Interface (CMPI)."
8HOMEPAGE = "http://www.sblim.org"
9SECTION = "Applications/System"
10LICENSE = "EPL-1.0"
11LIC_FILES_CHKSUM = "file://COPYING;md5=f300afd598546add034364cd0a533261"
12DEPENDS = "curl libpam openssl sblim-sfcCommon"
13
14SRC_URI = "http://downloads.sourceforge.net/sblim/${PN}-${PV}.tar.bz2 \
15 file://sblim-sfcb-1.3.9-sfcbrepos-schema-location.patch \
16 file://sblim-sfcb-1.3.15-fix-provider-debugging.patch \
17 file://sblim-sfcb-1.3.16-maxMsgLen.patch \
18 file://sblim-sfcb-1.4.5-service.patch \
19 file://sblim-sfcb-1.3.16-multilib-man-cfg.patch \
20 file://sblim-sfcb-1.4.8-default-ecdh-curve-name.patch \
21 file://sblim-sfcb-1.4.9-fix-ftbfs.patch \
22 file://sfcb.service"
23
24SRC_URI[md5sum] = "b2e0cb26628cb31e2374959637d9268c"
25SRC_URI[sha256sum] = "7dc0f16e2c2d3767466a09afee04e6febd611c157d66f8f0ae666be1fefbff3b"
26
27inherit autotools
28inherit ${@base_contains('VIRTUAL-RUNTIME_init_manager','systemd','systemd','', d)}
29
30SYSTEMD_PACKAGES = "${PN}"
31SYSTEMD_SERVICE_${PN} = "sblim-sfcb.service"
32SYSTEMD_AUTO_ENABLE = "enable"
33
34LDFLAGS_append = "${@base_contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}"
35
36EXTRA_OECONF = '--enable-debug \
37 --enable-ssl \
38 --enable-pam \
39 --enable-ipv6 \
40 CFLAGS="${CFLAGS} -D_GNU_SOURCE"'
41
42# make all with -j option is unsafe.
43PARALLEL_MAKE = ""
44
45INSANE_SKIP_${PN} = "dev-so"
46CONFIG_SITE = "${WORKDIR}/config-site.${P}"
47
48do_install() {
49 cp -f ${S}/sfcb.cfg.pre.in ${S}/sfcb.cfg
50
51 oe_runmake DESTDIR=${D} install
52
53 if ${@base_contains('DISTRO_FEATURES','systemd','true','false',d)}; then
54 install -d ${D}${systemd_unitdir}/system
55 install -m 0644 ${WORKDIR}/sfcb.service ${D}${systemd_unitdir}/system/sblim-sfcb.service
56 fi
57
58 install -d ${D}${sysconfdir}/init.d
59 mv ${D}${sysconfdir}/init.d/sfcb ${D}${sysconfdir}/init.d/sblim-sfcb
60 sed -i -e 's/\/var\/lock\/subsys\/sfcb/\/var\/lock\/subsys\/sblim-sfcb/g' ${D}${sysconfdir}/init.d/sblim-sfcb
61
62 rm -rf ${D}${libdir}/sfcb/*.la
63}
64
65pkg_postinst_${PN} () {
66 OPTS=""
67
68 if [ x"$D" != "x" ]; then
69 OPTS="--root=$D"
70 if type systemctl >/dev/null 2>/dev/null; then
71 systemctl $OPTS ${SYSTEMD_AUTO_ENABLE} ${SYSTEMD_SERVICE}
72 fi
73 exit 1
74 fi
75
76 ${datadir}/sfcb/genSslCert.sh ${sysconfdir}/sfcb
77 ${bindir}/sfcbrepos -f
78}
79
80FILES_${PN} += "${libdir}/sfcb ${datadir}/sfcb"
81FILES_${PN}-dbg += "${libdir}/sfcb/.debug"
82
83RDEPENDS_${PN} = "perl bash"