summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended
diff options
context:
space:
mode:
authorQian Lei <qianl.fnst@cn.fujitsu.com>2014-11-24 13:21:55 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2014-11-28 13:41:01 +0100
commit7f24cb1fe493152ba17e7ded10226c48ad572580 (patch)
treeb9ee43e77c545861de257aa2e9a76eb89c65c98a /meta-oe/recipes-extended
parent34be57e7454ffe5f591cc0d7638bf41bb4377a61 (diff)
downloadmeta-openembedded-7f24cb1fe493152ba17e7ded10226c48ad572580.tar.gz
indent: Add new recipe
Indent is a GNU program for beautifying C code, so that it is easier to read. Indent can also convert from one C writing style to a different one. Indent understands correct C syntax and tries to handle incorrect C syntax. Signed-off-by: Qian Lei <qianl.fnst@cn.fujitsu.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended')
-rw-r--r--meta-oe/recipes-extended/indent/indent_2.2.10.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/indent/indent_2.2.10.bb b/meta-oe/recipes-extended/indent/indent_2.2.10.bb
new file mode 100644
index 000000000..dbd6b7b59
--- /dev/null
+++ b/meta-oe/recipes-extended/indent/indent_2.2.10.bb
@@ -0,0 +1,22 @@
1SUMMARY = "A GNU program for formatting C code"
2HOMEPAGE = "http://www.gnu.org/software/indent/"
3SECTION = "Applications/Text"
4DESCRIPTION = "Indent is a GNU program for beautifying C code, so that \
5it is easier to read. Indent can also convert from one C writing style \
6to a different one. Indent understands correct C syntax and tries to handle \
7incorrect C syntax. \
8Install the indent package if you are developing applications in C and \
9you want a program to format your code."
10LICENSE = "GPL-2.0"
11LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
12DEPENDS = "virtual/gettext"
13
14SRC_URI = "${GNU_MIRROR}/${BPN}/${BP}.tar.gz"
15SRC_URI[md5sum] = "be35ea62705733859fbf8caf816d8959"
16SRC_URI[sha256sum] = "8a9b41be5bfcab5d8c1be74204b10ae78789fc3deabea0775fdced8677292639"
17
18inherit autotools gettext
19
20FILES_${PN}-doc += "/usr/doc/indent/indent.html"
21
22BBCLASSEXTEND = "native"