summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended
diff options
context:
space:
mode:
authorBian Naimeng <biannm@cn.fujitsu.com>2014-11-14 17:20:02 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2014-11-24 11:59:49 +0100
commit34909b91af6ef2006f1664908486b79192c53015 (patch)
tree687716cc9eef7ff4c886a53b3827b6fe34d16003 /meta-oe/recipes-extended
parent8da5b698fce2b44d965d8aeb36349754d0d3d4d9 (diff)
downloadmeta-openembedded-34909b91af6ef2006f1664908486b79192c53015.tar.gz
dash: Port from openembedded and upgrade to 0.5.8
Signed-off-by: Bian Naimeng <biannm@cn.fujitsu.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended')
-rw-r--r--meta-oe/recipes-extended/dash/dash_0.5.8.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/dash/dash_0.5.8.bb b/meta-oe/recipes-extended/dash/dash_0.5.8.bb
new file mode 100644
index 000000000..c3dbd45f9
--- /dev/null
+++ b/meta-oe/recipes-extended/dash/dash_0.5.8.bb
@@ -0,0 +1,27 @@
1SUMMARY = "Small and fast POSIX-compliant shell"
2HOMEPAGE = "http://gondor.apana.org.au/~herbert/dash/"
3SECTION = "System Environment/Shells"
4
5LICENSE = "BSD GPLv2+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=b5262b4a1a1bff72b48e935531976d2e"
7
8inherit autotools update-alternatives
9
10SRC_URI = "http://gondor.apana.org.au/~herbert/dash/files/${PN}-${PV}.tar.gz"
11SRC_URI[md5sum] = "5c152209680dab3c319e8923f6c51378"
12SRC_URI[sha256sum] = "c6db3a237747b02d20382a761397563d813b306c020ae28ce25a1c3915fac60f"
13
14EXTRA_OECONF += "--bindir=${base_bindir}"
15
16ALTERNATIVE_${PN} = "sh"
17ALTERNATIVE_LINK_NAME[sh] = "${base_bindir}/sh"
18ALTERNATIVE_TARGET[sh] = "${base_bindir}/dash"
19ALTERNATIVE_PRIORITY = "10"
20
21pkg_postinst_${PN} () {
22 grep -q "^${base_bindir}/dash$" $D${sysconfdir}/shells || echo ${base_bindir}/dash >> $D${sysconfdir}/shells
23}
24
25pkg_postrm_${PN} () {
26 printf "$(grep -v "^${base_bindir}/dash$" $D${sysconfdir}/shells)\n" > $D${sysconfdir}/shells
27}