summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended
diff options
context:
space:
mode:
authorPeter Tworek <tworaz666@gmail.com>2012-03-05 20:53:21 +0000
committerKhem Raj <raj.khem@gmail.com>2012-03-11 10:10:38 -0700
commitfe04de5c6d979d06b683dc0e44e019546bb79ac8 (patch)
treeb5e94e2a88d14f3cf9da997543797e096bd5ac42 /meta-oe/recipes-extended
parente0023c5a6eccdb20e0ecf892fcb5ecc7743b3b0b (diff)
downloadmeta-openembedded-fe04de5c6d979d06b683dc0e44e019546bb79ac8.tar.gz
zsh: Add initial recipe for version 4.3.17.
Run tested on netbook pro. Signed-off-by: Peter Tworek <tworaz666@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended')
-rw-r--r--meta-oe/recipes-extended/zsh/zsh_4.3.17.bb51
1 files changed, 51 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/zsh/zsh_4.3.17.bb b/meta-oe/recipes-extended/zsh/zsh_4.3.17.bb
new file mode 100644
index 0000000000..9192f20831
--- /dev/null
+++ b/meta-oe/recipes-extended/zsh/zsh_4.3.17.bb
@@ -0,0 +1,51 @@
1DESCRIPTION = "UNIX Shell similar to the Korn shell"
2HOMEPAGE="http://www.zsh.org"
3SECTION = "base/shell"
4
5LICENSE = "ZSH"
6LIC_FILES_CHKSUM = "file://LICENCE;md5=ad234d4b46db63491c4a9789da4fb341"
7
8DEPENDS = "ncurses libcap libpcre gdbm groff-native"
9
10SRC_URI = "ftp://ftp.zsh.org/pub/${P}.tar.bz2"
11SRC_URI[md5sum] = "8258967060b2654f30001a011946ac6a"
12SRC_URI[sha256sum] = "054e0452afd9c742c9f1489465175e1d4d7db50d88b602d132551d850cf7a704"
13
14FILES_${PN}-dbg += "\
15 ${libdir}/${PN}/${PV}/${PN}/.debug/*.so \
16 ${libdir}/${PN}/${PV}/${PN}/db/.debug/*.so \
17 ${libdir}/${PN}/${PV}/${PN}/net/.debug/*.so \
18 "
19
20inherit autotools
21
22EXTRA_OECONF = " \
23 --bindir=${base_bindir} \
24 --enable-etcdir=${sysconfdir} \
25 --enable-fndir=${datadir}/${PN}/${PV}/functions \
26 --enable-site-fndir=${datadir}/${PN}/site-functions \
27 --enable-function-subdirs \
28 --with-term-lib='ncursesw ncurses' \
29 --with-tcsetpgrp \
30 --enable-pcre \
31 --enable-cap \
32 --enable-multibyte \
33 --enable-gdbm \
34 --enable-dynamic \
35 zsh_cv_shared_environ=yes \
36 "
37
38do_configure () {
39 oe_runconf
40}
41
42pkg_postinst_${PN} () {
43 touch $D${sysconfdir}/shells
44 grep -q "bin/zsh" $D${sysconfdir}/shells || echo "/bin/zsh" >> $D${sysconfdir}/shells
45}
46
47pkg_postrm_${PN} () {
48 if [ -e $D${sysconfdir}/shells ]; then
49 sed -i -e '/\/bin\/zsh/d' $D${sysconfdir}/shells
50 fi
51}