summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-04-13 14:49:10 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-15 16:22:05 +0200
commitfe76f1ab77c118e077d2c98f405b6b78ad35a124 (patch)
treec58f86229942a17f87a9c0ec3b2942315b191cad /meta-oe/recipes-extended
parent1e29c4586eaf7af68ec8ea4276114cc6aec05a11 (diff)
downloadmeta-openembedded-fe76f1ab77c118e077d2c98f405b6b78ad35a124.tar.gz
atftp: move systemd support from meta-systemd back to meta-oe
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended')
-rw-r--r--meta-oe/recipes-extended/atftp/atftp/atftpd.service10
-rw-r--r--meta-oe/recipes-extended/atftp/atftp_git.bb19
2 files changed, 27 insertions, 2 deletions
diff --git a/meta-oe/recipes-extended/atftp/atftp/atftpd.service b/meta-oe/recipes-extended/atftp/atftp/atftpd.service
new file mode 100644
index 000000000..480bc702e
--- /dev/null
+++ b/meta-oe/recipes-extended/atftp/atftp/atftpd.service
@@ -0,0 +1,10 @@
1[Unit]
2Description=Advanced TFTP Server
3After=syslog.target network.target
4
5[Service]
6Type=forking
7ExecStart=/usr/sbin/atftpd --daemon --port 69
8
9[Install]
10WantedBy=multi-user.target
diff --git a/meta-oe/recipes-extended/atftp/atftp_git.bb b/meta-oe/recipes-extended/atftp/atftp_git.bb
index 774dd6884..67a2c1b4c 100644
--- a/meta-oe/recipes-extended/atftp/atftp_git.bb
+++ b/meta-oe/recipes-extended/atftp/atftp_git.bb
@@ -4,6 +4,7 @@ HOMEPAGE = "http://packages.debian.org/atftp"
4LICENSE = "GPLv2" 4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=94d55d512a9ba36caa9b7df079bae19f" 5LIC_FILES_CHKSUM = "file://LICENSE;md5=94d55d512a9ba36caa9b7df079bae19f"
6PV = "0.7.1+git${SRCPV}" 6PV = "0.7.1+git${SRCPV}"
7PR = "r3"
7 8
8SRCREV = "be3291a18c069ae23a124ffdc56d64a5ff0bbec7" 9SRCREV = "be3291a18c069ae23a124ffdc56d64a5ff0bbec7"
9 10
@@ -11,10 +12,11 @@ SRC_URI = "git://atftp.git.sourceforge.net/gitroot/atftp/atftp;protocol=git \
11 file://atftpd-0.7_circumvent_tftp_size_restrictions.patch \ 12 file://atftpd-0.7_circumvent_tftp_size_restrictions.patch \
12 file://atftpd-0.7_unprotected_assignments_crash.patch \ 13 file://atftpd-0.7_unprotected_assignments_crash.patch \
13 file://atftpd.init \ 14 file://atftpd.init \
15 file://atftpd.service \
14 " 16 "
15S = "${WORKDIR}/git" 17S = "${WORKDIR}/git"
16 18
17inherit autotools update-rc.d useradd 19inherit autotools update-rc.d useradd systemd
18 20
19INITSCRIPT_PACKAGES = "${PN}d" 21INITSCRIPT_PACKAGES = "${PN}d"
20INITSCRIPT_NAME_${PN}d = "atftpd" 22INITSCRIPT_NAME_${PN}d = "atftpd"
@@ -31,10 +33,23 @@ do_install_append() {
31 install -d ${D}/srv/tftp 33 install -d ${D}/srv/tftp
32 34
33 rm ${D}${sbindir}/in.tftpd 35 rm ${D}${sbindir}/in.tftpd
36
37 install -d ${D}${systemd_unitdir}/system
38 install -m 0644 ${WORKDIR}/atftpd.service ${D}${systemd_unitdir}/system
34} 39}
35 40
36PACKAGES =+ "atftpd" 41PACKAGES =+ "atftpd"
37 42
38FILES_${PN} = "${bindir}/*" 43FILES_${PN} = "${bindir}/*"
39 44
40FILES_${PN}d = "${sbindir}/* ${sysconfdir}/init.d/* /srv/tftp" 45FILES_${PN}d = "${sbindir}/* \
46 ${sysconfdir}/init.d/* \
47 /srv/tftp \
48 ${systemd_unitdir}/system/atftpd.service \
49"
50
51SYSTEMD_PACKAGES = "${PN}d"
52SYSTEMD_SERVICE_${PN}d = "atftpd.service"
53RPROVIDES_${PN}d += "${PN}d-systemd"
54RREPLACES_${PN}d += "${PN}d-systemd"
55RCONFLICTS_${PN}d += "${PN}d-systemd"