diff options
author | Paul Eggleton <paul.eggleton@linux.intel.com> | 2012-10-07 10:47:38 +0000 |
---|---|---|
committer | Koen Kooi <koen@dominion.thruhere.net> | 2012-10-09 14:25:40 +0200 |
commit | aee9bec6331c303d9a24351e1f8d5cf6b510ed7b (patch) | |
tree | a4f5f71662cbbed2749436a0246b9c578f43032e /meta-oe/recipes-extended | |
parent | aff5f48fb89ae8427cbbd5341f3bd1d4e43582f6 (diff) | |
download | meta-openembedded-aee9bec6331c303d9a24351e1f8d5cf6b510ed7b.tar.gz |
lcdproc: add recipe from OE-Classic and update/clean up
* Update to latest upstream version 0.5.5
* Add an Ubuntu patch to fix incompatibility with current automake
* Use automatic package splitting for drivers
* Allow specifying drivers to build via LCD_DRIVERS
* Allow specifying default enabled driver via LCD_DEFAULT_DRIVER
* Disable g15 driver by default (but allow it to be re-enabled using
PACKAGECONFIG, assuming the required recipes are also provided).
* Fix conf files not going into lcdvc and lcdd packages due to
override expansion not happening at the expected time (for
CONFFILES_*)
* Remove some unnecessary cruft
* Move packaging parts of recipe below do_install
* Add LIC_FILES_CHKSUM
* Make LICENSE more accurate
* Add SUMMARY
Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-extended')
-rw-r--r-- | meta-oe/recipes-extended/lcdproc/lcdproc/automake-111-fix.patch | 21 | ||||
-rw-r--r-- | meta-oe/recipes-extended/lcdproc/lcdproc5.inc | 77 | ||||
-rw-r--r-- | meta-oe/recipes-extended/lcdproc/lcdproc_0.5.5.bb | 24 |
3 files changed, 122 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/lcdproc/lcdproc/automake-111-fix.patch b/meta-oe/recipes-extended/lcdproc/lcdproc/automake-111-fix.patch new file mode 100644 index 000000000..061cc22f0 --- /dev/null +++ b/meta-oe/recipes-extended/lcdproc/lcdproc/automake-111-fix.patch | |||
@@ -0,0 +1,21 @@ | |||
1 | Description: With automake 1.11.3, pkglib_PROGRAMS is not valid anymore, | ||
2 | so work around this by using my_execbin_PROGRAMS. | ||
3 | Author: Andreas Moog <amoog@ubuntu.com> | ||
4 | Bug-Ubuntu: https://bugs.launchpad.net/bugs/934265 | ||
5 | |||
6 | Upstream-Status: Backport | ||
7 | |||
8 | Index: lcdproc-0.5.5/server/drivers/Makefile.am | ||
9 | =================================================================== | ||
10 | --- lcdproc-0.5.5.orig/server/drivers/Makefile.am 2012-02-26 14:04:37.000000000 +0100 | ||
11 | +++ lcdproc-0.5.5/server/drivers/Makefile.am 2012-02-26 14:13:17.764467350 +0100 | ||
12 | @@ -20,7 +20,8 @@ | ||
13 | |||
14 | ## Keep the lists sorted! | ||
15 | |||
16 | -pkglib_PROGRAMS = @DRIVERS@ | ||
17 | +my_execbindir = $(pkglibdir) | ||
18 | +my_execbin_PROGRAMS = @DRIVERS@ | ||
19 | EXTRA_PROGRAMS = bayrad CFontz CFontz633 CFontzPacket curses debug CwLnx ea65 EyeboxOne g15 glcdlib glk hd44780 icp_a106 imon imonlcd IOWarrior irman joy lb216 lcdm001 lcterm lirc lis MD8800 mdm166a ms6931 mtc_s16209x MtxOrb mx5000 NoritakeVFD picolcd pyramid sed1330 sed1520 serialPOS serialVFD shuttleVFD stv5730 SureElec svga t6963 text tyan sli ula200 xosd i2500vfd irtrans | ||
20 | noinst_LIBRARIES = libLCD.a libbignum.a | ||
21 | |||
diff --git a/meta-oe/recipes-extended/lcdproc/lcdproc5.inc b/meta-oe/recipes-extended/lcdproc/lcdproc5.inc new file mode 100644 index 000000000..50b6b0efb --- /dev/null +++ b/meta-oe/recipes-extended/lcdproc/lcdproc5.inc | |||
@@ -0,0 +1,77 @@ | |||
1 | DESCRIPTION = "LCDproc is a client/server suite to drive all kinds of LCD (-like) devices. The client \ | ||
2 | shipped with this package can be used to acquire various kinds of system stats." | ||
3 | SUMMARY = "Drivers for character-based LCD displays" | ||
4 | HOMEPAGE = "http://lcdproc.org" | ||
5 | SECTION = "utils" | ||
6 | LICENSE = "GPLv2+" | ||
7 | DEPENDS = "virtual/libusb0 ncurses" | ||
8 | |||
9 | LIC_FILES_CHKSUM = "file://COPYING;md5=18810669f13b87348459e611d31ab760 \ | ||
10 | file://README;startline=60;md5=8237b4d4d80a525b15f8162192e07bee" | ||
11 | |||
12 | SRC_URI = "${SOURCEFORGE_MIRROR}/lcdproc/${P}.tar.gz" | ||
13 | |||
14 | inherit autotools update-rc.d | ||
15 | |||
16 | LCD_DRIVERS ?= "all" | ||
17 | LCD_DEFAULT_DRIVER ?= "curses" | ||
18 | |||
19 | EXTRA_OECONF = "--enable-drivers=${LCD_DRIVERS} --enable-libusb" | ||
20 | |||
21 | do_install () { | ||
22 | # binaries | ||
23 | install -D -m 0755 server/LCDd ${D}${sbindir}/LCDd | ||
24 | install -D -m 0755 clients/lcdproc/lcdproc ${D}${bindir}/lcdproc | ||
25 | |||
26 | # init scripts | ||
27 | install -d ${D}${sysconfdir}/init.d | ||
28 | # so far, not fixed :-( and now even uglier :-(( | ||
29 | cat scripts/init-LCDd.debian | sed -e s'/--oknodo//' -e 's/ -s -f / -s 1 -f 1 /' -e 's/force-reload/force-restart/' -e 's/sleep 1/sleep 4/' > ${D}${sysconfdir}/init.d/lcdd | ||
30 | chmod 0755 ${D}${sysconfdir}/init.d/lcdd | ||
31 | install -m 0755 scripts/init-lcdproc.debian ${D}${sysconfdir}/init.d/lcdproc | ||
32 | sed -i s'/--oknodo//' ${D}${sysconfdir}/init.d/lcdproc | ||
33 | |||
34 | # configuration files | ||
35 | install -m 0644 LCDd.conf ${D}${sysconfdir}/LCDd.conf | ||
36 | sed -i 's!^DriverPath=.*!DriverPath=${libdir}/lcdproc/!' ${D}${sysconfdir}/LCDd.conf | ||
37 | sed -i 's!^Driver=.*!Driver=${LCD_DEFAULT_DRIVER}!' ${D}${sysconfdir}/LCDd.conf | ||
38 | install -m 0644 clients/lcdproc/lcdproc.conf ${D}${sysconfdir}/lcdproc.conf | ||
39 | |||
40 | # driver library files | ||
41 | install -d ${D}${libdir}/lcdproc | ||
42 | for i in server/drivers/*.so; do | ||
43 | install -m 0644 $i ${D}${libdir}/lcdproc/ | ||
44 | done | ||
45 | } | ||
46 | |||
47 | PACKAGES =+ "lcdd" | ||
48 | |||
49 | RRECOMMENDS_${PN} = "lcdd" | ||
50 | |||
51 | FILES_lcdd = "${sysconfdir}/LCDd.conf \ | ||
52 | ${sbindir}/LCDd \ | ||
53 | ${sysconfdir}/init.d/lcdd" | ||
54 | |||
55 | CONFFILES_lcdd = "${sysconfdir}/LCDd.conf" | ||
56 | CONFFILES_${PN} = "${sysconfdir}/lcdproc.conf" | ||
57 | |||
58 | # Driver packages | ||
59 | |||
60 | # USB / no USB trickery | ||
61 | |||
62 | RCONFLICTS_lcdd-driver-hd47780nousb = "lcdd-driver-hd44780" | ||
63 | RCONFLICTS_lcdd-driver-hd47780 = "lcdd-driver-hd44780nousb" | ||
64 | |||
65 | INITSCRIPT_PACKAGES = "lcdd lcdproc" | ||
66 | INITSCRIPT_NAME_lcdd = "lcdd" | ||
67 | INITSCRIPT_NAME_lcdproc = "lcdproc" | ||
68 | INITSCRIPT_PARAMS_lcdd = "defaults 70 21" | ||
69 | INITSCRIPT_PARAMS_lcdproc = "defaults 71 20" | ||
70 | |||
71 | python populate_packages_prepend() { | ||
72 | plugindir = d.expand('${libdir}/lcdproc') | ||
73 | do_split_packages(d, plugindir, '(.*)\.so$', 'lcdd-driver-%s', 'LCDd driver for %s', prepend=True) | ||
74 | } | ||
75 | |||
76 | PACKAGES_DYNAMIC = "lcdd-driver-*" | ||
77 | |||
diff --git a/meta-oe/recipes-extended/lcdproc/lcdproc_0.5.5.bb b/meta-oe/recipes-extended/lcdproc/lcdproc_0.5.5.bb new file mode 100644 index 000000000..0276c55a9 --- /dev/null +++ b/meta-oe/recipes-extended/lcdproc/lcdproc_0.5.5.bb | |||
@@ -0,0 +1,24 @@ | |||
1 | require lcdproc5.inc | ||
2 | |||
3 | SRC_URI += "file://automake-111-fix.patch" | ||
4 | |||
5 | SRC_URI[md5sum] = "c92d4529d36eeec6d9d6fd0a4aa3ec82" | ||
6 | SRC_URI[sha256sum] = "b136b47d7bf585a003334f432d8730a36ef5ed1cd520084b919667d825e48d42" | ||
7 | |||
8 | PACKAGECONFIG ?= "" | ||
9 | PACKAGECONFIG[g15] = ",,libg15 g15daemon libg15render," | ||
10 | |||
11 | LCD_DRIVERS_append = "${@base_contains('PACKAGECONFIG', 'g15', '', ',!g15', d)}" | ||
12 | |||
13 | do_install_append () { | ||
14 | # binaries | ||
15 | install -D -m 0755 clients/lcdvc/lcdvc ${D}${sbindir}/lcdvc | ||
16 | |||
17 | # configuration files | ||
18 | install -D -m 0644 clients/lcdvc/lcdvc.conf ${D}${sysconfdir}/lcdvc.conf | ||
19 | } | ||
20 | |||
21 | PACKAGES =+ "lcdvc" | ||
22 | CONFFILES_lcdvc = "${sysconfdir}/lcdvc.conf" | ||
23 | FILES_lcdvc = "${sysconfdir}/lcdvc.conf ${sbindir}/lcdvc" | ||
24 | |||