summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-11-21 12:00:54 +0100
committerKoen Kooi <koen@dominion.thruhere.net>2011-11-21 12:00:54 +0100
commitb006355af5ebe0e0465dd8412d918fa042bbda55 (patch)
treea6f9ce8d347d4519bd8deaef1006a3d5e55a801f /meta-oe/recipes-extended
parentfdbc6ae58b2bddb2ba7bac1cad61c8526a702cc2 (diff)
downloadmeta-openembedded-b006355af5ebe0e0465dd8412d918fa042bbda55.tar.gz
t1lib: add 5.1.2
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-extended')
-rw-r--r--meta-oe/recipes-extended/t1lib/t1lib-5.1.2/configure.patch128
-rw-r--r--meta-oe/recipes-extended/t1lib/t1lib-5.1.2/libtool.patch116
-rw-r--r--meta-oe/recipes-extended/t1lib/t1lib_5.1.2.bb31
3 files changed, 275 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/t1lib/t1lib-5.1.2/configure.patch b/meta-oe/recipes-extended/t1lib/t1lib-5.1.2/configure.patch
new file mode 100644
index 000000000..8b98707cd
--- /dev/null
+++ b/meta-oe/recipes-extended/t1lib/t1lib-5.1.2/configure.patch
@@ -0,0 +1,128 @@
1
2#
3# Patch managed by http://www.holgerschurig.de/patcher.html
4#
5
6--- t1lib-5.0.2/configure.in~configure.patch
7+++ t1lib-5.0.2/configure.in
8@@ -75,9 +75,9 @@
9 T1LIB_VERSIONSTRING=\"MACRO_T1LIB_IDENTIFIER\"
10
11
12-dnl We use this file by Andreas Zeller to check for libXaw
13-builtin(include, ac-tools/ice_find_athena.m4)
14-builtin(include, ac-tools/aclocal.m4)
15+#dnl We use this file by Andreas Zeller to check for libXaw
16+#builtin(include, ac-tools/ice_find_athena.m4)
17+#builtin(include, ac-tools/aclocal.m4)
18
19 dnl We want these before the checks, so the checks can modify their values.
20 test -z "$LDLIBS" && LDLIBS=-lm AC_SUBST(LDLIBS)
21@@ -161,6 +161,7 @@
22
23 dnl **** Check for underscore on external symbols ****
24
25+AH_TEMPLATE([NEED_UNDERSCORE_PREFIX], [Define if external symbols need an underscore prefix])
26 AC_CACHE_CHECK("whether external symbols need an underscore prefix",
27 ac_cv_c_extern_prefix,
28 [saved_libs=$LIBS
29@@ -178,68 +179,48 @@
30 AC_DEFINE(NEED_UNDERSCORE_PREFIX)
31 fi
32
33-dnl **** Check which ANSI integer type is 16 bit
34+dnl **** Check which ANSI integer type is 16 bit
35+T1_AA_TYPE16=""
36+for type in short int; do
37+ if test x"`eval echo \\$ac_cv_sizeof_$type`" = "x2"; then
38+ T1_AA_TYPE16="-DT1_AA_TYPE16=$type"
39+ T1_INT16="$type"
40+ break
41+ fi
42+done
43
44-AC_CACHE_CHECK( "which ANSI integer type is 16 bit", ac_16bit_type,
45- AC_TRY_RUN([
46-int main(void) {
47- if (sizeof(short)==2)
48- return(0);
49- else if (sizeof(int)==2)
50- return(1);
51- else
52- return(2);
53-}], ac_16bit_type="short", ac_16bit_type="int", ac_16bit_type=))
54-if test "$ac_16bit_type" = "short"
55-then
56- T1_AA_TYPE16="-DT1_AA_TYPE16=short"
57- T1_INT16="short"
58-else
59- T1_AA_TYPE16="-DT1_AA_TYPE16=int"
60- T1_INT16="int"
61+if test x"$T1_AA_TYPE16" = "x"; then
62+ AC_MSG_ERROR("Unable to determine which integer type is 16 bit.")
63 fi
64
65-
66 dnl **** Check which ANSI integer type is 32 bit
67+T1_AA_TYPE32=""
68+for type in int long; do
69+ if test x"`eval echo \\$ac_cv_sizeof_$type`" = "x4"; then
70+ T1_AA_TYPE32="-DT1_AA_TYPE32=$type"
71+ T1_INT32="$type"
72+ break
73+ fi
74+done
75
76-AC_CACHE_CHECK( "which ANSI integer type is 32 bit", ac_32bit_type,
77- AC_TRY_RUN([
78-int main(void) {
79- if (sizeof(int)==4)
80- return(0);
81- else if (sizeof(long)==4)
82- return(1);
83- else
84- return(2);
85-}], ac_32bit_type="int", ac_32bit_type="long", ac_32bit_type=))
86-if test "$ac_32bit_type" = "int"
87-then
88- T1_AA_TYPE32="-DT1_AA_TYPE32=int"
89- T1_INT32="int"
90-else
91- T1_AA_TYPE32="-DT1_AA_TYPE32=long"
92- T1_INT32="long"
93+if test x"$T1_AA_TYPE32" = "x"; then
94+ AC_MSG_ERROR("Unable to determine which integer type is 32 bit.")
95 fi
96
97-
98 dnl **** Check which ANSI integer type is 64 bit
99+T1_AA_TYPE64=""
100+for type in long long_long; do
101+ if test x"`eval echo \\$ac_cv_sizeof_$type`" = "x8"; then
102+ AC_MSG_WARN("$type is 64 bit")
103+ T1_AA_TYPE64="-DT1_AA_TYPE64=\"`echo $type|tr '_' ' '`\""
104+ break
105+ fi
106+done
107
108-AC_CACHE_CHECK( "which ANSI integer type is 64 bit", ac_64bit_type,
109- AC_TRY_RUN([
110-int main(void) {
111- if (sizeof(long)==8)
112- return(0);
113- else
114- return(1);
115-}], ac_64bit_type="long", ac_64bit_type="<none>"))
116-if test "$ac_64bit_type" = "long"
117-then
118- T1_AA_TYPE64="-DT1_AA_TYPE64=long"
119-else
120- T1_AA_TYPE64=
121+if test x"$T1_AA_TYPE64" = "x"; then
122+ AC_MSG_ERROR("Unable to determine which integer type is 64 bit.")
123 fi
124
125-
126 CFLAGS="${CFLAGS} -DT1LIB_IDENT=\"\\\"${T1LIB_IDENTIFIER}\\\"\" -DGLOBAL_CONFIG_DIR=\"\\\"${T1LIB_DATA_DIR}\\\"\""
127
128 dnl **** Check for functions and header files ****
diff --git a/meta-oe/recipes-extended/t1lib/t1lib-5.1.2/libtool.patch b/meta-oe/recipes-extended/t1lib/t1lib-5.1.2/libtool.patch
new file mode 100644
index 000000000..e05002573
--- /dev/null
+++ b/meta-oe/recipes-extended/t1lib/t1lib-5.1.2/libtool.patch
@@ -0,0 +1,116 @@
1
2#
3# Patch managed by http://www.holgerschurig.de/patcher.html
4#
5
6--- t1lib-5.0.2/Makefile.in~libtool
7+++ t1lib-5.0.2/Makefile.in
8@@ -18,7 +18,8 @@
9 # Last modified: 2001-04-01
10 #
11
12-SHELL = /bin/sh
13+SHELL = @SHELL@
14+LIBTOOL = @LIBTOOL@
15 CC = @CC@
16 CPP = @CPP@
17 CFLAGS = @CFLAGS@
18@@ -150,7 +151,7 @@
19 $(RM) examples/Makefile
20 $(RM) xglyph/Makefile
21 $(RM) doc/Makefile
22- $(RM) libtool
23+ $(RM) $(LIBTOOL)
24
25
26 # The following two targets are for building and cleaning the python-
27--- t1lib-5.0.2/examples/Makefile.in~libtool
28+++ t1lib-5.0.2/examples/Makefile.in
29@@ -14,9 +14,10 @@
30 # Last modified: 2001-04-01
31 #
32
33+top_builddir = @top_builddir@
34
35-LIBTOOL = ../libtool
36-SHELL = /bin/sh
37+LIBTOOL = @LIBTOOL@
38+SHELL = @SHELL@
39 CC = @CC@
40 CPP = @CPP@
41 CFLAGS = @CFLAGS@
42--- t1lib-5.0.2/lib/Makefile.in~libtool
43+++ t1lib-5.0.2/lib/Makefile.in
44@@ -15,8 +15,10 @@
45 #
46 # Contributions by H.Kakugawa to use libtool!
47
48-LIBTOOL = ../libtool
49-SHELL = /bin/sh
50+top_builddir = @top_builddir@
51+
52+LIBTOOL = @LIBTOOL@
53+SHELL = @SHELL@
54 CC = @CC@
55 CPP = @CPP@
56 CFLAGS = @CFLAGS@
57--- t1lib-5.0.2/lib/t1lib/Makefile.in~libtool
58+++ t1lib-5.0.2/lib/t1lib/Makefile.in
59@@ -14,8 +14,10 @@
60 #
61 # Modified by H.Kakugawa to use libtool
62
63-LIBTOOL = ../../libtool
64-SHELL = /bin/sh
65+top_builddir = @top_builddir@
66+
67+LIBTOOL = @LIBTOOL@
68+SHELL = @SHELL@
69 CC = @CC@
70 CPP = @CPP@
71 CFLAGS = @CFLAGS@
72--- t1lib-5.0.2/lib/type1/Makefile.in~libtool
73+++ t1lib-5.0.2/lib/type1/Makefile.in
74@@ -14,8 +14,10 @@
75 #
76 # Modified by H.Kakugawa to use libtool
77
78-LIBTOOL = ../../libtool
79-SHELL = /bin/sh
80+top_builddir = @top_builddir@
81+
82+LIBTOOL = @LIBTOOL@
83+SHELL = @SHELL@
84 CC = @CC@
85 CPP = @CPP@
86 CFLAGS = @CFLAGS@
87--- t1lib-5.0.2/type1afm/Makefile.in~libtool
88+++ t1lib-5.0.2/type1afm/Makefile.in
89@@ -15,8 +15,10 @@
90 #
91 # Modified by H.Kakugawa to use libtool
92
93-LIBTOOL = ../libtool
94-SHELL = /bin/sh
95+top_builddir = @top_builddir@
96+
97+LIBTOOL = @LIBTOOL@
98+SHELL = @SHELL@
99 CC = @CC@
100 CPP = @CPP@
101 CFLAGS = @CFLAGS@
102--- t1lib-5.0.2/xglyph/Makefile.in~libtool
103+++ t1lib-5.0.2/xglyph/Makefile.in
104@@ -15,8 +15,10 @@
105 #
106 # Modified by H.Kakugawa to use libtool
107
108-LIBTOOL = ../libtool
109-SHELL = /bin/sh
110+top_builddir = @top_builddir@
111+
112+LIBTOOL = @LIBTOOL@
113+SHELL = @SHELL@
114 CC = @CC@
115 CPP = @CPP@
116 CFLAGS = @CFLAGS@
diff --git a/meta-oe/recipes-extended/t1lib/t1lib_5.1.2.bb b/meta-oe/recipes-extended/t1lib/t1lib_5.1.2.bb
new file mode 100644
index 000000000..f905c9d63
--- /dev/null
+++ b/meta-oe/recipes-extended/t1lib/t1lib_5.1.2.bb
@@ -0,0 +1,31 @@
1DESCRIPTION = "A Type1 Font Rastering Library"
2SECTION = "libs"
3DEPENDS = "virtual/libx11 libxaw"
4
5LICENSE = "LGPLv2 GPLv2"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=8ca43cbc842c2336e835926c2166c28b \
7 file://LGPL;md5=6e29c688d912da12b66b73e32b03d812 \
8"
9
10SRC_URI = "${DEBIAN_MIRROR}/main/t/t1lib/t1lib_${PV}.orig.tar.gz \
11 file://configure.patch \
12 file://libtool.patch"
13SRC_URI[md5sum] = "a5629b56b93134377718009df1435f3c"
14SRC_URI[sha256sum] = "821328b5054f7890a0d0cd2f52825270705df3641dbd476d58d17e56ed957b59"
15
16inherit autotools
17
18# Fix GNU_HASH problem
19TARGET_CC_ARCH += "${LDFLAGS}"
20
21EXTRA_OECONF = "--with-x --without-athena"
22EXTRA_OEMAKE = "without_doc"
23
24do_configure() {
25 rm -f ${S}/ac-tools/aclocal.m4
26 autotools_do_configure
27}
28
29FILES_${PN} += " ${datadir}/t1lib/t1lib.config"
30FILES_${PN}-doc = "${datadir}/t1lib/doc/t1lib_doc.pdf"
31