summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2012-03-09 10:13:55 +0000
committerKhem Raj <raj.khem@gmail.com>2012-03-11 10:10:38 -0700
commite0023c5a6eccdb20e0ecf892fcb5ecc7743b3b0b (patch)
treeae02cd0eb579968209660221114c9b7316e3d3e3 /meta-oe/recipes-extended
parent5b45051bca0746832ad988323eed799fa81f01a9 (diff)
downloadmeta-openembedded-e0023c5a6eccdb20e0ecf892fcb5ecc7743b3b0b.tar.gz
lighttpd: inherit systemd / remove unneded systemd code
Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended')
-rw-r--r--meta-oe/recipes-extended/lighttpd/lighttpd_1.4.30.bbappend16
1 files changed, 5 insertions, 11 deletions
diff --git a/meta-oe/recipes-extended/lighttpd/lighttpd_1.4.30.bbappend b/meta-oe/recipes-extended/lighttpd/lighttpd_1.4.30.bbappend
index b914405b7..5449b1a26 100644
--- a/meta-oe/recipes-extended/lighttpd/lighttpd_1.4.30.bbappend
+++ b/meta-oe/recipes-extended/lighttpd/lighttpd_1.4.30.bbappend
@@ -1,16 +1,10 @@
1FILESEXTRAPATHS := "${THISDIR}/${PN}" 1FILESEXTRAPATHS := "${THISDIR}/${PN}"
2 2
3PRINC = "1" 3PRINC = "2"
4 4
5SRC_URI += "file://lighttpd.service" 5inherit systemd
6
7do_install_append() {
8 install -d ${D}${base_libdir}/systemd/systemd/
9 install -m 0644 ${WORKDIR}/lighttpd.service ${D}${base_libdir}/systemd/systemd/
10 6
11 install -d ${D}${base_libdir}/systemd/systemd/multi-user.target.wants 7SRC_URI += "file://lighttpd.service"
12 ln -sf ../lighttpd.service ${D}${base_libdir}/systemd/systemd/multi-user.target.wants
13}
14
15FILES_${PN} += "${base_libdir}/systemd"
16 8
9SYSTEMD_PACKAGES = "${PN}"
10SYSTEMD_SERVICE_${PN} = "lighttpd.service"