summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/zsh
diff options
context:
space:
mode:
authorMartin Ertsaas <mertsas@cisco.com>2012-09-20 07:01:44 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2012-09-24 10:01:24 +0200
commit4cfe58d3ce694ee2951a0ed0e855c6e4dbca2dc2 (patch)
treed8327e5749451df8254528416bc72a0a727387f6 /meta-oe/recipes-extended/zsh
parentc988ce5518967d3acd0edd5d71a44963f08dae7a (diff)
downloadmeta-openembedded-4cfe58d3ce694ee2951a0ed0e855c6e4dbca2dc2.tar.gz
zsh: Change from 4.3.17 to 5.0.0, which is the latest stable release. Also change the mirror from the zsh ftp server, which is really slow and unstable, to a sourceforce mirror.
The reason for removing the 4.3.17 recipe is that it used the ftp mirror, which has removed the 4.3.17 tarbal used. Signed-off-by: Martin Ertsaas <mertsas@cisco.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-extended/zsh')
-rw-r--r--meta-oe/recipes-extended/zsh/zsh.inc (renamed from meta-oe/recipes-extended/zsh/zsh_4.3.17.bb)46
-rw-r--r--meta-oe/recipes-extended/zsh/zsh_5.0.0.bb5
2 files changed, 30 insertions, 21 deletions
diff --git a/meta-oe/recipes-extended/zsh/zsh_4.3.17.bb b/meta-oe/recipes-extended/zsh/zsh.inc
index 9192f2083..cacce9140 100644
--- a/meta-oe/recipes-extended/zsh/zsh_4.3.17.bb
+++ b/meta-oe/recipes-extended/zsh/zsh.inc
@@ -2,50 +2,54 @@ DESCRIPTION = "UNIX Shell similar to the Korn shell"
2HOMEPAGE="http://www.zsh.org" 2HOMEPAGE="http://www.zsh.org"
3SECTION = "base/shell" 3SECTION = "base/shell"
4 4
5PR = "r0"
6
5LICENSE = "ZSH" 7LICENSE = "ZSH"
6LIC_FILES_CHKSUM = "file://LICENCE;md5=ad234d4b46db63491c4a9789da4fb341" 8LIC_FILES_CHKSUM = "file://LICENCE;md5=ad234d4b46db63491c4a9789da4fb341"
7 9
8DEPENDS = "ncurses libcap libpcre gdbm groff-native" 10DEPENDS = "ncurses bison-native"
9 11
10SRC_URI = "ftp://ftp.zsh.org/pub/${P}.tar.bz2" 12SRC_URI = "http://downloads.sourceforge.net/project/${BPN}/${BPN}/${PV}/${BPN}-${PV}.tar.gz"
11SRC_URI[md5sum] = "8258967060b2654f30001a011946ac6a"
12SRC_URI[sha256sum] = "054e0452afd9c742c9f1489465175e1d4d7db50d88b602d132551d850cf7a704"
13 13
14FILES_${PN}-dbg += "\ 14inherit autotools gettext update-alternatives
15 ${libdir}/${PN}/${PV}/${PN}/.debug/*.so \
16 ${libdir}/${PN}/${PV}/${PN}/db/.debug/*.so \
17 ${libdir}/${PN}/${PV}/${PN}/net/.debug/*.so \
18 "
19
20inherit autotools
21 15
22EXTRA_OECONF = " \ 16EXTRA_OECONF = " \
23 --bindir=${base_bindir} \ 17 --bindir=${base_bindir} \
24 --enable-etcdir=${sysconfdir} \ 18 --enable-etcdir=${sysconfdir} \
25 --enable-fndir=${datadir}/${PN}/${PV}/functions \ 19 --enable-fndir=${datadir}/${PN}/${PV}/functions \
26 --enable-site-fndir=${datadir}/${PN}/site-functions \ 20 --enable-site-fndir=${datadir}/${PN}/site-functions \
27 --enable-function-subdirs \
28 --with-term-lib='ncursesw ncurses' \ 21 --with-term-lib='ncursesw ncurses' \
29 --with-tcsetpgrp \ 22 --with-tcsetpgrp \
30 --enable-pcre \
31 --enable-cap \ 23 --enable-cap \
32 --enable-multibyte \ 24 --enable-multibyte \
33 --enable-gdbm \ 25 --disable-gdbm \
34 --enable-dynamic \ 26 --disable-dynamic \
35 zsh_cv_shared_environ=yes \ 27 zsh_cv_shared_environ=yes \
36 " 28 "
37 29
30ALTERNATIVE_${PN} = "sh"
31ALTERNATIVE_LINK_NAME[sh] = "${base_bindir}/sh"
32ALTERNATIVE_TARGET[sh] = "${base_bindir}/${BPN}"
33ALTERNATIVE_PRIORITY = "100"
34
35export AUTOHEADER = "true"
36
38do_configure () { 37do_configure () {
39 oe_runconf 38 oe_runconf
40} 39}
41 40
41do_install_append () {
42 rm -fr ${D}/usr/share
43}
44
42pkg_postinst_${PN} () { 45pkg_postinst_${PN} () {
43 touch $D${sysconfdir}/shells 46 touch $D${sysconfdir}/shells
44 grep -q "bin/zsh" $D${sysconfdir}/shells || echo "/bin/zsh" >> $D${sysconfdir}/shells 47 grep -q "bin/zsh" $D${sysconfdir}/shells || echo /bin/zsh >> $D${sysconfdir}/shells
48 grep -q "bin/sh" $D${sysconfdir}/shells || echo /bin/sh >> $D${sysconfdir}/shells
45} 49}
46 50
47pkg_postrm_${PN} () { 51FILES_${PN}-dbg += "\
48 if [ -e $D${sysconfdir}/shells ]; then 52 ${libdir}/${PN}/${PV}/${PN}/.debug/*.so \
49 sed -i -e '/\/bin\/zsh/d' $D${sysconfdir}/shells 53 ${libdir}/${PN}/${PV}/${PN}/db/.debug/*.so \
50 fi 54 ${libdir}/${PN}/${PV}/${PN}/net/.debug/*.so \
51} 55 "
diff --git a/meta-oe/recipes-extended/zsh/zsh_5.0.0.bb b/meta-oe/recipes-extended/zsh/zsh_5.0.0.bb
new file mode 100644
index 000000000..3421d950c
--- /dev/null
+++ b/meta-oe/recipes-extended/zsh/zsh_5.0.0.bb
@@ -0,0 +1,5 @@
1require zsh.inc
2DEPENDS = "ncurses libcap libpcre gdbm groff-native"
3
4SRC_URI[md5sum] = "01df38e4aa34aa227462fdf2f6d4c5cd"
5SRC_URI[sha256sum] = "835194ea83abd812b5fdb1d2bfa6427c4c4e95e771c4a75e9006037af8efd264"